Jump to content

installed Lion... some trouble ! Should I buy new parts ?


  • Please log in to reply
12 replies to this topic

#1
vjuluss

vjuluss

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi guys

I tried to install Lion on my computer. Here is the config :

- H61M-HVS motherboard
- Core i3 2120
- Sapphire Radeon 6850
- 2 x 4 Go Crucial Ballistix
- Asus PCE-N13 Wireless Card

So, the installation was easy and fast. I used a tool to make the bootable stick with my Macbook.
The computer booted on the stick, clic, clic, clic and it's done !
The first boot was fine too.

But, after that, lot of problem.


My Wireless card : I tried some kext for ralink 2860 but they don't work. So, I guess I should change this part ?
Video card : I tried to install some kext for ATI 6850 but they don't work : after the reboot, I got nothing
Network : I tried compatible driver for RTL81xxx : does not work.


So, what should I do ?
Buying some news parts ? Like a motherboard and a Wireless card ? In fact, if buying news parts give me a fully fonctionnal computer with Mac OS X, I will do it.

Thanks :)

#2
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 869 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackintosh&Ap...
Should honor more for Hackintosh,dont need new parts,only good site like this... :thumbsup_anim:
for best drivers(kext)see here:
http://www.osx86.net/
ATI 6850 is here
RTL is here
Ralink is here
Good Hack....

#3
rockinron_1

rockinron_1

    InsanelyMac Sage

  • FAQ Team
  • 394 posts
  • Gender:Male
  • Location:UK
Combatible wireless card would be a good idea, see the wiki for supported cards.

The sapphire radeon 6850 will work OOB straight away with Lion. If it doesn't the installer your using is screwing up OS X somehow.

If the kext doesn't work then your clearly not using a compatible one, do some research (use the right kext) any you'll get the rtl kext working.

#4
vjuluss

vjuluss

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Should honor more for Hackintosh,dont need new parts,only good site like this... :thumbsup_anim:
for best drivers(kext)see here:
http://www.osx86.net/
ATI 6850 is here
RTL is here
Ralink is here
Good Hack....


I will search on this website, thanks.

Combatible wireless card would be a good idea, see the wiki for supported cards.

The sapphire radeon 6850 will work OOB straight away with Lion. If it doesn't the installer your using is screwing up OS X somehow.

If the kext doesn't work then your clearly not using a compatible one, do some research (use the right kext) any you'll get the rtl kext working.


Yea I thinks I will buy a new wireless card, I want to use Apple Wireless Utility to connect on the wireless.

The Sapphire is working, but OS X shows "ATI Radeon HD 6xxx 1024 MB". Is this good ? Or it should be "ATI Radeon HD 6850 1024 MB" ?

May the motherboard in cause ?

The installer I used was ###### Wich one would you suggest instead of this one ?

Edit: whoops it seems I can't tell the name of the installer here....

#5
vjuluss

vjuluss

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi

I got more informations :

No way to get wired or wireless network. I tried a lot of kext but no one worked. My chipsets are :
- RTL8101E/RTL8102E for wired
- Ralink RT2790 for wireless

I did not even try audio, because I have a USB sound card, wich is better than audio on motherboard.

I tried to update to 10.7.4 with the ComboUpdate, it worked fine.

And no boot from hard drive, I use the USB stick to boot :

#6
TheRacerMaster

TheRacerMaster

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
Try booting with GraphicsEnabler=Yes and it should correctly identify your card. The network should work with Lnx2Mac's Realtek ethernet driver. http://lnx2mac.blogs...osx-driver.html There are drivers available for your WiFi card, but they are for Leopard...so they most likely won't work. http://www.ralinktec...port.php?sn=502 Good luck with your hackintosh.

#7
vjuluss

vjuluss

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi ! Thanks for your answer.

I already tried the "GraphicsEnabler" option and it didn't work. I use the USB stick as bootloader, so I added the option in the boot file on the USB stick and on the hard drive.

I tried drivers for ehternet card and it did not work :(



#8
JamesLittler

JamesLittler

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,022 posts
  • Gender:Male
  • Location:Portsmouth, England
If you're booting from your USB you will get kext conflicts using RealtekRTL81xx.
Install Chameleon to your HDD, use Chameleon Wizard to generate your smbios.plist and org.chameleon.Boot.plist.
Place only the kexts you need in S/L/E.

#9
rockinron_1

rockinron_1

    InsanelyMac Sage

  • FAQ Team
  • 394 posts
  • Gender:Male
  • Location:UK

The Sapphire is working, but OS X shows "ATI Radeon HD 6xxx 1024 MB". Is this good ? Or it should be "ATI Radeon HD 6850 1024 MB" ?


This isn't actually a problem. Chances are you've got QI / CE graphics working fine with it displaying ati6xxx rather than hd6850 (mine works perfect either way I have it set) and its just cosmetic.

If you want it to display hd6850 then set use ati rom = yes and graphics enabler = yes. You can use chameleon wizard to facilitate setting these options. Also I have used the *beast stuff a while back and for reasons I won't bore you with you shouldn't be booting from the USB, you should have chameleon installed to your HDD

Of course I would recommend my own guide which will teach you a little about how hackintoshing works and will give you a better setup than trying to bodge *beast to work:
http://www.insanelym...l=&fromsearch=1

#10
vjuluss

vjuluss

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

If you're booting from your USB you will get kext conflicts using RealtekRTL81xx.
Install Chameleon to your HDD, use Chameleon Wizard to generate your smbios.plist and org.chameleon.Boot.plist.
Place only the kexts you need in S/L/E.


This isn't actually a problem. Chances are you've got QI / CE graphics working fine with it displaying ati6xxx rather than hd6850 (mine works perfect either way I have it set) and its just cosmetic.

If you want it to display hd6850 then set use ati rom = yes and graphics enabler = yes. You can use chameleon wizard to facilitate setting these options. Also I have used the *beast stuff a while back and for reasons I won't bore you with you shouldn't be booting from the USB, you should have chameleon installed to your HDD

Of course I would recommend my own guide which will teach you a little about how hackintoshing works and will give you a better setup than trying to bodge *beast to work:
http://www.insanelym...l=&fromsearch=1


So I tried to install Chameleon, but I got kernel panic on boot. I guess I did something wrong but what ? I don't know wich version I should use. I will try again, and if it does not work, I will reinstall the system. Maybe I tried too much kext.

About the video card, if it's just comestic, it's a good news.

So let's try again !

#11
rockinron_1

rockinron_1

    InsanelyMac Sage

  • FAQ Team
  • 394 posts
  • Gender:Male
  • Location:UK
Show us a picture of that kernel panic and chances are I can help you.
Having said that I recommend reinstalling vanilla rather than using *beast anyway

#12
vjuluss

vjuluss

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi

I restarted the entire process from the beginning.

  • Installed Lion with *beast
  • Installed Chameleon to get boot from hard drive. At this point I got kernel panic on boot.
  • Tried an older version : same problem
  • Installed easy beast (wich is based on chameleon) to get boot from hard drive : I got the boot, with OSX boot screen ! But after, the scren stay black. So I added "GraphicsEnabler=No" on org.chameleon.boot.plist : Boot ok !
  • Installed drivers for wired network : no effect.
  • Installed drivers for wireless network : no effect.

I didn't try yet audio, cause I will use my USB sound card.

Show us a picture of that kernel panic and chances are I can help you.
Having said that I recommend reinstalling vanilla rather than using *beast anyway


I will post tonight a sreenshot of "About this Mac" for video card, and network. I guess it will help you to help me.

What do you mean by "Reinstalling Vanilla" ?

I'am also thinking to a new motherboard, to get everything working perfectly, like a real mac :o.

Thanks

#13
rockinron_1

rockinron_1

    InsanelyMac Sage

  • FAQ Team
  • 394 posts
  • Gender:Male
  • Location:UK
Vanilla method:
http://www.insanelym...l=&fromsearch=1

Wifi cards are dirt cheap - you may as well get a combatible one, as I said see the wiki.

*beast stuff isn't supported on this forum so I suggest if you wish to continue installing that way you go to tony's forum





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy