Jump to content

Asus P5K-E Wifi (Socket 775) Installation Guide for Mountain Lion


  • Please log in to reply
10 replies to this topic

#1
Tuen

Tuen

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
More information can be found on my blog:
http://blog.vondroid.com/?p=2631

Lan, Sound, Sleep tested and work.
Also it works on my NVidia 8800 GTS 320MB only apply EFI-String
Flash browsing in Safari works with that Graphic card without problem.

#2
St2333

St2333

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

More information can be found on my blog:
http://blog.vondroid.com/?p=2631

Lan, Sound, Sleep tested and work.
Also it works on my NVidia 8800 GTS 320MB only apply EFI-String
Flash browsing in Safari works with that Graphic card without problem.


Did you have to do anything besides use the included kext for your ethernet?

I can't seem to get the right combination of DSDT/audio/ethernet for everything to work correctly.

#3
Tuen

Tuen

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Did you have to do anything besides use the included kext for your ethernet?

I can't seem to get the right combination of DSDT/audio/ethernet for everything to work correctly.


There is a modified kext file for ethernet.
For audio you need follow the blog: after install OSX you need to install AppleHDA.kext to fix the audio (also need it for future update)

#4
St2333

St2333

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

There is a modified kext file for ethernet.
For audio you need follow the blog: after install OSX you need to install AppleHDA.kext to fix the audio (also need it for future update)


I've tried using your attached Marvell 88E8056.kext and modifying the Info.plist of IONetworking.kext (this was what worked for me previously in SL and Lion), but neither of these work for me now on Mountain Lion.

I've got most everything working, except ethernet is the big one that doesn't. The weird thing is, the Marvell 88E8056.kext worked fine for my ethernet using my SL DSDT, but I couldn't get ICH9 patched (for DVD eject) in my DSDT (gave me a bunch of errors that I didn't know how to fix). Using your DSDT, the ICH9 DVD patch works (can eject with holding down F12), but I can't boot the system with the 88E8056 kext.

Any ideas?

#5
Tuen

Tuen

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

I've tried using your attached Marvell 88E8056.kext and modifying the Info.plist of IONetworking.kext (this was what worked for me previously in SL and Lion), but neither of these work for me now on Mountain Lion.

I've got most everything working, except ethernet is the big one that doesn't. The weird thing is, the Marvell 88E8056.kext worked fine for my ethernet using my SL DSDT, but I couldn't get ICH9 patched (for DVD eject) in my DSDT (gave me a bunch of errors that I didn't know how to fix). Using your DSDT, the ICH9 DVD patch works (can eject with holding down F12), but I can't boot the system with the 88E8056 kext.

Any ideas?


You have the same board?
you have follow the whole tutorial on the blog?
Use the same files from my blog?
using the same bootloader as described?

#6
St2333

St2333

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

You have the same board?
you have follow the whole tutorial on the blog?
Use the same files from my blog?
using the same bootloader as described?


Yes, I have the exact same P5K-E / Wifi-AP board. Yes, I followed the whole tutorial with the same files. I modified it only slightly (such as not copying .disk_Label, .Disk_Label_2x, Boot.efi, Kernelcache) in comparison with the Vanilla install thread that's usually on the first page of this sub-forum. Using Chameleon-2.1svn-r2030. So a few things are different (I don't think they would be the culprit, but I didn't want to start fresh all over).

In any event, I've got everything working except for SpeedStep finally. There must've been something wrong with the DSDT I was using. Both my unpatched DSDT (extracted from Windows) and your DSDT, Tuen, gave me one error and lots of warnings when compiling. My Lion DSDT, however, compiled fine straight from Lion and after patching it.

I can't attach my DSDT (Note: My DSDT is built for the P5K-E / Wifi-AP with 4 GB of RAM!) and audio kexts (probably due to number of posts?), but in case anyone needs them, PM me with an e-mail address to send them to.

Tuen (or anyone else), is there a way for me to check if SpeedStep is working in Terminal or through some program? I didn't notice anything new booting in -v with Tuen's IntelCPU kext.

#7
St2333

St2333

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Just kidding, here they are (DSDT + audio kexts):

Attached Files



#8
kenkenc

kenkenc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:Vancouver
Did any of you get the WIFI working, I had it working in a previous version of Lion.. Can't find the Reltek software or kext anymore

#9
kenkenc

kenkenc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:Vancouver
Got 10.8 working with your blog

Still can't get the video to work fully with QE/QC

do you think I need to do the efi string?

#10
deaftolight

deaftolight

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
No matter what I do, I can't get the sleep working? I'm afraid to use a DSDT because I can't seem to find one easily enough... it seems like the few I see mentioned when I google P5K-E DSDT have really customized versions and I'm pretty new to this, so I don't wanna start throwing in wrong DSDTs if I don't have to.

I have a Sapphire Radeon HD7770 GHz edition, and putting the computer to sleep seems to be the only way to get this card to work.

I boot to a white screen with a movable cursor. When I press the power button, nothing happens. If I come back after a few minutes, the monitor is off, but the computer and fans are still on... Moving the mouse or hitting the keybaord just brings me back to the white screen.

#11
deaftolight

deaftolight

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
got it working by extracting my own dsdt and patching it with olarilas p5k wifi ap.txt

only problem now is i cna't get audio to work! tuen's appleHDA doesnt work for me, neither does voodooHDA





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy