Jump to content

IOAHCIBlockStorage Driver Could Not Recover SATA HDD


  • Please log in to reply
2 replies to this topic

#1
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 502 posts
  • Gender:Male
  • Location:Southern California
I am making progress getting an ML USB Installation Disk to boot up on my Dell Inspiron 1720. However, I have encountered the error "IOAHCIBlockStorage Driver Could Not Recover SATA HDD after 5 attempts, terminating." I have tried using the IOAHCIBlockStorageInjector.kext and have tried using the IOAHCIFamily.kext from Lion and neither have solved this problem. It occurs after the boot disk has been found, the ram disks are created and DSMOS has arrived. Any ideas? Thanks.

Posted Image

#2
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 502 posts
  • Gender:Male
  • Location:Southern California
I got this error to go away by using the boot flag "max_valid_dma_addr=1024." However, it is still hanging, and I suspect it is the same issue as the "DSMOS has arrived" issue - graphics not loading. I have the X3100 GPU and am trying to combine the installation files for OSx86 along with the files from macrumors used to install ML on an unsupported mac with X3100.

#3
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
i think if available, installing to hard drive using a supported mac(or maybe hack), then making your GPU hacks and move it to old mac to use it to boot would be easier





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy