Jump to content

Lion sur P5Q SE et ATI 4870


  • Please log in to reply
14 replies to this topic

#1
Naced28

Naced28

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Salut à tous
Je tiens à préciser que cela fait un moment que je n'ai pas refait de hackintosh.

J'avais fait il y a 3ans un Leo4all / iDeneb (les 2 fonctionnaient) sur mon PC actuel:
  • Asus P5Q SE Rev 1.xx
  • Intel QuadCore Q9650 3.0 Ghz
  • 4 x 2Go DDR2 G.Skill 6400 (400 Mhz)
  • ATI Radeon HD 4870 (1024 Mo)

J'ai depuis acheté un MacBook Fin 2009 (actuellement sous Lion 10.7.4)


Et donc je suis ici car je voulais depuis Mettre Lion sur mon PC.

Voici mes tentatives:

J'ai essayer iATKOS L2 avec ce tuto: TuTo Iatkos L2 Gigabyte P35 DS3P
Ayant une ATI javais activé les Kext ATI et non Nvidia.
J'ai eu un Kernel panic au premier redémarrage

J'ai essayer ce tuto: Installation Lion 10.7.4 64bits avec USB bootable
Au premier boot sur la clé USB, chargement du logo de la pomme puis écran noir. Donc je ne peux même pas faire l'installation.

Là je voulais testé: Lion installation via USB stick using Chameleon
Mais je suis bloquer dès le départ vu que Extra Lion DP4.pkg ne me propose pas de choisir l'emplacement où l'installer et veux le faire sur mon vrai Mac :(

Que faire? ^^

Merci d'avance pour votre aide

#2
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,720 posts
  • Gender:Male
salut anthony ! :D

pour ta config, elle devrait passer sans trop de souci si tu te bases sur une installation Retail !

Mets ta clé usb dans ton MacBook et crée une partition Mac OS étendu (journalisée) sur la totalité de ta clé usb et en GUID. Ensuite restaure le DVD de Lion sur ta clé usb en te basant sur le tuto suscité. Installe chameleon dessus (je préfère pcefi 10.6 Lion+Snow), fais que ton com.apple.Boot.plist ou org.chameleon.Boot.plist ne comporte que le stricte minimum, dans ton dossier Extra mets uniquement FakeSMC.kext, trouves-toi un dsdt.aml pour ta carte mère et un smbios.plist qui convient le mieux pour ta config !!!

Regarde dans le bios de ta carte mère si tu as l'option AHCI, si oui, qu'elle soit sur Enabled. Ou bien Sata mode, sur AHCI !!!

Avec ça, ton installe doit se dérouler sans problème !!!

Pour la suite, on verra après l'install réussie !!! ;)

#3
Naced28

Naced28

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Pour l'AHCI j'avai déjà ;)

Sinon j'ai un Bios qui correspond a ma carte fait par Juzzi. Je sais qu'il fonctionne vu que j'l'avais utiliser lors de Leo4all
(Bon si j'peux éviter de le remettre tant mieu mais bon sinon j'le ferai)
  • Je sais pas où mettre les fichiers DSDT.aml et smbios.plist ?
  • Pour le DSDT j'ai trouvé celui ci: DSDT P5QE SE Rev1 mais il es précisé qu'il ne fonctionne pas avec Lion es-ce vrai?
Pour le SMBios j'ai pris un tout simple:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosdate</key>
<string>02/29/08</string>
<key>SMbiosversion</key>
<string>MP31.88Z.006C.B05.0802291410</string>
<key>SMboardproduct</key>
<string>Mac-F221BEC8</string>
<key>SMfamily</key>
<string>MacPro</string>
<key>SMmanufacter</key>
<string>Apple Inc.</string>
<key>SMproductname</key>
<string>MacPro3,1</string>
<key>SMserial</key>
<string>G88014V4XYK</string>
</dict>
</plist>
  • Es-ce qu'il devrai être plus complet?
Sinon com.apple.Boot.plist

ou

org.chameleon.Boot.plist j'le trouve nul part pourtant j'ai installer le

pcefi 10.6



En tout cas merci de m'aider c'est cool :D



#4
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,720 posts
  • Gender:Male
ok, donc si tu as installé pcefi 10.6, tu auras un dossier nommé Extra sur la racine de ta clé usb !!! Tu n'auras qu'un dossier nommé Themes dedans, c'est ensuite à toi de mettre ton smbios.plist et com.apple.Boot.plist, ainsi que ton dsdt.aml !!!!

Dans ce dossier Extra, tu peux créer aussi un autre dossier nommé Extensions et y mettre ton FakeSMC.kext ou carrément mettre FAkeSMC.kext dans /System/Library/Extensions

N'oublie pas de réparer les permissions de ta clé usb !!


oui, laisse ton smbios.plist comme tel pour l'instant, inutile d'ajouter autre chose, tu pourras le faire (si tu le veux) plus tard, disons que c'est plus esthétique qu'autre chose !

#5
Naced28

Naced28

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • ATY_Init.kext
  • Darwinx86-ATI48X0-IDs-Injector.kext
  • EVOenabler.kext
  • FakeSMC.kext
  • AttansicL1eEthernet.kext
  • OpenHaltRestart.kext
  • VoodooHDA.kext
  • IOAHCIBlockStorageInjector.kext
  • NullCPUPowerManagement.kext

Voila ce que j'ai récupéré des pack P5Q SE1 et 4870 sur divers site internet

Le problème c'est que j'ai l'impression que je sais pas où les mettres enfaites
J'ai testé toute la soirée...
J'obtien toujours le même soucis mon écran ne voit pas l'entrée vidéo "Input not supported'
avec des boot -v pour savoir mais rien de colorer alors j'sais pas si ya des soucis...
-x mais ca change rien
et quand j'met -v-x il ne fait que -x

#6
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,720 posts
  • Gender:Male
et pourtant je t'ai dit que dans un premier temps il faut mettre un strict minimum !! :wallbash: ^_^

là, tu as mis carrément 2 injecteurs pour carte vidéo: :laser:
  • ATY_Init.kext
  • Darwinx86-ATI48X0-IDs-Injector.kext
et là tu mets un kext pour le problème de redémarrage/arrêt (OpenHaltRestart.kext) et aussi son remplaçant (EVOenabler.kext) :tomato:

ne te préoccupes pas de ta carte graphique pour le moment, ni pour le son, ni pour ethernet !!!

le but c'est de faire l'install avec le moins possible de bidouillage !!!

donc, une restauration propre du DVD de Lion sur ta clé usb, install dessus pcefi 10.6 lion+snow, mets FakeSMC dans S/L/E et répare les permissions !!!

mets ton com.apple.Boot.plist et smbios.plist dans le dossier Extra ainsi que ton dsdt.aml

voici l'exemple de com.apple.Boot.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>DSDT</key>
<string>/Extra/dsdt.aml</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1280x1024x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>SMBIOS</key>
<string>/Extra/smbios.plist</string>
<key>Theme</key>
<string>Default</string>
<key>Timeout</key>
<string>1</string>
<key>UseKernelCache</key>
<string>Yes</string>
</dict>
</plist>



et pour smbios.plist :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosdate</key>
<string>09/03/09</string>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>IM101.88Z.00CC.B00.0909031926</string>
<key>SMboardmanufacter</key>
<string>Apple Inc.</string>
<key>SMboardproduct</key>
<string>Mac-F2268CC8</string>
<key>SMfamily</key>
<string>iMac</string>
<key>SMmanufacter</key>
<string>Apple Inc.</string>
<key>SMmanufacturer</key>
<string>Apple Inc.</string>
<key>SMproductname</key>
<string>iMac10,1</string>
<key>SMserial</key>
<string>CK0106PDB9U</string>
<key>SMsystemversion</key>
<string>1.0</string>
</dict>
</plist>


#7
Naced28

Naced28

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
J'ai essayer une install simple comme ce que tu décrit j'ai eu un écran noir donc j'ai chercher des kext pour ma carte et comme je sais pas ce qui marche :(

j'vais retest avec tes plist.

Autre chose j'utiliser la méthode avec le BaseSystem + remettre le Dossier Package mais j'crois que j'vais prendre directement l'image InstallESD, non?
(EDIT: en prenant le InstallESD je n'ai pas le dossier Extensions de S/L/E)

Par contre réparer les permissions c'est bien réparer la clé depuis l'utilitaire de disque puis les permissions si il l'accepte?



EDIT2:
de ce que j'ai eu le temps de lire avant l'écran noir:
nstatlookup failed
AppleSMDusPCI Start failed

#8
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,720 posts
  • Gender:Male
non, c'est la méthode avec BaseSystem + remettre le dossier package qu'il faut utiliser !!!

tu as mis ton dsdt.aml ?


bases-toi sur ce tuto et utilise dsdt.aml qui se trouve dans le package à télécharger, il corrige l'erreur que tu as, entre autres !!!

http://www.insanelym...howtopic=219471

#9
Naced28

Naced28

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Je crois que c'est de là que je tien pas mal de mes fichiers car je les déjà le Rev1.06 je te tiens au courant

au passage petite question si j'met Snow leopard après on peux faire l'installe Lion comme sur un mac?

EDIT:
Alors j'ai changer les jumpers de place, j'ai rajouter les options S3 et tout dan le bios.
J'ai mis le bootcd j'ai mis Snow leopard que j'ai eu lors de l'achat de mon mac, et j'obtien cette erreur:
EBIOS read error: Error 0x09
Block 0x199860 Sectors 0

J'vais chercher pourquoi et aussi testé en gravant l'InstallESD de Lion :(

#10
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,720 posts
  • Gender:Male
tu n'aurais pas un dd externe de branché ? si oui, débranches-le !!!

ton DVD de Lion, il faut le graver en 2x

ton dd est en s-ata ? vérifie qu'il est bien reconnu dans le bios et que l'install de Windows par exemple est possible !!!

#11
Naced28

Naced28

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Tous ce que tu vien de me dire est OK... alors j'ai refait un test par USB classique avec le DSDT.aml de l'archive malheureusement c'est celui pour la SE2 alors que moi c'est la SE1 ... ca ma tout de même permis d'aller plus loin (à 10 ligne prêt)
J'ai eu l'erreur

nstatlookup failed mais elle ca à continuer derrière.

Sa ma mis après :


Mac OS Version 11A511
Kernel version ....
Darwin kernel ...
Kernel UDID ....
System Model name: imac10,1 ...

System uptime in nanoseconde: 150511344069

Et la plus rien... sa reste figé.


EDIT: J'ai test chameleon 2.0 RC 5 il charge au boot les fichiers (il me fait une liste Read HFS+ File.. blah blah)
Puis il redémarre... jrechoisi de boot sur la clé... il lis quelques fichiers et il redémarre.

Donc bon déjà avec PCEFI j'ai pas le soucis mais bon j'ai toujours pas réglé mon problème...

#12
Matt35

Matt35

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 250 posts
  • Gender:Male
  • Location:France
Essaye de démarrer avec -x -f -v.
fantomas1 : je crois que le dsdt se place à la racine du disque, à vérifier.
Et sinon pour iatkos, démarre avec -arch=i386 -x -f -v... Peut être que ça fonctionnera ! Moi ça m'avait fait ça sur un acer aspire 3810

#13
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,720 posts
  • Gender:Male
dsdt il faut le mettre dans le dossier Extra crée par défaut lors de l'installation de chameleon ou PCEFI 10.6. Chameleon va chercher en premier les fichiers dans ce dossier et les charger "avant" les autres kexts du S/L/E.

#14
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 252 posts
Essaye de démarrer avec -v PCIRootUID=1

#15
Matt35

Matt35

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 250 posts
  • Gender:Male
  • Location:France
Ah ? Moi je met toujours mon dsdt à la racine... Merci fantomas1, je le saurai pour la prochaine fois !





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy