Jump to content

Snow Leopard rebooting every 15 minutes (give or take)


  • Please log in to reply
4 replies to this topic

#1
vmenge

vmenge

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hey :)
I've got Snow Leopard 10.6.8 installed on my machine (AMD Phenom II X4 955, Asus M4A78T-E, Radeon 5970, 8GB RAM). Everything is working perfectly fine, besides sound glitching now and then.
For some reason my machine reboots every 15 to 20 minutes (give or take) giving me a message on the screen.
Posted Image
Sometimes it's this image, sometimes it's another one. This one that I managed to take a picture appears and the computer freezes until I reboot it manually. The other one is very similar (if not the same) but goes by fast and the computer reboots on its own.
Anyone have any clue to what is going on?
Any help appreciated :)

#2
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Wild guess here, but small possibility you could be having a kernel panic there :) seriously though, are you using a patched kernel? AMD hacks, most times, are a pain and very buggy, but can work fine if done right, although would be very rough as a first time hack setup. Anyway, more info? install methods used, kernel used, guide followed, bootloader, bootflags? Even better console logs showing other logged errors leading up to the kernel panic?

read here, http://www.insanelym...howtopic=265619 also many other similar posts scattered about. But I would first try removing any audio kexts installed such as voodoo, or may need different kernel patch. Look around and you'll find the answer, if it was too easy everyone would do it :)

#3
vmenge

vmenge

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Thanks for the quick reply :)
I followed this topic exactly like it said:
http://www.osx86.net...x-10-6-amd.html
When I installed the Legacy Kernel 10.8 I chose the force 64 bit option so that I could use my 8GB ram. After that x86 applications would crash on start, so I followed this guide on how to make it work: http://www.osx86.net...ps-working.html (I don't remember if it started before or after this)

I start with arch=i386 and force64.
Funny thing is I just left my computer on overnight downloading some stuff and it's fine. Obviously I think it's being triggered by something, I just have no clue what :(
Maybe it's the CPU overheating?

VIA VT1708S 8 is the audio of my motherboard. I'll search for something different than VodooHDA :)

Edit: I found this http://www.osx86.net...ia_vt1708s.html for my audio, to fix the sound issues, but I don't know my device ID :(
Also, it says for me to put my device ID on

IOPCIPrimaryMatch, is that on the Info.plist contained in the kext?
Thanks a lot! :D


Edit 2: Just happened again :P
Was surfing around trying to fix my audio problems (I was listening to music the for a while, so I don't think it's the audio) and when I tried to use spotlight it showed my same kind of white text on black BG real quick and rebooted on it's own :T
At least I managed to find the audio fix, going to try it and see if the reboots stop :)

Edit 3: Fixed the audio, but reboots keep happening. This time it happened as soon as I tried to attach a file to Facebook. Is it something with the hard drive, maybe?

#4
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,111 posts
  • Gender:Male
  • Location:Brazil

I chose the force 64 bit option so that I could use my 8GB ram.


You don't have to do that, OS X is not like Windows. Just go back to 32-bit kernel and drivers mode if 64-bit mode is giving you trouble.

On OS X you can run 64-bit applications and use up to 32GB RAM when in 32-bit kernel and drivers mode. Each running process can access up to 4GB RAM.

reboots keep happening. This time it happened as soon as I tried to attach a file to Facebook. Is it something with the hard drive, maybe?

It's possible. Some older ATA drivers (usually drivers that were written or patched by a 3rd party) don't work well on PCs with 4GB RAM or more.Look for a newer version of the driver you're using.
You can check for this issue by booting with maxmem=2048. if it stops crashing then it's probably your ATA driver.

For example, if your drive controller (motherboard Southbridge) is VIA then try to find SuperVIAATA.kext, it has all those problems fixed and works in 64-bit kernel and drivers mode as well.

Here's the original (and very old) thread about that issue, don't use any files from it until you have checked if there are newer versions available:
http://www.insanelym...howtopic=127611

#5
rlf

rlf

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,004 posts
Here is a thread about your audio. There are various solutions throughout the thread so read the entire thing.

To get your audio device id, download and run this program: http://www.insanelym...howtopic=219584





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy