Jump to content

Problemi con audio alc889

[AIUTO]

  • Please log in to reply
13 replies to this topic

#1
khris801822

khris801822

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Italy
Salve a tutti ho un problema che non riesco a risolvere con l' audio alc889 su Lion 10.7.3 .Praticamente ogni volta che parte una traccia audio viene sempre preceduta da una forte scarica fastidiosa... Utilizzo applehda.kext patchato con layout per alc889 e patch hdef nel dsdt. Premetto che ho fatto diverse prove con svariati kext come alc8xx ma il risultato è sempre lo stesso..Con i vodoo mi va in kernel panic... Qualcuno sa darmi una soluzione a questo fastidioso problema?

#2
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Fai un tentativo con l'AppleHDA che ho messo a punto per il mio ALC889

http://www.insanelym...dpost&p=1804684

#3
khris801822

khris801822

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Italy

Fai un tentativo con l'AppleHDA che ho messo a punto per il mio ALC889

http://www.insanelym...dpost&p=1804684

Grazie per la celere risposta ma purtroppo non va con il tuo applehda. non funziona proprio. Ma anche la parte del dsdt devo copiare dal tuo o devo lasciare il mio?
Edit: Allora ho iniettato anche la parte del tuo hdef nel mio dsdt e ora l' audio funziona. Devo verificare se fa ancora le scariche poi faccio sapere. Per il momento mille grazie.

#4
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Prego :)

#5
Zell

Zell

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts
  • Gender:Male
Guarda la mia discussione, ho risolto il problema facendo una cosa strana http://www.insanelym...owtopic=276516.
Spero di esserti d'aiuto

#6
khris801822

khris801822

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Italy
Ciao zell grazie per l' interessamento ma a quanto pare nemmeno tu hai risolto se non con microfono collegato. Il mio però non è un problema di rumore o fruscio ma piuttosto un rumore simile a quello che si ha quando si inserisce uno spinotto nell' entrata della scheda audio con periferica accesa, una specie di scarica insomma. Questo avviene solo appena faccio partire la prima traccia audio poi se ascolto musica in sequenza non lo fa più. La cosa curiosa è che poi se smetto di utilizzare l' audio pare che la periferica vada a riposo e quando vi riaccedo dopo un pò con una traccia audio oppure su una pagina web con pubblicità che hanno audio ecc... ecco che mi rifà la scarica che in certi casi è molto fastidiosa...L' applehda di buoo ha un pò accentuato la cosa ma non è del tutto scomparsa. Prima o poi se qualcuno dice la sua idea risolverò... Nel tuo caso comunque proverei a usare l' applehda per alc889 più la patch hdef nel dsdt e secondo me risolvi. :smoke:

#7
khris801822

khris801822

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Italy
Dopo tante ricerche e qualche imprecazione ho trovato una cosa interessante che a quanto pare risolve il problema di queste scariche o pop come dirsivoglia... Ho trovato questo paccheto che si chiama antipop 1.0.2 che a quanto pare impedisce alla periferica audio di dormire e far la scarica quando la risvegliamo se si riaccede con una traccia audio... A questo punto mi chiedo e chiedo anche a voi più esperti di me se non sia possibile implementare questa funzione direttamente nel dsdt o nel kext in modo da evitare l' installazione del pacchetto... Chiunque abbia idee e suggerimenti in merito è ben accetto ... Bye :thumbsup_anim:

#8
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,281 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Prova questi

Attached Files



#9
khris801822

khris801822

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Italy

Prova questi

No questi non vanno Carbo. Non rileva la periferica. Grazie comunque per l' interessamento. Credo comunque che la soluzione sia nel provare ad inserire questo antipop o nel kext o nel dsdt ma io non ho idea di come fare. Continuo a sperimentare.

#10
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,281 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Ho trovato questi, SEMBRA funzionino bene x la tua MB, all'interno trovi anche la parte di codice da iniettare nel DSDT...
Inutile raccomandarti di fare un backup del DSDT e dei kext originali...

Attached Files



#11
khris801822

khris801822

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Italy

Ho trovato questi, SEMBRA funzionino bene x la tua MB, all'interno trovi anche la parte di codice da iniettare nel DSDT...
Inutile raccomandarti di fare un backup del DSDT e dei kext originali...

Ciao carbo questi funzionano ma la scarica non mi abbandona mai :worried_anim: ... E che ce vuoi fà... Mi dovrò rassergnare ad averlo così poi magari un dì si troverà una soluzione definitiva. Per orà andrò con l' antipop perchè questa cosa mi sta sfinendo e mi voglio dedicare ad altri problemi come trovare le cause dei rallentamenti al boot... Grazie per il supporto :thumbsup_anim: ...

#12
netgear

netgear

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
Avete fatto progressi...? Io ho una Gigabyte GA-Z68MA-D2H-B3 con 889, ho avuto dal'inizio questo problema poi risolto su segnalazione di carbo178 con antipop, ho visto che macpro3.1 evita come per il video che anche l'audio vada in risparmio ma ovviamente cercavo una soluzione più elegante... Dicono che l'antipop su Lion dopo due ore abbuia l'audio, ma non ho mai verificato.

Ciao...

#13
khris801822

khris801822

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Italy
In che senso abbuia l' audio? Io ormai lo uso da tempo e sinceramente non ho cercato più soluzioni altrove perchè con antipop funziona bene e non vedo tracce su kernellog di problemi causati da esso... Mettere mac pro 3,1 non so, non ho mai provato, ma poi magari crea problemi in altri ambiti... Per ora la soluzione antipop è per me la migliore poi vedremo più in là...

#14
netgear

netgear

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
Avevo letto di non usare antipop su Lion perchè creava questo problema, dopo due ore l'audio spariva, meglio così...





Also tagged with one or more of these keywords: [AIUTO]


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy