Jump to content

Flashing Radeon HD6770 to HD5770


  • Please log in to reply
5 replies to this topic

#1
Clayf700

Clayf700

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
Hey guys, The last time I flashed my video card from Radeon HD6770 to HD5770, It worked great on Snow Leopard. But not so much the same on Windows 7, It goes to a terrible resolution and disables aero. My assumption, is that Windows 7 stopped recognizing the video card. Does anyone know how to get it working for both Operating systems? My theory is if I do this:
Posted Image
Then it will work for both?

#2
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,789 posts
  • Gender:Male
Hi

no, this is what is causing your problem on Windows ! I had the same trouble !

http://www.insanelym...dpost&p=1791236

#3
Clayf700

Clayf700

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts

Hi

no, this is what is causing your problem on Windows ! I had the same trouble !

http://www.insanelym...dpost&p=1791236


Since I am AMD, I'm stuck on snow leopard. Is it possible to do this with only snow leopard?
My Plan:
keep the vendor on default and change the Videocard ID to HD6770

#4
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,789 posts
  • Gender:Male
to 6770 or 5770 ?

if to 5770, yes, you can !

http://www.insanelym...dpost&p=1790274


my flashed 6770 into 5770 work fine on 10.6.8/10.7.3/10.8 without any patched kext.

on Seven x64 works fine too !

#5
Clayf700

Clayf700

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts

to 6770 or 5770 ?

if to 5770, yes, you can !

http://www.insanelym...dpost&p=1790274


my flashed 6770 into 5770 work fine on 10.6.8/10.7.3/10.8 without any patched kext.

Okay, I kept everything the same except for the Video ID, which I changed to HD5570, and when I reset my machine I got an error message do I need to install the drivers and that's it?
Attached File  Error.png   1.3MB   30 downloads

#6
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,789 posts
  • Gender:Male
Personally, I didn't have need to install any driver, since I already had the latest version of Catalyst. (i'm on seven x64)

In your case, you can optionally install it.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy