Jump to content

HELP! Asus M3N-HT, Phenom II 955, GTX 460 - Which distro works?!

GTX460 GTX 460 Phenom 10.6 M3N-HT

  • Please log in to reply
1 reply to this topic

#1
audio84

audio84

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
PLEASE help!

I used to have a perfectly working Leopard iAtkos 7 10.5.8 running with my system (shown below), but since I've upgraded my graphics card from a 9800GTX+ to a GTX 460 I'm now in deep {censored}. Leopard no longer picks it up.

I've tried to install iAtkos 7 10.5.8 again I can't boot as the graphics card isn't recognised. The -x command works, but there aren't any drivers to install as the supported nvidia drivers are only for Snow Leopard.

"So just install Snow Leopard?" I hear you say. Well I've tried to install iAtkos S3 V2 10.6.3 but to no avail. Whatever way I try to install, I either get kernel panics at boot, or the PC shuts down on boot (verbos reads CPU halted). With iAtkos S3 V2 I've tried the Chameleon 2 RC5 boot loader, the AnVal bootloader, the 10.3.0 kernel, the 10.2.0 kernel, etc.

When booting, I always enter my correct FSB, Busratio and Maxmem values. The DVD was burned at 4x, my bios is set to AHCI and I'm installing to an internal sata drive - all completely normal stuff. Every distro installs great, but they never boot.

Can someone please help me? I could really do with having this system up and running soon - I do a lot of Final Cut Pro at work and would love to use it at home.

System:
Asus M3N-HT Deluxe
AMD Phenom II 955 BE
6Gb Corsair XMS2 DDR2
EVGA GTX 460 SE

Thanks guys! Much appreciated :)

#2
maya77

maya77

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
I'm using Asus GTX 460 on 10.6 with official NVIDIA driver and:

<key>GraphicsEnabler</key>
<string>Yes</string>

in org.chameleon.Boot.plist.

You don't need any special distro to install SnowLeo.
Use retail disc and boot it using nawcom ModCD +:
arch=i386 -force64 busratio=16 maxmem=4096

After install boot from the same CD to your SL, then install:
10.6.8 update, Chameleon 2.1svn-r1819, and nawcom legacy kernel 10.8.0 v2.

You'll need some flags to get it booting correctly, probably:
arch=i386 -force64 cpus=4 busratio=16 npci=0x2000

Also use amd_insn_patcher_V2 and patch some known binaries to avoid errors.

And use VoodooTSCSync for your AMD to work correctly (sync TSC through all cores).

If you have any more questions feel free to ask.





Also tagged with one or more of these keywords: GTX460, GTX, 460, Phenom, 10.6, M3N-HT


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy