Jump to content

[GUIDE] 10.6.8 on a Dell Optiplex GX620

gx620 Dell Optiplex GX620

  • Please log in to reply
107 replies to this topic

#21
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Yes, everything you discribe points toward a problem with the video. Definatly try the laptop GMA950 patch.


I've apllied laptop patch OS boots but I'still can't change monitor resolusion :( any ideas

#22
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

I've apllied laptop patch OS boots but I'still can't change monitor resolusion :( any ideas


Throw out the dsdt.aml file and then restart the computer using the boot flag
graphicsenabler=yes

#23
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
thank you Cerastez. I have another problem after update to 10.6.8 and kernel update it won't boot again. Damn.
Luck to boot with safe mode :( I'm looking for drivers but can't find any.

on 10.6.3 everything works accept graphics but after update it gone.

#24
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,508 posts
  • Gender:Male
  • Location:Tampa, Florida
try PciRoot=1
its a chameleon2 boot arg

#25
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

pciroot=

? sorry I'm new to hackintosh.

Cerastez I think the problem is that your setup has one VGA port but mine has two DVI and VGA so card needs to be configured to works with two monitors mabye? I've plugged monitor to DVI so I don't know if the VGA works? I have to find DSDT patch for it but I googled everything yesterday and can't find anything useful :(

I've tried special kexts to GMA950 but whey screw 10.6.8 completely (can't boot even if safe mode) so I need to reinstall again :(
This is really nice small computer but with Snow Leo would be nicer :) Thank you.

#26
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Cerastez I think the problem is that your setup has one VGA port but mine has two DVI and VGA so card needs to be configured to works with two monitors mabye? I've plugged monitor to DVI so I don't know if the VGA works? I have to find DSDT patch for it but I googled everything yesterday and can't find anything useful :(

I've tried special kexts to GMA950 but whey screw 10.6.8 completely (can't boot even if safe mode) so I need to reinstall again :(
This is really nice small computer but with Snow Leo would be nicer :) Thank you.


You could very well be right about the dual monitor setup being the problem. I did a little looking too and it seems like you need a gma950 kext and a framebuffer kext. Maybe something like this: http://www.osx86.net...950_ _lion.html

#27
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

You could very well be right about the dual monitor setup being the problem. I did a little looking too and it seems like you need a gma950 kext and a framebuffer kext. Maybe something like this: http://www.osx86.net...950_+_lion.html


Oh my God it works. I've just needed to reistall framebuffer kext after 10.6.8 update but for now it seems working :)
Thank you again :) Can I buy you a beer?

UPDATE: after 2 hours - works and perfectly stable. 720p movies plays smothly in Movist. Sleep seems to work but I don't know how to wake him up? :) mouse, keyboard and power button didn't work.

It's cheapest mac mini on the planet :) It cost me about 80$.

#28
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Oh my God it works. I've just needed to reistall framebuffer kext after 10.6.8 update but for now it seems working :)
Thank you again :) Can I buy you a beer?

UPDATE: after 2 hours - works and perfectly stable. 720p movies plays smothly in Movist. Sleep seems to work but I don't know how to wake him up? :) mouse, keyboard and power button didn't work.

It's cheapest mac mini on the planet :) It cost me about 80$.


Fantastic!! I would take you up on that beer if you were within driving distance.
The mouse or keyboard should wake him up. There are some kexts out there that might fix that, sleepenabler or openhaltrestart.
Or you can just open the System Preferences/Energy Saver and set sleep to never.

#29
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Fantastic!! I would take you up on that beer if you were within driving distance.
The mouse or keyboard should wake him up. There are some kexts out there that might fix that, sleepenabler or openhaltrestart.
Or you can just open the System Preferences/Energy Saver and set sleep to never.


Thank you again Cerastez. I'm in Poland so this beer have to stay in "virtual domain" :) Sleep enabler works.

#30
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,508 posts
  • Gender:Male
  • Location:Tampa, Florida
sleepenabler= bad idea.

#31
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

sleepenabler= bad idea.


Could you be more specific? and explain why?

#32
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,508 posts
  • Gender:Male
  • Location:Tampa, Florida

Could you be more specific? and explain why?

look around how many people got kernel panics on update with sleepenabler.
is it still being developed by originator ?

to get sleep to work patch usb in dsdt.

#33
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

look around how many people got kernel panics on update with sleepenabler.
is it still being developed by originator ?

to get sleep to work patch usb in dsdt.


Thank you LatinMcG. Could you write me how to path USB in DSDT (which patch to use - I now a little DSDT editor)? Sleep works great for now but it removes USB drives not safely. So that patch could resolve that problem. Is DSDT patch only for USB and works with sleepenabler.kext to make sleep working perfect?

I've aplied EHCI sleep.txt path from DSDT editor patches and the computer goes to sleep but didn't wake up. Without this patch it sleeps and wake up perfectly but removes USB drives not safely.

I also found that my menu bar volume control slider is not changing volume at all but keyboard keys works and the preference panels volume sliders works.

UPDATE: Volume slider sometimes works sometimes don't :( the same keyboard keys. Only system preferences slider can control volume all the time.

#34
sbaby3

sbaby3

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Thanks to you and all the information I found here, I could install SL 10.6.8 on my optiplex GX620 P4 with a new ATI5450 to get dual screen. Everything is very fast and stable but I still have a minor issue.
From the moment I update the system with the 10.6.8_combo_update, I couldn't access anymore my windows computer on the network. I see them in the finder but can't connect. I can't share properly my printer as well.
I could do it in 10.6.3. I tested twice. I guess it has to do with some incompatible kext, but wich one? Any idea?

#35
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Thanks to you and all the information I found here, I could install SL 10.6.8 on my optiplex GX620 P4 with a new ATI5450 to get dual screen. Everything is very fast and stable but I still have a minor issue.
From the moment I update the system with the 10.6.8_combo_update, I couldn't access anymore my windows computer on the network. I see them in the finder but can't connect. I can't share properly my printer as well.
I could do it in 10.6.3. I tested twice. I guess it has to do with some incompatible kext, but wich one? Any idea?

Uggg, that explains a few things! I will defiantly look into this.......but I won't have time until this weekend. If you find a fix, post it!

#36
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Thanks to you and all the information I found here, I could install SL 10.6.8 on my optiplex GX620 P4 with a new ATI5450 to get dual screen. Everything is very fast and stable but I still have a minor issue.
From the moment I update the system with the 10.6.8_combo_update, I couldn't access anymore my windows computer on the network. I see them in the finder but can't connect. I can't share properly my printer as well.
I could do it in 10.6.3. I tested twice. I guess it has to do with some incompatible kext, but wich one? Any idea?


I didn't get into this problem, but have solved others :)

If you want to have sleep working instal this kexts:
http://www.pawelhebd...USBandSleep.zip

If you want to make app store working generate computer serial number (creating smbios file and put it into /extra folder) with champlist:
http://tools.inmac.org/

#37
sbaby3

sbaby3

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I tried several kernels and updates, the thing is terrible, can't solve this "connection" problem.
It works in 10.6.3 and 10.6.5 but not in 10.6.4, 10.6.6, 10.6.7 and of course 10.6.8.
It doesn't seem to be a kernel problem...

#38
sbaby3

sbaby3

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Ok solved.
Just need to repair permissions on the volume using diskutility.
That was so simple...

#39
refinery

refinery

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
ive been trying for days to get this to work. no matter what, i almost always get a KP on IOATAFamily... i tried removing it from the extensions but then it wont even see the hard drive.
sometimes by booting through safe mode i can get past the problem and install OSX, but when i use ###### after the initial install, it either goes into a reboot loop, or it still crashes at the IOATAFamily extension.
i would love to get this working. anybody got any tips? I have followed this tutorial *to the letter* and i also used a different distro and had pretty much exactly the same problems, or it would hang in verbose mode after "systemshutdown false"

GX620 w/ 3.4ghz Pentium D
4GB RAM
1TB HD
Asus DVDRW
Asus 8400GS Silent

thanks!

the two errors i keep getting. please let me know if i need to post more info about my setup.

oh, and the only things i have changed in BIOS were to turn off the floppy drive, SATA mode to "combination" and I had to disable "SERR DMI" mode otherwise it wouldnt even get to the bootloader screen.

Attached Files



#40
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Asus 8400GS Silent



Try removing your video card and use the built in video for the installation.





Also tagged with one or more of these keywords: gx620, Dell Optiplex GX620

  Topic Stats Last Post Info

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy