Jump to content

Errors encountered while starting up the computer


  • Please log in to reply
105 replies to this topic

#21
PookyMacMan

PookyMacMan

    InsanelyMac Legend

  • Moderators
  • 1,462 posts
  • Gender:Male
  • Location:Earth–Western Hemisphere, specifically
  • Interests:Computer science, engineering, trumpet performance, and a host of others. :D
Basically any Broadcom or Atheros card is good. :)

#22
bertmannaustria

bertmannaustria

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 211 posts
  • Gender:Male
  • Location:Vienna, Austria
Wenn WiFi 100%ig funktionieren soll, dann z.B. http://www.sonnettec...iaextremen.html

musst aber auch vorher abklären, ob dein Laptop damit kompatibel ist und ob er mit einer anderen WiFi Karte booten kann

#23
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Ok, Danke. Und wie finde ich das vor dem Kauf heraus? Google findet nichts :-/

Übrigens versuche ich immer noch die blöde kext fÜr den Marvell Yukon zu installieren. Habe es mit kextHelper 0.7 versucht, der bleibt aber hängen, wenn er geschlossen werden soll.
Mit KextWizard habe ich es auch nicht geschafft bzw. ich sehe die IONetworkfamily.kext im Extensions-Ordner, diese wird aber unter "geladene kexts" nicht aufgefÜhrt. Wie geht das genau? Was muss ich da bei Rechten usw. anklicken, d.h. in welcher Reihenfolge was anklicken? Das ist mir ein wenig unklar...

#24
bertmannaustria

bertmannaustria

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 211 posts
  • Gender:Male
  • Location:Vienna, Austria
Was für ne Hardware ID hat denn die Marvell Yukon?

Nun ja, manche Laptops können aufgrund einer Sperre im Bios nicht mit allen WiFi Karten booten bzw. könnte der Chipsatz inkompatobel sein, das im Vorfeld herauszufinden ist schwer, dazu kommt noch, dass du den Garantieanspruch verlierst. Ich hatte zu Tiger-Zeiten einen Toshiba Satellite Laptop mit Intel 2915 ABG WiFi Karte, mit einer Broadcom Karte hat er nicht booten können, mit einer Noname Karte mit Ralink Chipsatz serwohl, allerdings ist halt das Interface von Ralink nicht so hübsch, mit einer Broadcom oder Atheros Karte kannst halt die OS X eigene Airport Software verweden.

#25
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Ok, verstehe. Die Garantie ist sowieso schon abgelaufen ;-)
Die NIC ID bzw Modell scheint Marvell Yukon 88E8055 zu sein. Dafür hab ich die kext von hier geladen: http://www.osx86.net...?do=file&id=667
Kann mir einer ne detaillierte Anleitung geben, was ich zu tun habe, damit die richtig installiert werden?
Wie kann ich falsche bzw. nicht funktionierende kext-Dateien korrekt deinstallieren?

Mit dem Kauf der NIC werde ich noch ein wenig warten. Wird wohl die Broadcom werden, da ich Berichte gelesen habe, dass die Out of the Box funktioniert. Wenn ich Ethernet zum Laufen bekomme, will ich Snow Leopard erstmal updaten und bissle mehr testen, damit ich entscheiden kann, ob ich OS X zum produktiven Betrieb übernehme (neben Win7).

#26
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Hier ist die Hardware-ID in Win7 ausgelesen:
Attached File  HardwareIDMarvell.png   36.09KB   2 downloads

PCI/VEN_11AB&DEV_4363_SUBSYS_C041144D&REV_13
Wie gehts nun weiter? Was fange ich nun an mit der Hardware-ID? Wie installiere ich Ethernet auf Mac OS? :help:

PS: Dual Boot geht jetzt perfekt! 1.Partition: Win7, 2.Partition: Daten, 3.Partition: Mac OS X
Habe eine Win7-DVD eingelegt und die Computerreparatur machen lassen. Danach konnte ich Win7 booten, aber Mac OS nicht. Dann habe ich in EasyBCD einen Eintrag für Mac OS (Auswahl: MBR) hinzugefügt. Nun kann ich Windows 7 und Mac OS booten. :king:

#27
bertmannaustria

bertmannaustria

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 211 posts
  • Gender:Male
  • Location:Vienna, Austria
hier

#28
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Die Datei zum Downloaden heißt aber 88E8056 und nicht 88E8055. Ist ne falsche Datei, wa? Dort steht übrigens, dass nur 10.7.x unterstützt wird. Ich habe 10.6.3 momentan.

Irgendwas eigenartiges geht da vor sich. Nach jedem Reboot des Laptops gehen meine zuvor eingestellten BIOS Einstellungen flöten??!?! Was geht ab?

#29
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Den Yukon bekomme ich immer noch nicht installiert. Hier ein Screenshot mit Fehlermeldungen:

Attached File  IMG_20120202_203325.jpg   947.87KB   1 downloads

can't load kext com.apple.iokit.ionetworkingfamily
failed to load executable for com.apple.iokit.ionetworkingfamily
library kext com.apple.iokit.ionetworkingfamily not found
kext com.apple.iokit.AppleYukon failed to load
couldn't alloc class "yukonosx"

Irgendwie wird die IONetworkingFamily geladen, das Gerät aber nicht erkannt. Woran liegt es?
Attached File  IMG_20120202_233514.jpg   959.27KB   2 downloads

#30
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Ok, ich habe es geschafft die Marvell Yukon 88e8055 zu installieren! Das Netzwerk geht (auch wenn ich das Kabel am Anfang mal neu reinstecken muss.
Mittlerweile habe ich die Intel Wifi 5100 AGN ausgebaut und eine Atheros AR5B91 bzw. AR9281 (steht auf dem Chip) eingebaut. Diese wird als Airport Extreme erkannt, ich kann diese aber nicht "aktivieren" geschweige denn, eine IP-Adresse angeben oder sowas. Das System an sich ist seit der WiFi-Installation auch verlangsamt.
Was kann ich tun? Wie aktiviere ich die Karte? Soll ich vll. Fehlerlogs oder Screenshots schicken?
Danke!

Edit: Ok, es sieht so aus, als läge es daran, dass com.apple.configd alle 10 Sekunden abstürzt. Die Meldung ist:
(com.apple.configd[732]) Job appears to have crashed: Segmentation fault
(com.apple.configd) Throttling respawn: Will start in 10 seconds
Werde weiterrecherchieren...

#31
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Also das Problem mit der configd und dem langsamen System habe ich mithilfe eines anderen Forums lösen können! Man muss eine Datei umbenennen!
Gebt folgendes ins Terminal ein:
sudo -s
mv /System/Library/SystemConfiguration/Apple80211Monitor.bundle /System/Library/SystemConfiguration/Apple80211Monitor.bundle_
Dadurch wird die Datei umbenannt. Neustart! Man braucht keine Caches zu löschen/erneuern. Einfach nur ein Neustart und dann läuft das System wieder flüssig und man kann die Atheros Wifi-Karte aktivieren! Haut rein!

#32
PookyMacMan

PookyMacMan

    InsanelyMac Legend

  • Moderators
  • 1,462 posts
  • Gender:Male
  • Location:Earth–Western Hemisphere, specifically
  • Interests:Computer science, engineering, trumpet performance, and a host of others. :D
Herzlichen Glückwunsch zu Ihrem Erfolg! :thumbsup_anim:

Sind alle Ihre Probleme kümmern jetzt getroffen? :)

#33
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Danke! :king:

Leider noch nicht alles. Bluetooth kann ich nicht deaktivieren und das Touchpad geht noch nicht. Ich versuche mal den Treiber voodoops2controller



EDIT:Außerdem verliert mein BIOS die Einstellungen nach Beenden/Neustart von Mac OS X. Bei Windows7 bleiben die Einstellungen erhalten.
Fährt MAC vielleicht nicht richtig herunter?

#34
PookyMacMan

PookyMacMan

    InsanelyMac Legend

  • Moderators
  • 1,462 posts
  • Gender:Male
  • Location:Earth–Western Hemisphere, specifically
  • Interests:Computer science, engineering, trumpet performance, and a host of others. :D
Versuchen Sie, diese Version von VoodooPS2Controller. Es hat einigebesondere Merkmale Trackpad.

Sie wollen Bluetooth deaktivieren?

#35
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
No, I don't want to deactivate it permanently, I just want to be able to deactivate it when I don't need it. But for me the BIOS settings issue is more important because all BIOS settings that I do (i.e. Intel SpeedStep => disabled, AHCI Mode Control => Manual [Enabled]) get lost after Mac OS shutdown/reboot. That means Intel Speedstep is enabled again and AHCI Mode Control is set to "Auto" automatically. Plus the boot device sequence gets lost as well. It's quite awkward to set up BIOS every time, otherwise Mac OS crashed while starting up.
Why is that? When I reboot Win7 the BIOS settings are being saved as usual. So I exclude that it is the Mainboard Battery. Do you know a Mac OS fix for this?

#36
PookyMacMan

PookyMacMan

    InsanelyMac Legend

  • Moderators
  • 1,462 posts
  • Gender:Male
  • Location:Earth–Western Hemisphere, specifically
  • Interests:Computer science, engineering, trumpet performance, and a host of others. :D
The BIOS issue is an easily fixed issue. The reason why it resets is because Mac OS has a limited knowledge of DSDT, so if your DSDT doesn't have a particular setting in the RTC device, the BIOS will be reset when you restart. Windows does not heavily rely on DSDT like Mac OS and Linux do, so it has no problems. You can either give me your DSDT to patch, or just use this kext.

For Bluetooth, are you saying that you try to turn it off in the prefpane (pictured below) and it doesn't work?

Attached File  Screen shot 2012-02-09 at 8.17.53 AM.png   59.03KB   2 downloads

#37
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
What does this kext do? Will it keep my BIOS settings saved?

My BT looks like this:
Attached File  BT.png   41.63KB   0 downloads

EDIT: The VoodooPS2 kext that I used (not yours) from their website messed up my laptop and I had to boot from SL DVD to repair the changes :-/. But it works again. Touchpad still not working.

What would you do with my DSDT?

#38
PookyMacMan

PookyMacMan

    InsanelyMac Legend

  • Moderators
  • 1,462 posts
  • Gender:Male
  • Location:Earth–Western Hemisphere, specifically
  • Interests:Computer science, engineering, trumpet performance, and a host of others. :D
The kext corrects the RTC info so the BIOS does not reset. If I had your DSDT, I would manually correct the RTC info so the BIOS does not reset. Basically the DSDT patch and the kext do the same thing; it's a matter of preference. I personally use the DSDT fix now, but I used to use ElliotForceLegacyRTC.kext (the kext I gave you) when I first installed OS X.

You're right; you can't change the Bluetooth! Is the Bluetooth card internal or external?

The only thing I could suggest is a different SMBIOS...but Bluetooth doesn't use much power, so how come you want to turn it off?

Try my kext. If it doesn't work, take a pic; it might be an easy fix. :)

#39
sukati

sukati

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Cool man, your file works, the BIOS settings survive the reboot! :smoke:

The Bluetooth is internal. Here is the System Profiler Screenshot:
Attached File  BTProfiler.png   135.91KB   2 downloads

Tell me more about the smbios thing. :worried_anim:

#40
PookyMacMan

PookyMacMan

    InsanelyMac Legend

  • Moderators
  • 1,462 posts
  • Gender:Male
  • Location:Earth–Western Hemisphere, specifically
  • Interests:Computer science, engineering, trumpet performance, and a host of others. :D
By default, OS X cannot detect what your machine is because it is not a "real Mac". The identification technology Mac OS uses is called SMBIOS. Therefore, to identify your computer we need to create a preference list (known as plist) with the info which Chameleon can pass on to OS X.

Right now your computer is being identified as a MacBook Pro. This is just a guess, but if the model does not closely correspond with your computer's specs, there may be some issues. You can check this in the top listing of System Profiler (it's called Hardware, I believe) The other thing is, can you turn Bluetooth off in Windows? Your card may also not support on/off functions...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy