Jump to content

All users of Gigabyte Z68 motherboards please read


  • Please log in to reply
5 replies to this topic

Poll: Please read the post before answering. (7 member(s) have cast votes)

Are USB devices working properly after wakeup from sleep?

  1. I am having some of the mentioned symptoms. (4 votes [57.14%])

    Percentage of vote: 57.14%

  2. I am having most/all of the mentioned symptoms. (1 votes [14.29%])

    Percentage of vote: 14.29%

  3. Everything working properly the same moment as computer wakes up and I have any of the mentioned symptoms. (2 votes [28.57%])

    Percentage of vote: 28.57%

Vote Guests cannot vote

#1
Moze

Moze

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
Hi, I am having problems with USB devices on my GA-Z68XP-UD3 motherboard. I could not find solution, but I found what I think is a problem with all Z68 motherboards.

Symptoms of the problem:
  • After waking up, need to wait couple second for devices to start working.
  • Often the device, with which computer was woken up, need to be reconnected manually, for it to work.
  • After waking up there are errors in console similar to this:
    • kernel: 0 AppleUSBCDC: start - initDevice failed
      kernel: USBF: The IOUSBFamily was not able to enumerate a device.
      kernel: USBF: The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying.
      kernel: E:[AppleUSBBluetoothHCIController][InterruptReadHandler] Received kIOUSBHighSpeedSplitError error - retrying
  • In System Preferences, keyboard modifiers keys settings, you see duplicated keyboards. Like in this screenshot:
    Posted Image
Please do some testing and review all the symptoms. After that answer the poll question.

Also please post your hackintosh configuration (motherbaord name, bios version, boot loader, any special settings in boot.plist or bios, used kexts).

Any contribution is appreciated.

#2
Edkroket

Edkroket

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Amsterdam
  • Interests:Music, I'm a bass player
I have the same mobo. Running bios F8. Everything works great also USB.
What I do is sleep on energy saver or via apple-menu or by pressing powerbutton.
To wake I press Powerbutton once, wait a few seconds and hit my keyboard.
It;s awake and usable though I have some errors in console as well but never mind.
I have USB3 Enabled in bios and use PXHCD.kext for them to work.
Here is org.chameleon.plist;
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>-f npci=0x2000</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>PciRoot</key>
<string>1</string>
<key>Theme</key>
<string>Different</string>
<key>Timeout</key>
<string>1</string>
</dict>
</plist>

Disable in Bios/C3 C6 state!!
That is about it.
And only kext I use is Fakesms in /S/L/E

Ed

#3
JamesLittler

JamesLittler

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,022 posts
  • Gender:Male
  • Location:Portsmouth, England
Do you have any kexts in E/E? if so move them to S/L/E, rebuild caches and repair permissions and then remove any mkexts and any backups from Extra.

Then add UseKernelCache=Yes to org.chameleon.boot.plist/com.apple.boot.plist depending on your bootloader

#4
magnifico

magnifico

    Retired

  • Donators
  • 2,557 posts
  • Gender:Male

I have the same mobo. Running bios F8. Everything works great also USB.
What I do is sleep on energy saver or via apple-menu or by pressing powerbutton.
To wake I press Powerbutton once, wait a few seconds and hit my keyboard.
It;s awake and usable though I have some errors in console as well but never mind.
I have USB3 Enabled in bios and use PXHCD.kext for them to work.


Hi, because you use pxhcd.kext ?
You have hardware usb3 ?
I have same problem whit my mouse ....
stops the mouse pointer on the finder, and I have to remove and put back to work in another USB port


#5
Edkroket

Edkroket

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Amsterdam
  • Interests:Music, I'm a bass player
Yes I have Z68XP-UD3 with USB3 yes

#6
kanedaguy

kanedaguy

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Yes I have Z68XP-UD3 with USB3 yes


Can you share your installation process btw? Thanks.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy