Jump to content

Acer Aspire 5670/5671 10.6.X "work in progress" Guide

- - - - - Snow Leopard Acer Aspire 5670 5671

  • Please log in to reply
3 replies to this topic

#1
FiLhAcK

FiLhAcK

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
Hi Guys,
for those interested and have an Acer Aspire 5670 or 5671, I was able to run Snow Leopard to 10.6.7 with a retail installation.
The features of the notebook are as follows:

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port [8086:27a1] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 [8086:27d4] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M56P [Radeon Mobility X1600] [1002:71c5]
02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express [14e4:169d] (rev 21)
03:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) Swapped original Intel 3945
07:06.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
07:06.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]
07:06.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
07:06.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]

First Step:

SL 10.6.0 Installation Disc through retail and Nawcom Modcd 0.3 which can be found here
Installation is simple and fluid, on the first reboot you should use the flags:
-v cpus = 1 (otherwise it will remain stuck on IOAPIC)

At this point you have installed everything perfectly, what I recommend, is to immediately install the Combo update to 10.6.7
then reboot-v cpus = 1

Once this is done it is time to personalize the boot settings to do what you have to enter some kext that is in Extra Extensions and then extract the most important thing and patched DSDT.

Soon will post a package of files ready to be replaced in order to solve problems and recognition of boot devices, currently pointing you to what goes and what does not:

ATI Radeon X1400: Works with QE / CI and 1280x800 resolution, unfortunately, only 32Bit :wallbash:

ALC 883 Audio: Works perfectly but only from 10.6.6 onwards, at least I have the kext!

Firewire: OOB

Webcam: works but I have not had time to test it;

Wireless BCM4311: OOB

BCM5789 Ethernet: unfortunately the only thing that I can not run and I can not understand why, give me all the kext found the same problem at startup "Memory Dump Failed" That's why I have not posted the kext pack for everything else, I want to first see if I can solve the problem. :hammer:

If any of you can give me a hand with the network card I appreciate it, because i work on it from 10 days and my brain went into kernel panic :help:

Good Luck to everyone! :thumbsup_anim:

#2
montiniz

montiniz

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Chicago
Hi, just wondering what kexts are you using to run your laptop, i have, aspire 5672. with radeonhd i get mouse tearing, and i also changed wlan to bcm4311 which shows up in DPCIManager but i can't turn it on. I'm using dsdt, do i have to change somthing over there for computer to see it?
What about the audio? i'm using voodoohda, but it's terible, how did you enable your audio

#3
FiLhAcK

FiLhAcK

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
Hi montiniz,
well, i'll try to answer to all questions....
1 with radeon x1400 i've tried a lot of version but only 1 really work, but with arch=i386 and until 10.6.7. after not work.

2 for wifi issue, is a long story, i tried many modify and many card but the problem is only 1 if you use command lspci -vvnn you'll see that bcm4311 or else card, have a "sub vendor ID" this is the problem because in acer 5670 series the bios have like a white list and not allow osx, to dump memory of wifi card and doesn't load the right kext. after all test i think the solution are 2, 1 buy a genuine Apple mini pci card, it work! trust me!, 2 rebrand your card sub vendor by linux, find guide in this forum, but i'm not sure it really work.
3 for Alc883 no problem i've the kext but, it only work from 10.6.6

if you send me a mail in pm i'll send you a kext pack, i don't wanna post here because is not definitive pack, i don't wanna give problems to other users until my test are finished.

feel free to contact me for further information
:wink2:

#4
FiLhAcK

FiLhAcK

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male

Hi, just wondering what kexts are you using to run your laptop, i have, aspire 5672. with radeonhd i get mouse tearing, and i also changed wlan to bcm4311 which shows up in DPCIManager but i can't turn it on. I'm using dsdt, do i have to change somthing over there for computer to see it?
What about the audio? i'm using voodoohda, but it's terible, how did you enable your audio


Kext pack sent ;) wait your answer!





Also tagged with one or more of these keywords: Snow Leopard, Acer Aspire 5670 5671


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy