Jump to content

[aiuto] installare lion su SONY VAIO VPCEH2N1E/W


  • Please log in to reply
174 replies to this topic

#141
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
Serve il numero dopo la r..usa almeno l'r1886 o successivi..anche r19e qualcosa..

#142
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Rifacendo la procedura da capo tu pensa che devo aver fatto qualcosa di diverso perché ora non mi da più quell errore della foto ma sempre PCI configuration begin..bo domani a mente più lucida riprovo a fare tutto da capo e con molta pazienza..

#143
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
Ok.. aggiornaci.. comunque nel bootloader prova aggiungendo PCIRootUid=1 oltre a npci=0x2000.

#144
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Oddio... antonio...fabio.... si e avviata installazione e procedo a farla dopo di che che faccio??

#145
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
;).. Procedi..una volta configurato avrai bisogno di riavviare da penna USB..installi gli stessi kext che hai usato per la USB con kext utility.. Installi chameleon con le stesse impostazioni stavolta sull'hdd..ovviamente con pcirootuid=1, npci=0x2000, ecc ecc..come con la penna..e facci sapere se fila tutto

#146
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

.. Procedi..una volta configurato avrai bisogno di riavviare da penna USB..installi gli stessi kext che hai usato per la USB con kext utility.. Installi chameleon con le stesse impostazioni stavolta sull'hdd..ovviamente con pcirootuid=1, npci=0x2000, ecc ecc..come con la penna..e facci sapere se fila tutto


Allora ho riavviato ed e partito con solo usbbusfix =yes perché se no non mi funzionava il mouse. Ora il mouse funziona ma non mi vede la tastiera e quindi non mi fa partire il wizard

#147
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
Hai messo i kext ps2 nella penna? Non hai la possibilità di procurarti una tastiera USB per il wizard?

#148
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Si Antonio pro curata e infatti ora ho risolyo ma sono incappato nel mio primo kernel panic. Praticamente ho installato il driver della scheda di rete e come ho riavviato si e fermato in uptime nanosecons etc...

Mi diresti ordine di installszione e poi kext wizard va bene??

Scusami dimenticavo ma cosa serve multibest?? Cosa mi consigli..sei un mito grszie

#149
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
Linka l'immagine del Kernel panic, tutta la schermata. Che kext hai installato per la scheda di rete?

Multiche? Ahahah.. Vale lo stesso discorso fatto per iAtkos..

#150
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Linka l'immagine del Kernel panic, tutta la schermata. Che kext hai installato per la scheda di rete?

Nella cartella che mi hai dato cera un pkg per i driver della scheda di rete lo installatobe al riavvio kp.. ora stonformattando e reinstallo da capo.. e procedo con ordine che tu mi darai

Linka l'immagine del Kernel panic, tutta la schermata. Che kext hai installato per la scheda di rete?

Multiche? Ahahah.. Vale lo stesso
discorso fatto per iAtkos..


Ah ah ah sei un mito

#151
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
Evidentemente non è il tuo.. Cerca e scarica da http://www.osx86.net/ i kext a te necessari.
Trovi tutto li..
Quelli per la rete sono ionetworkingfamily.kext e io80211family.kext.
Da installare in S/L/E.. Prima fai il backup degli originali..
Dopo che li installi ricostruisci la cache con kext wizard o kext utility, è uguale..
Io non ho seguito un ordine preciso.. Per necessitá prima ps2, poi video e infine rete..e batteria..

#152
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Evidentemente non è il tuo.. Cerca e scarica da http://www.osx86.net/ i kext a te necessari.
Trovi tutto li..
Quelli per la rete sono ionetworkingfamily.kext e io80211family.kext.
Da installare in S/L/E.. Prima fai il backup degli originali..
Dopo che li installi ricostruisci la cache con kext wizard o kext utility, è uguale..
Io non ho seguito un ordine preciso.. Per necessitá prima ps2, poi video e infine rete..e batteria..


Ok ho messo i kext gli stessi che avevo nella penna USB e poi sempre con kext wizard ho proceduto a riparare i permessi e ricostruire la cache.. giusto???

#153
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
Esatto..

#154
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Ok ho messo i kext gli stessi che avevo nella penna USB e poi sempre con kext wizard ho proceduto a riparare i permessi e ricostruire la cache.. giusto???

Antonio toglimi questa curiosità ho chamaleon ma se lo faccio partire senza la chiavetta con le solite stringhe mi va in kernel panic mentre invece se metta la USB faccio il boot con lei e poi faccio partire lion con le solite stringhe va tranquillamente..booooo mistero della fede. Ho forse sbagliato qualcosa con chamelon 2.1 svn-r1713

Esatto..

Ok dato che ormai queste stringhe le devo mettere sempre come le metto deffinitive.. ?? Scusami io vengo da Linux e qui e un altro monso

#155
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
La cartella extra e l'smbios l'hai fatte? I kext necessari al boot ci sono in extra? Comunque utilizza un chameleon successivo come avevo detto qualche post fa..r1886 o successivi..meno problemi..

#156
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

La cartella extra e l'smbios l'hai fatte? I kext necessari al boot ci sono in extra? Comunque utilizza un chameleon successivo come avevo detto qualche post fa..r1886 o successivi..meno problemi..

No antonio cosa faccio li prendo dalla USB e li copio e incollo nel PC??

#157
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
Si, prova così.. Copia incolla.. E crea l'smbios.. Per metterle definitive devi vedere nelle opzioni del boot loader quando lo installi.. Ti fa selezionare le opzioni USB, ehci, pci e npci, oltre a generate c-state e p-state.. Tranquillo, abbiamo sbattuto tutti un sacco.. :)
Ovviamente qualsiasi modifica fai ai kext ricrea la cache..

#158
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Si, prova così.. Copia incolla.. E crea l'smbios.. Per metterle definitive devi vedere nelle opzioni del boot loader quando lo installi.. Ti fa selezionare le opzioni USB, ehci, pci e npci, oltre a generate c-state e p-state.. Tranquillo, abbiamo sbattuto tutti un sacco..
Ovviamente qualsiasi modifica fai ai kext ricrea la cache..


Allora ti aggiorno quello che ho fatto. Dimmi se ho fatto tutto bene. Allora installato lion osx. Dopo installato ho riavviato e proceduto ad attaccare una tastiera USB cosi ho fatto il wizard ed e andato tutto bene. Dopo di che ho installato la cartella extrafolder e smbios dopo di che sono passato a installare alcuni kext di quelli che mi avete dato. Per me hanno funzionato quelli della batteria, wi-fi, mouse, tastiera, spegnimento e audio solo per la parte hdmi. Mentre ancora non ho audio dalle casse (volume bloccato). Scheda video a risoluzione a 1024 x 768 ma si vedono gli effetti. Face time non mi vede la telecamera mentre il bluetooth funziona nativamente.
Infine con chameleon wizard ho scaricato e installato ultima versione di chameleon v.2.1 r1907 e sempre con questo programma ho modificato org.boot.chameleon.list in modo da includere i flags e non scriverle all'avvio e modificato smbios per il mio Sony..

Dopo tutto CIO devo fare altro?? oltre che cercare altri kext x far funzionare tutto quello che rimane??

Grazie per immenso aiuto

#159
Antonio Manni

Antonio Manni

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
Fidati che già è tanto quello che hai ottenuto.. e figurati per l'aiuto..siamo qui per questo.. aiutarci a vicenda..
Passiamo al pratico:
prima di fare qualsiasi altro esperimento fissa quello che hai ottenuto facendo una bella copia con CCC Carbon Copy Cloner in modo da non dover ripetere l'installazione in caso di problemi con gli esperimenti kext.
Secondo come avrai letto nelle pagine precedenti a noi funziona la webcam nativamente ma non funziona il bluetooth a meno che non avviamo da windows.. abbiamo la risoluzione ma qualche artefatto con Lion.. risolto con Mountain Lion..
Per l'audio devi cercare sul sito che ti ho dato prima i kext per la tua scheda audio o provare VoodooHDA.kext..
Anche per la risoluzione dovrebbe esserci la soluzione.. dovresti cercare sempre in base alla tua vga su quel sito..
Se non sbaglio agli altri partecipanti a questo 3D l'audio tramite HDMI non funzionava.. io non ho provato.. evidentemente i nostri modelli differiscono per questo, anche..
Per la webcam cerca isight.kext ..
Se ti funzionano iCloud, AppStore è un passo avanti..
Io al posto tuo farei il backup e poi proverei a installare Mountain Lion (La creazione della penna è la stessa ma vanno usati 2 kext specifici). Con il Vaio mi sono funzionate nativamente molte più cose rispetto a Lion ma con meno problemi..
Oltretutto te dovrai aggiornare Lion alla 10.7.3 rimuovendo prima Sleepenabler e poi vedendo quali kext vanno reinstallati..

Un favore.. Se aggiorni la firma inserendo tutte le specifiche del modello ci eviti di girarci tutti i post per cercare le caratteristiche da sistemare.. :D

#160
acroteleuzia

acroteleuzia

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Fidati che già è tanto quello che hai ottenuto.. e figurati per l'aiuto..siamo qui per questo.. aiutarci a vicenda..
Passiamo al pratico:
prima di fare qualsiasi altro esperimento fissa quello che hai ottenuto facendo una bella copia con CCC Carbon Copy Cloner in modo da non dover ripetere l'installazione in caso di problemi con gli esperimenti kext.
Secondo come avrai letto nelle pagine precedenti a noi funziona la webcam nativamente ma non funziona il bluetooth a meno che non avviamo da windows.. abbiamo la risoluzione ma qualche artefatto con Lion.. risolto con Mountain Lion..
Per l'audio devi cercare sul sito che ti ho dato prima i kext per la tua scheda audio o provare VoodooHDA.kext..
Anche per la risoluzione dovrebbe esserci la soluzione.. dovresti cercare sempre in base alla tua vga su quel sito..
Se non sbaglio agli altri partecipanti a questo 3D l'audio tramite HDMI non funzionava.. io non ho provato.. evidentemente i nostri modelli differiscono per questo, anche..
Per la webcam cerca isight.kext ..
Se ti funzionano iCloud, AppStore è un passo avanti..
Io al posto tuo farei il backup e poi proverei a installare Mountain Lion (La creazione della penna è la stessa ma vanno usati 2 kext specifici). Con il Vaio mi sono funzionate nativamente molte più cose rispetto a Lion ma con meno problemi..
Oltretutto te dovrai aggiornare Lion alla 10.7.3 rimuovendo prima Sleepenabler e poi vedendo quali kext vanno reinstallati..

Un favore.. Se aggiorni la firma inserendo tutte le specifiche del modello ci eviti di girarci tutti i post per cercare le caratteristiche da sistemare..

Antonio mi correggo mi funziona anche la webcam e sto risolvendo x audio e video.. o almeno spero ah ah ah e il bluetooth mi funziona nativamente





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy