Jump to content

Mac OS X Lion 10.7 Golden Master on Fujitsu S6410


  • Please log in to reply
39 replies to this topic

#21
Sasch

Sasch

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Germany
Hi Robi - no - have problems with the second core.
I look later when my other notebook runs well .

#22
gazzauk71

gazzauk71

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Ok new here but where I am with an FSC S6410. 2GB memory Dual Core 2.0 Ghz procs.

osx 10.7.1 have 10.7.2 combo update downloaded, but worried about trashing the following.

wifi. Changed to a Broadcom bcm4312 from a dell ebay £2.95! Needed a kext but found one eventually. The supplied FSC was an Atheros which I couldn't get to work.

LAN. 88E8055 using a modded appleyukon2 kext for this. works fine. This was a mod for the venID and devID within the ionetworkingfamily kext, which was where I found the yukon2 kext and associated plist.

USB all ports work once you get the right combo of kexts in S/L/E folder.

printing CUPS works, but SMB/LPR printing to Windows doesnt. Issues in MAC OS X apparently.

sound. voodooHDA kext works ok. Feedback from lid mics though, so not the greatest. Front sockets work, if you reconfig in the sound options. The plugging in and out of the front jacks doesnt work automatically as it would in Windows.

Battery meter etc. Thats now working today thanks to you guys in this thread. Shows the battery icon on the topbar, with power left options/time etc. Cheers all! Was a case of reading the instructions properly and installing voodoobattery.kext.

1280x800 32bit graphics working using AppleintelGMAX3000 kext out the box . Had some strange screens when building sort of a while burnin screen... don't know what that was all about but had to use graphicenabler=No to get it up!

max resolution achieved using switchresx4 download. Easy enough to configure.

Built from Iatkos Lion 10.7.1 L1 doot disc. Then used ##### and switch to ##### or the thing with the little red man on.... works a treat.

Keyboard working using a modified UK keyboard downloaded windows-uk.keylayout. This fixes the issues such as a shifted 2 showing as an @ rather than "

And a big thanks to you guys today again as the sleepenabler now works. pwr button requests sleep etc, and it sleeps. Opening the lid wakes it again. great stuff. That was a case of using the sleepenabler kext .

So thats about it for now. Any questions post here.

Things that don't work :).

o2micro SDMC card reader. Tried and failed....

Firewire, havent really looked into this.

Bluetooth I think works out the box, but I've disabled it in the BIOS for now.

Function keys for brightness. needs a dsdt as described here, but I don't want to take the risk of trashing the system... just for some brightness to work!

All for now.



if any one else has some offerings on this laptop (FSC S6410) e.g. Should I go and update to 10.7.2 then I'd appreciate it?

#23
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
@gazzauk71

Hi I have updated to 10.7.2 only problem was my lcd I had to reinstall my modded eidid
Can you send me normal links to posts you mentioned I cannot open those stupid kontera ad

does not let me open links

Ps always do a back up b4 updating

Regards

#24
gazzauk71

gazzauk71

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi Robi.

The links are not in there because I didnt note them, but I do have the files of course, which I can send to you. Most of them did come from the osx86 forums or here. It was all through looking. I was particularly happy with the keyboard fix as that just plain annoyed me... @ for " and all! Maybe I should have noted them... but given the weeks of messing around I'm not 100% of where I got them from and the order I did things in. I have noted them all as I need to provide the notes to a colleague who has.... another S6410 for this exercise!

I'll take a screen grab of the kexts used (Showing in system info utility) on my S6410 and post it here for your comparison if you like? I can also send you the kexts that I'm using as well. They are not big files really.

For me, 10.7.2 is the big one, so Ive backed up using superduper as an image across to my windows server. I guess its best to BU to a USB drive though, so I'll do that and swap the laptop disc to an older 80GB and test restore and then 10.7.2 update. Thay will preserve my existing 10.7.1 version.

So let me know if you want any of these kexts etc.

Also, any joy with the 02micro SD card reader? And whether voodoo sound is the best to use or not? I have feedback from the two mics on the lcd panel via the voodooHDA kext, a little annoying.

Can you also expand on the 10.7.2 upgrade and how you fixed the loss of the screen? I had a number of early issues with black and white lines across the screen, then I had some sort of grey looking burn in lcd... messed around for ages with the boot flags etc to get it to work ok. I think it was because I hadn't run ##### before restarting the thing, or I'd gone a bit over the top with the kexts that I thought I needed. In reality you really don't need that many, so little is more in the case of the S6410. oh and 32-bit is a must as far as I can see with it, although the dmesg log shows 64-bit enabled... but still runs as i386 given i've set it as arch=i386 in #####.

Right enough of my waffling... laters.

#25
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
that is what I usually do when I upgrade on usb external b4 I commit to my hdd

For sound I use my modded apple hda


For screen I use a modded edid so I dont have to use switch res

Laptop is working good in boot option in chameleon is


<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=i386 pmVersion=102</string>
<key>PciRoot</key>
<string>0</string>
<key>SMBIOS</key>
<string>Extra/smbios.plist</string>
<key>Theme</key>
<string>Default</string>
<key>Timeout</key>
<string>5</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>arch</key>
<string>i386</string>
</dict>
</plist>

So it boots quite quick and for brighntess keys and volume I use keyboard maestro

I am glad sleep works for u did you use my modded dsdt???



This is my sytem info

Attached File  myinfo_copy.jpg   81.5KB   54 downloads


After 10.7.2 update screen was with gray lines so I reinstalled my modded edid id in system/library/display/overides/displayvendor id 756e... display product 717

#26
gazzauk71

gazzauk71

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Attached File  loadedkext.png   221.16KB   19 downloadsHi again.

Thanks for the details above. No I've not got into DSDt files yet. So I've done all of mine via kexts. For sleep it the sleepenabler.kext and the apple one from a 10.6 version of OSX together. Its dowloadable from here as sleepenabler lion.

Voodoobattery lion on osx86.net is the battery meter kext etc. Than works for me. So you might want to stick that one in.

Heres my kexts as loaded by the way.

#27
gazzauk71

gazzauk71

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
BTW.

Volume keys via FN and F8/F9 work on mine I assume via VoodooHDA kext. Shows a speaker icon on screen with a vol up/down line.

Boot time on mine is around 50 seconds BIOS to apple desktop.

#28
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
@gazzauk71

so do you boot with dsdt file or not????

#29
gazzauk71

gazzauk71

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
No, don't use any DSDT files at all.

#30
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain

No, don't use any DSDT files at all.


I did that b4 but could not get sleep to work and also I needed dsdt for my applehda kext....

Battery meter is the one with appleacpiplatform kext in it???

Here are my kext I have noticed your yukon is newer where didi u get it from???


Attached File  kexts.jpg   282.69KB   32 downloads

#31
gazzauk71

gazzauk71

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi Again.

I wish I knew where I found it. It was only on one of the forums. I can send the files to you if you want? I actually read an article on changing kexts to match the cards header e.g. yukon 8E8055 etc, which I did in the kext. I then cut the ionetworkfamily kext down to just the card that I wanted and ran the kext utility and restart... up came the network card etc.

I changed my machine yesterday to a apple macbook 5.1 in the smbios via ##### 4.1. Wrong move, caused a panic, so had to start with a -x and switch it back.... to 3.1, whoops. Don't know why that happened considering yours is using a 5.1 ?

As for battery meter. Yes, its got the appleacpiplatform and voodoobattery in together that worked for me!

#32
Laszlo Lebrun

Laszlo Lebrun

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

Ok new here but where I am with an FSC S6410. 2GB memory Dual Core 2.0 Ghz procs.


if any one else has some offerings on this laptop (FSC S6410) e.g. Should I go and update to 10.7.2 then I'd appreciate it?


Could you please tell me which BIOS version and which Bios settings you have to run your Hackintosh?
V1.30 does not even load the iAtkos disk. Can't boot, get "waiting for root device" which use to be a mismatch in the DSDT.
RIN67630

After a week of testing managed a dsdt with sleep fix so laptop goes to sleep and wakes up no problem

To make F6 and F7 keys working for brightness I installed keyboard maestro and mapped those keys for it :)



Me, Me, Me!
Would you please send me your working DSDT?
I currently (with the V1.30 Bios) can't boot at all.
Thank you very much for your Chrismas present to me...
;-)
RIN67630

#33
Nypan

Nypan

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi

I have read this page up and down many timed and followed the instructions from “ucing” line by line. I must admit that I’m new to Mac and when I got my S6410 over I would like to test and see if it’s greener on the Mac side. Same BIOS setting as Sasch with the correction of robi62.

I have:
Computer Lifebook S6410
BIOS v. 1.30
CPU Intel Core™ 2 Duo T7500 2.2 GHz
Memory 2048 MB * 2 = 4096 MB
LAN Mobile Intel® 945/965 Express Chipset Family
WLAN Intel Wireless WiFi Link & Centrino Advanced-N
Bluetooth CSR Bluetooth stack
GRPS/UMTS Sierra Wireless MC87xx 3G
Modem Agere Systems HDA Modem
Cardbus O2 Micro OZ711 SP2 (Onboard)
Graphics Mobile Intel® 945/965 Express Chipset Family
Audio Realtek HD Audio ALC269
Fingerprint Sensor AuthenTec Inc. AES2550 / 2501

When I boot my USB Flash (lion 10.7.2) the laptop hanged, see picture DSC00046.JPG
Any bright ideas?

#34
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain

Could you please tell me which BIOS version and which Bios settings you have to run your Hackintosh?
V1.30 does not even load the iAtkos disk. Can't boot, get "waiting for root device" which use to be a mismatch in the DSDT.
RIN67630




Me, Me, Me!
Would you please send me your working DSDT?
I currently (with the V1.30 Bios) can't boot at all.
Thank you very much for your Chrismas present to me...
;-)
RIN67630


Here is my dsdt smbios and bootlist files

Enjoy

Attached File  lion s6410.zip   16.1KB   54 downloads

Hi

I have read this page up and down many timed and followed the instructions from “ucing” line by line. I must admit that I’m new to Mac and when I got my S6410 over I would like to test and see if it’s greener on the Mac side. Same BIOS setting as Sasch with the correction of robi62.

I have:
Computer Lifebook S6410
BIOS v. 1.30
CPU Intel Core™ 2 Duo T7500 2.2 GHz
Memory 2048 MB * 2 = 4096 MB
LAN Mobile Intel® 945/965 Express Chipset Family
WLAN Intel Wireless WiFi Link & Centrino Advanced-N
Bluetooth CSR Bluetooth stack
GRPS/UMTS Sierra Wireless MC87xx 3G
Modem Agere Systems HDA Modem
Cardbus O2 Micro OZ711 SP2 (Onboard)
Graphics Mobile Intel® 945/965 Express Chipset Family
Audio Realtek HD Audio ALC269
Fingerprint Sensor AuthenTec Inc. AES2550 / 2501

When I boot my USB Flash (lion 10.7.2) the laptop hanged, see picture DSC00046.JPG
Any bright ideas?


Cannot see picture you did not upload it..

#35
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
Just updated to 10.7.3 I only had to reinstall apple hda kext and my display id 717 file for the screen to work

Geekbench score higher 3005 :-}


Old sleepenabler still works with pmVersion=102 in bootplist

Edited by robi62, 05 February 2012 - 11:42 AM.


#36
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
Just updated to 10.7.5 just had to replace apple hda kext andDisplayProductID-717 file in overrides sleep cookbook and everything working fine

#37
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
Guys pls ask for help here I will not reply to pm anymore......

#38
mahil00

mahil00

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi Guys,

I'm new here and I've recently installed 10.8.2 on FSC S6410.

I'd like to compare if some of you have mountain lion installed.


What I have working:

- 64bit kernel Core 2 Duo 2 Ghz, 4GB RAM

- GMA X3100 in native resolution 1280x800x32 60HZ with modified DisplayProductID-717

- Brightness works with Shades utility

- Sound works (headphones detection is OK) with Aplle HDA and modified DSDT from robi62

- LAN works with 88E8055 Marvell Yukon

- Camera works on FaceTime only with camera control app

- Battery meter works with AppleACPIPlatform & VoodooBattery

- Bluetooth works OOB (checked with PAN connection)

- 1394 detects by system but hasn't tested yet

- DVD works

- All USB

- Keyboard + trackpad


What doesn't works:

- QE/CI

- Native brightness slider exist in Display Pref, but doesn't work. Function keys for brightness do not work as well

- Wifi Intel 4965 doesn't work

- Card Reader

- FingerPrint Sensor detects on USB, but hasn't tested

- Sleep doesn't work

Please, post here if you have something to add.

#39
sorgua

sorgua

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi Robi. I have a problem with the graphics card on my Fujitsu S6410. I installed the kext for the video card gmax3100 but I haven't the functions QE/CI enabled. I would like to know where I can find working kext with graphics acceleration.

#40
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
  • Gender:Male
  • Location:Javea Spain
To both last posters QE/CI only works in 32bits not 64
I have managed to install 10.8.4 with hack from macrumours forum





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy