Jump to content

Ati Radeon HD 5650 on Lion 10.7 with CI/QE


  • Please log in to reply
138 replies to this topic

#21
zapsu

zapsu

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
I'm waiting for a tutorial...

#22
Dannii

Dannii

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Female
  • Location:UK
Okie dokies, I uploaded to kexts.com as the file size is 22mb & I couldn't upload here. Tutorial & all files you can get from: http://www.kexts.com...do=file&id=1502


Carlonzo, did you want to link to this/put the tutorial in your first post?


P.S. Sorry everyone for going OTT with the instructions lol :$

#23
carlonzo

carlonzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Italy

Okie dokies, I uploaded to kexts.com as the file size is 22mb & I couldn't upload here. Tutorial & all files you can get from: http://www.kexts.com...do=file&id=1502


Carlonzo, did you want to link to this/put the tutorial in your first post?


P.S. Sorry everyone for going OTT with the instructions lol :$




Awesome!! I love you!! I copy all your tutorial in first post!! thankyou!

#24
Dannii

Dannii

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Female
  • Location:UK
YAY! ;)

#25
carlonzo

carlonzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Italy

YAY! ;)




done. What do you think about?

#26
Dannii

Dannii

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Female
  • Location:UK
Fantastic! Thank you again! I'm glad I could help with the tutorial & files ;)

#27
carlonzo

carlonzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Italy

Fantastic! Thank you again! I'm glad I could help with the tutorial & files ;)



Thank you too!

#28
Dannii

Dannii

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Female
  • Location:UK
Just edited the file & page on kexts.com to add your point on the first page! I didn't think it would work using other peoples EDID ;)

#29
jamdownian

jamdownian

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
I know its lion but can someone try it on 10.6.X with amd system...

#30
Dannii

Dannii

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Female
  • Location:UK
The boot file is meant to work on snowy too and as far as I am aware the only difference between this method & the snowy one is the option: AtiConfig. On snowy its Eulemur (as thats what I used).

As for AMD, I cannot help you there...sowwie!

#31
jamdownian

jamdownian

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Could you post your machine specs..

#32
Dannii

Dannii

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Female
  • Location:UK
@jamdownian A please would have been nice :D BUT in case you haven't seen them yet my specs are in my siggie & on the first post.

Anyone else have success :)?

#33
jamdownian

jamdownian

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
@ Dannii.. my bad. I saw it in your signature. Thanks for the help but this method doesnt work on my Toshiba a665d-s6091 with hd 4200m and hd 5650m switchable cards...

#34
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 723 posts
  • Gender:Male
  • Location:South NSW, Australia

@ Dannii.. my bad. I saw it in your signature. Thanks for the help but this method doesnt work on my Toshiba a665d-s6091 with hd 4200m and hd 5650m switchable cards...


switchable are always harder because OSX will choose one over the other.

Awesome!! I love you!! I copy all your tutorial in first post!! thankyou!


i'm glad finally it was worked out :blink: disappeared for a while but am back now.

Getting Lion GM now will let you know how it goes, also have other kexts to work on alc272, and might fix DSDT up :D

#35
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 723 posts
  • Gender:Male
  • Location:South NSW, Australia
Hi danni,

The ATI texts included did not have to be included because they are included as stock. Just a heads up tto save time.I,m glad you figured it out thanks,
Good work though, setting up my triple boot now, lion runs so snappy :rolleyes:

Forcing EDID just basically unscrambles screen just like SwitchResX did or whatever it was called, the big thing need here is being able to extend monitors so you can dual or maybe even hook to your plasma screen without issues?

If all this can be achieved then great.

***Update***
I need extended monitors so I'm using combination of Uakari FB and Forced EDID to get my results, Lion works great. will work on my other hardware now :wacko:

#36
OnkelSid

OnkelSid

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Not working for me, i booted got into pc via vnc got my edid via switchresx pasted and edited it into my display file did ALL steps of the tut but my computer still hangs on the verbose-screen (i can vnc to desktop but do not get it on the laptop display...) pls help me!!

#37
Dannii

Dannii

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Female
  • Location:UK
Hi atlee, I am so happy you have yours working too! I was following you in the threads to see if you would come up with something, hehe!

I only put the stock kext in just in case they were needed, wasn't much work at all and it saves anyone asking for them. As you could see... I don't do things by halves I tend to go a bit ott because it usually saves me time in the long run - in my experience, anyway.

The only thing that bugs me about my graphics right now (maybe someone else has had these issues too..) is when I look at gradients I can see the "blocks" of colour change... does anyone get what I mean? Also I really need to calibrate my screen, just can't get it to show colours perfectly (again, I am ott about these things). Another thing that bugs me is brightness I have to use genericbrightness.kext & the brightness app which is a pain but liveable.

#38
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 723 posts
  • Gender:Male
  • Location:South NSW, Australia

Hi atlee, I am so happy you have yours working too! I was following you in the threads to see if you would come up with something, hehe!

I only put the stock kext in just in case they were needed, wasn't much work at all and it saves anyone asking for them. As you could see... I don't do things by halves I tend to go a bit ott because it usually saves me time in the long run - in my experience, anyway.

The only thing that bugs me about my graphics right now (maybe someone else has had these issues too..) is when I look at gradients I can see the "blocks" of colour change... does anyone get what I mean? Also I really need to calibrate my screen, just can't get it to show colours perfectly (again, I am ott about these things). Another thing that bugs me is brightness I have to use genericbrightness.kext & the brightness app which is a pain but liveable.


There is quite a few DSDT edits you could do for brightness including native brightness, my laptop has native, i don't use any brightness kexts, also regarding your colour issues if you are injecting the right EDID information from windows then your MacOSX should be using your forced edid colour profile.

Yeah i had been playing around with ATI 5650m in SL and Lion for quite sometime, I had it working with SwithResX but this new boot file seems to load all four kexts ATI5000Controller, ATIRadeonX3000, ATISupport, ATIFramebuffer which is needed for everything to work.

I'm going to copy ati.c inside of the bootfile so i can port it over to all the new RC5 Chameleon release branches.

Before the previous boot files would only load every kext except for ATIFramebuffer but now with this new one, everything is good. If you use Uakari FB you can have extended desktop.

So I am running dual screens, now i have a great hackingtosh to do design work ;) thanks again for bringing this thread alive, I haven't been around for a while but I'm glad I landed back here.

#39
theakseffect

theakseffect

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Location:Netherlands

The only thing that bugs me about my graphics right now (maybe someone else has had these issues too..) is when I look at gradients I can see the "blocks" of colour change... does anyone get what I mean? Also I really need to calibrate my screen, just can't get it to show colours perfectly (again, I am ott about these things). Another thing that bugs me is brightness I have to use genericbrightness.kext & the brightness app which is a pain but liveable.


If you are having the same problem I had on Snow Leopard (which is why I'm no longer on OSX right now), you are experiencing banding and the wrong pixel depth is shown in system profiler (32 bit is shown, but your graphics look more like 16 bit or lower).

Please let me know if and how you fixed this :)

#40
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 723 posts
  • Gender:Male
  • Location:South NSW, Australia

If you are having the same problem I had on Snow Leopard (which is why I'm no longer on OSX right now), you are experiencing banding and the wrong pixel depth is shown in system profiler (32 bit is shown, but your graphics look more like 16 bit or lower).

Please let me know if and how you fixed this :unsure:


Custom forced EDID should fix this.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy