Jump to content

could not restore - cannot allocate memory


  • Please log in to reply
2 replies to this topic

#1
Rudebox

Rudebox

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
have tried to make a bootable usb flash drive in vmware following the instructions on the RoberT_XeS
http://www.insanelym...p...3336&hl=P5Q

but I get the error message: "Restore failure Could not restore - Cannot allocate memory"

I'm using retail snow leopard

i tired with 8 gb usb , 16gb and hd 40gb ..

image :
http://img268.images...25/58320256.jpg

what to do ?

thanks..

#2
josh256

josh256

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
I just encountered this error tonight attempting to restore an OSX dmg to a brand new USB stick [8GB]. I did *not* encounter the error earlier today w/ two older USB sticks [8GB and 16GB]. Will do some more testing and post my results later tonight however I will say this new stick is no name and the old [working] sticks are Corsair and Centon.

UPDATE:
I've purchased and tested a second no name stick and have the same issue at the very end of the validation.
I have also tried the restore on another mac and have the same problem w/ the no name sticks.
I have also verified that the Centon and Corsair don't have any issues restoring the same dmg so it's definitely these lower quality USB sticks at fault

NOTE

Although these sticks fail verification they both work after being reconnected. EG OS detects volume as bootable, they do boot the Mac OS X Installer and install OS X successfully.

So if you're encountering the error at the very end of the DMG restore process it would appear to be cosmetic.

#3
The Drk Stoner

The Drk Stoner

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I have noted that usb drives with a MBR partition table have this issue changing the thumb drive to GUID has fixed the issue for me I hope it helps you





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy