Jump to content

Run Mac OS in VMWare Workstation without Hardware Virtualization


  • Please log in to reply
76 replies to this topic

#21
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Well if the VM starts, the patch works. If you get stuck during the boot process, that's a configuration issue.

#22
SimpleMindedMe

SimpleMindedMe

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

edit: all you german guys should also have a look at this thread on boerse.bz.

Hey guys,

as I couldn't run Mac OS in VMWare Workstation because my hardware is not capable of Hardware Virtualization, I figured out a way to bypass the check.

This patch was created using Tola's Patching Engine 2.03b and packed using UPX 3.07, which will possibly cause virus scanners to detect it as malware. However, this patch is absolutely clean and only changes 2 bytes in vmware-vmx.exe.

Patch for 7.1.3/7.1.4/8.0.0/8.0.1 32/64 bit:
https://rapidshare.c...re-vmx-patch.7z


Regards,
CubeZ


Not sure why, but this patch does not work for me.
I'm running Win7 64bit, but I have VMware Workstation v8.0.1.528992 32bit.

I placed the patch file in Program Files (86x)/VMware.. folder, ran the patch. Got a message saying 0 of 7 patterns, Patch will not work.
I ran it again, got a message saying 1 of 7 patterns.. Patch may work.

Tried to Power on the VM of OSX Lion and I contuniue to get "Mac OS X is not supported with software virtualization. To run Mac OS X you need a host on which VMware Workstation supports hardware virtualization."

Was really hoping this would work, as I have yet to find any other options/possible solutions.

#23
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

I'm running Win7 64bit, but I have VMware Workstation v8.0.1.528992 32bit.


I don't think that's possible as long as you run the standard vmware setup.
is there a \x64 subfolder? did you patch the vmware-vmx.exe file in the \x64 subfolder?

#24
guit5412

guit5412

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Hello, I've got the same problem as Kurt Hectic with VMware 7.1.3 (324285). You don't have any solution ? I'd love to install Mac Osx Lion on my PC, I was happy because I tought I could bypass the hardware virtualization successfully, but no...
Please help me.

In any case, thanks a lot for your soft !

#25
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
If you have the very same problem as Kurt, this still applies:

Well if the VM starts, the patch works. If you get stuck during the boot process, that's a configuration issue.


I'm not too much into Mac OS itself, so I'm afraid I can't help you with this. Boot Lion in verbose mode to check what the problem is and you'll most likely be able to solve it.

#26
guit5412

guit5412

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Thank for your answer very fast !
But how could I boot Lion in verbose mode ?

#27
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
press Apple+V after powering on your vm. I'm not sure which key gets recognized as the apple key, try ctrl, win-key or alt. It's the win-key for me.

edit: googling stuff like this is greatly appreciated!

#28
guit5412

guit5412

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Oh sorry, but Lion doesn't even boot, I see a black screen with "VMware" and then I've got the message...

#29
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
1. what message
2. you didnt read this thread entirely, did you?

#30
guit5412

guit5412

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
It's kinda hard, because I'm French, but I've read the thread entirely... And I've got the same message as Kurt Hectic, the 64-bit thing...
I'm really sorry for these questions, but I'd really love to have Lion on my PC...
Thanks a lot !

#31
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
sorry for being harsh, i'm kinda stressed out, exams and stuff.

try this:

Try changing the value of "guestOS" from "darwin64" to "darwin" or "darwin10-64" to "darwin10"


edit: in your vm's .vmx file

#32
guit5412

guit5412

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Ok, so I've tried this, and VMware with a grey background began to charge. Then, instead of the Apple logo, there is a crossed round :

Posted Image


Hope you will have an answer...
Good luck for your exams :)

#33
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Now boot in verbose mode to get error messages!

You'll most likely be able to solve your problem by googling the error message. your problem is quite common and not that hard to solve afaik.
I can't really help you from here as i'd need to google anything i tell you myself and I'm not having spare time for that right now, sorry!

#34
guit5412

guit5412

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I understand, thanks so much !

EDIT : sorry, just a last question. Could you recommand me a version of Mac Osx Lion 10.7.2 which works surely with your soft ? I can't find the solution for my problem...

Thanks a lot and I'm sorry...again...

#35
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Never ran Lion in VMware as I managed to install it natively. Can't help you with that, sorry.

#36
Will Caine

Will Caine

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Hey CubeZ I really appreciate your work, and im sure you have lots on your mind but changing the value of guest OS from "darwin10-64" to "darwin10" etc... does mean that the patch will work, however it stops the os from installing. Please could you try fixing the problem on win 7 64-bits. Really would be greatful!

EDIT: just thought i would mention I'm having the exact same problem as guit5412. Also, there is no error message in verboose mode.

#37
guit5412

guit5412

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Ok, so maybe another version ?

#38
cubez

cubez

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
you guys running 8.0.1? I'ma take out the disabling of long mode in software virtualization, can't test if it works though, you gotta tell me. uploading it in like 20 min.

#39
Will Caine

Will Caine

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I have tried on vmware workstation 8.0 and 8.0.1

thanks CubeZ I'll test as soon as its up.

#40
guit5412

guit5412

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Thanks so much, and I use VMware 7.1.3 (324285)





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy