Jump to content

Help me to get 16:9 res on my vaio fw laptop: ATI mobility 4650


  • Please log in to reply
14 replies to this topic

#1
tofeeq

tofeeq

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hello,

As this is my first post, I think I have to thank all the members here and osx86 project developers as they helped me to get a mac and start learning how to develop iphone apps. I even changed my facebook photo to OSx86 :D

I need a help from you.
I have Vaio FW laptop and I installed 10.6.6 leohazard dvd on it. No sound, No Ethernet, no WiFi (I use usb wifi now).... But what kills me is the resolution... 1400x1050.
It's very important to me to get a 16:9 res to be able to design apps graphics well.

Unfortunately, I couldn't understand the topics here about patching ati 4650 framebuffer..... and when i used the attached patched kexts, my hackintosh didn't boot (also, using alc sound kexts did the same)...

So if any one can help me with simple steps to get my graphics card to work.. I'd be very thankful...
My laptop is still new and I don't want to pay a lot to replace it with a mac

Best regards

#2
fistofkhesahn

fistofkhesahn

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
We are many who still have a hard time getting the 4650m to work, and I do understand you.
I've been looking at the topics that would be of interest, and I've tried every possible combination of all kexts, boot files,
boot loaders you name it. And still I can't even get my card to be recognized..

I do how ever know how go get full res (but nothing else but that)

For full ress you need Dongs radeonhd.kext

http://code.google.c...e...mp;can=2&q=

#3
tofeeq

tofeeq

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
thanks for this fast replay.

I think getting widescreen res is enough for me until the guys here find an easy way.

Howver, I installed your RadeonHD.kext using kext utility but after that mac keeps rebooting...

#4
fistofkhesahn

fistofkhesahn

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

thanks for this fast replay.

I think getting widescreen res is enough for me until the guys here find an easy way or i find sowm time to work with their tutorial to get CI/Q?? which i don't know what it means except it seem to be a good thing :unsure:


It's basicly Hardware acceleration from your gfx card. For movies, games, apps etc..

#5
fistofkhesahn

fistofkhesahn

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Do you use any boot flags?

Try booting with, -v cpus=1, if that doesn't help. Try booting into safe mode with -x cpus=1

I haven't encountered that problem after installing that kext hackintosh is very unpredictable sadly..

#6
tofeeq

tofeeq

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I tried your boot flags but cpus didn't change the situation and -x boots with no change is resolution options

#7
tofeeq

tofeeq

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
up up up

#8
fistofkhesahn

fistofkhesahn

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Hey again..

Sad to hear the RadeonHd.kext didnt work out for you :/

Botting with -x Enters safe mode, so no unnecessary kexts are loaded. Thus the res change wont work..

If boot you up with -x and goto your install drive>system>library>extensions you can find the RadeonHd.kext and delete it.

You should be able to boot up in normal mode again..

But where to go from there I dont know. I havent had my 4650m working yet either :/

#9
SliderSD

SliderSD

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
On my Sony FW54M (having a mobility radeon 4650 inside), the RadeonHD.kext is working, giving me full resolution but no QE/CI.

As I read in other threads, I would need to patch my framebuffer to get QE/CI. For this, I need to extract the i2cid values from the VRAM bios dump. The problem is, the LVDS connector does not have a i2cid value:

[codebox]ATOM BIOS Rom:
SubsystemVendorID: 0x104d SubsystemID: 0x9035
IOBaseAddress: 0xd000
Filename: BR34169.001
BIOS Bootup Message:
Sony_M764_M96M2LP_gDDR3 M96 GDDR3 128bit 450e/600m

PCI ID: 1002:9480
Connector at index 0
Type [@offset 46098]: LVDS (7)
Encoder [@offset 46102]: INTERNAL_UNIPHY2 (0x21)
Connector at index 1
Type [@offset 46108]: VGA (1)
Encoder [@offset 46112]: INTERNAL_KLDSCP_DAC1 (0x15)
i2cid [@offset 46179]: 0x90, OSX senseid: 0x1
Connector at index 2
Type [@offset 46118]: HDMI-A (11)
Encoder [@offset 46122]: INTERNAL_UNIPHY (0x1e)
i2cid [@offset 46202]: 0x94, OSX senseid: 0x5
[/codebox]

do you have an idea how to solve this?

Kind regards and thanks in advance

#10
tofeeq

tofeeq

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
fistofkhesahn,
Yes I deleted those files from windows and restored the backup to boot again

SliderSD
Would you please tell me what version of mac u have and what steps or kexts or bootloaders should I use with radeonHD to get full hd res.

#11
tofeeq

tofeeq

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
please help me--- 7 hours of continuous trying with no luck
---
I did a bios dump and decode
the results r attached

Attached Files



#12
SliderSD

SliderSD

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

SliderSD
Would you please tell me what version of mac u have and what steps or kexts or bootloaders should I use with radeonHD to get full hd res.


I will take a look at my configuration tomorrow and will come back zu to.

Nevertheless, the RadeonHD way is not really practicable. My laptop gets quite hot a the fan is much louder than under windows. It seems is has something to do with the graphics driver...
Our aim should be to get the mobility 4650 running with the native drivers (and a hex-patched framebuffer) with QE/CI.

Kind regards

#13
max22

max22

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
radeon_bios_decode < 9553.0301.00E0.vga.rom 
ATOM BIOS Rom: 
	SubsystemVendorID: 0x104d SubsystemID: 0x9056
	IOBaseAddress: 0xd000
	Filename: BR34079.001 
	BIOS Bootup Message: 
Sony_M851_M92S2_XT_GDDR3 M92 GDDR3 64bit 680e/800m						  

PCI ID: 1002:9553
Connector at index 0
	Type [@offset 46244]: LVDS (7)
	Encoder [@offset 46248]: INTERNAL_UNIPHY2 (0x21)
Connector at index 1
	Type [@offset 46254]: VGA (1)
	Encoder [@offset 46258]: INTERNAL_KLDSCP_DAC1 (0x15)
	i2cid [@offset 46325]: 0x90, OSX senseid: 0x1
Connector at index 2
	Type [@offset 46264]: HDMI-A (11)
	Encoder [@offset 46268]: INTERNAL_UNIPHY (0x1e)
	i2cid [@offset 46348]: 0x94, OSX senseid: 0x5

redsock_bios_decoder < 9553.0301.00E0.vga.rom
BR34079.001 :

Sony_M851_M92S2_XT_GDDR3 M92 GDDR3 64bit 680e/800m						  

Subsystem Vendor ID: 104d
	   Subsystem ID: 9056
Object Header Structure Size: 193
Connector Object Table Offset: 32
Router Object Table Offset: 0
Encoder Object Table Offset: 93
Display Path Table Offset: 10
Connector Object Id [14] which is [LVDS]
	encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
Connector Object Id [5] which is [VGA]
	encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false
Connector Object Id [12] which is [HDMI_TYPE_A]
	encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
RadeonHD.kext is not necessary for QE.

Here's a linklist with people who have the same problem, no i2cid with radeon_biod_decode on Sony Vaio devices. Maybe one of them will find a solution?

http://wiki.osx86pro...bles#VGN-NW21ZF

yanghy: http://www.insanelym...p...t&p=1658269

moob: http://www.insanelym...p...t&p=1660354

陈小龙: http://www.insanelym...p...t&p=1671489

SliderSD: http://www.insanelym...p...t&p=1680070

kokosnuss: http://www.insanelym...p;#entry1656983

asofan: http://www.insanelym...p...t&p=1724099
http://www.insanelym...p...t&p=1736938

AcidSyl: http://www.insanelym...p...t&p=1725956

#14
max22

max22

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
This guy seems to had progress with his Sony VAIO (but different Radeon)
http://www.insanelym...p...t&p=1686688

He also had the "clouds" which moob had mentioned.

Next time i'll try changing LVDS from (as kizwan had suggested)
02 00 00 00 40 00 00 00 09 01 00 00 12 00 00 00
to:
02 00 00 00 40 00 00 00 09 01 00 00 02 01 00 00
Perhaps this will work?! yanghy suggested 02 as Senseid (last block of numbers).

#15
asofan

asofan

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:yemen
Hi guys,

did any of you get his vaio FW to work with QE/CI on lvds screen? I'm having a problem getting dongs radeon dump reading tool to read my video bios i got from everest. I am getting the same output as SliderSD.

Please help if you have anything to add. the long story of my experiment is in this thread: http://www.insanelym...howtopic=263766

Thanks in advance





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy