Jump to content

Activate TRIM support on any SSD


  • Please log in to reply
54 replies to this topic

#41
pinarek

pinarek

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 643 posts
  • Gender:Male
  • Location:Deutschland

do not use this tool, it will slow down your Snow/Lion System ... I tested this on 128GB SSD C300 and 64GB SSD OCZ ...



YES !! you have full right !!
i have the same Event with my Mushkin and A-Data and Corsair SSD.
All this have SF-Controller and have IGC Option.
The IGC is better as this TRIM !!!
Maby under Windoof work this.
All both is not god !!!!

#42
trexplorer

trexplorer

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
Adding patched kext or using terminal commands did not work for me (X58-UD3R running 10.6.8). Applying the patch finally worked. Xbench no change in speed before / after (330.) 60GB OCZ Vertex 2 (1st gen).

cheers ..

Attached Files

  • Attached File  trim.png   43.98KB   93 downloads


#43
Graebags

Graebags

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Canberra
Ran the terminal command on 10.7 (11a511), and it appears to have activated Trim for my G.Skills Falcon2 and OCZ Agility3 disks. A bit early yet to report beyond that. Thanks for providing it.

#44
JoQ

JoQ

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

Intel SSD 320: (80Gb)

Works fine with H55M-UD2H, xBench gives 260 before and 300 after trim activation.

On G31M-ES2L however, the status does not show up at all, and after some research it looks like ich7 doesn't really support trim, or you need some special windows drivers. Too bad.

Damn, I had no idea GA-G31M-ES2L didn't support SSD? I just bought a Intel X25-M G2 disk and when checking disk info the Protocol says ATA and not SSD as others, and running Trim Enabler doesn't do any difference, Trim doesn't even show up as "No".

Any more experience to share?
Thanks!

#45
teme

teme

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
just tried it on my hack running 10.6.7
i get this
SSD G2 series 64GB:

  Capacity:	60.02 GB (60,022,480,896 bytes)
  Model:	SSD G2 series 64GB					  
  Revision:	3.4.3   
  Serial Number:	10000000000000000680
  Native Command Queuing:	Yes
  Queue Depth:	32
  Removable Media:	Yes
  Detachable Drive:	No
  BSD Name:	disk1
  Medium Type:	Solid State
  TRIM Support:	Yes
  Partition Map Type:	GPT (GUID Partition Table)
  S.M.A.R.T. status:	Verified
  Volumes:
  Capacity:	209.7 MB (209,715,200 bytes)
  Writable:	Yes
  BSD Name:	disk1s1
Macintosh SSD:
  Capacity:	59.68 GB (59,678,507,008 bytes)
  Available:	51.61 GB (51,611,791,360 bytes)
  Writable:	Yes
  File System:	Journaled HFS+
  BSD Name:	disk1s2
  Mount Point:	/

I see Trim Support: Yes. Does it means i'm good to go?

Thanks

#46
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • News Team
  • 1,154 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
Yep it's good to go. You'll most likely see TRIM support unless your drive somehow doesn't support it, your mobo doesn't support SSD's or if you RAID em.

#47
JuniorGump

JuniorGump

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Paraíba, Brasil
Working on Lion =D

#48
teme

teme

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts

Yep it's good to go. You'll most likely see TRIM support unless your drive somehow doesn't support it, your mobo doesn't support SSD's or if you RAID em.


sweet
thank you Sir :)

10.6.8 keeps hanging on my SSD, with or without the TRIM enabler
guess i'll stay on 10.6.7 in the meantime.

Question; does this tool work for Lion, or is it not needed over there?

thanks

#49
afiser

afiser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
Anyone else get orange icon's (unknown achi controller) when patching for trim?

#50
twitterers

twitterers

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Installed on Mac OS X 10.7.2 No issues

#51
westwaerts

westwaerts

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 879 posts
  • Gender:Male
konsole says TRIM ON,
trim says NOT WORKING,
sys profiler says TRIM NO

version 2 beta 4.0 on samsung 830 64GB, rebooted,

so i did it the manual method, edited the kext in hexeditor
(APPLE SSD replaced with the name of my drive (first 9 digits))
and it works.

#52
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Ok in ML 10.8.0

sudo perl -pi -e 's|\x41\x50\x50\x4C\x45\x20\x53\x53\x44|\x00\x00\x00\x00\x00\x00\x00\x00\x00|g' /System/Library/Extensions/IOAHCIFamily.kext/Contents/PlugIns/IOAHCIBlockStorage.kext/Contents/MacOS/IOAHCIBlockStorage



#53
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,415 posts
  • Gender:Male

Ok in ML 10.8.0



If users dont use ioahciblockstorage?

#54
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
What are you

If users dont use ioahciblockstorage?


Impossible! :P

Take a look in IOAHCIFamily.kext, you'll find it there ;)



#55
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,415 posts
  • Gender:Male
Ok ...thz





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy