Jump to content

ASUS G73JH - Mac OS X 10.6.6 - All is WORKING!


  • Please log in to reply
228 replies to this topic

#121
jackxlj

jackxlj

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 10 posts

As stated by the OP, doesn't the boot file need to be replaced? I can't seem to find the directory where its located.



i didnt touch the boot file,i installed sl, restarted,updated to 10.6.7, installed ##### and the assorted kexts, installed chameleon, copied the extra folder over to root, restarted, and now the chameleon menu asks if i want to boot into my osx hdd or my windows hdd

#122
driftingbunnies

driftingbunnies

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
There is no need to replace the boot file after using the ATI drivers in the new #####.

For those of you who are still having trouble please look here. I will try to put down as much detail as possible but because i'm not reinstalling at the moment, it might be off.

1. Prepare hard drive for installation. Backup all important information in the hard drive you are installing into. If you want, you can remove the other hard drive just in case. Do not need to remove memory.
2. insert #####
3. insert SL disk, press F5, and install SL
4. Make sure hard drive is reformatted to GUID partition.
5. Install OSX, restart
6. insert ##### and select OSX
7. open up ##### but do not install yet
8. Install combo update 10.6.7
9. do not restart after combo update. Install #####
10. select ##### for now, with the voodoo PS2 options, SATA, ATI kernal, Macbook pro definition, and the OSX software (kexthelper etc)
11. Install chameleon and prefpane
12. Replace Extra folders into root of OSX drive
13. Restart
14. Install rest of Kexts (voodooHDA, Applehdadisabler, LAN, wifi)
15. Place DSDT in extra folder. in prefpane of chameleon, select DSDT that you will be using.

There is no need for the boot file anymore and the ATI rom file found in the original extra folder by Pavol is not needed.

#123
mikedmor

mikedmor

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 3 posts
Ok let me state that after following driftingbunnies method sleep still does not work for me, and im still having issues finding any network that is running on wireless N. Sleep is honestly the biggest thing for me. Once i get sleep working Windows is getting completely removed off of my computer.

I did notice something different after adding DSDT in the prefpane. My monitor never came back on just like normal, but after i restarted my computer it began to restore back to how it was when i put it to sleep. only issue was my wifi, touchpad, keyboard, and usb ports were not working anymore.

#124
QuistisTrepe

QuistisTrepe

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 11 posts

There is no need to replace the boot file after using the ATI drivers in the new #####.

For those of you who are still having trouble please look here. I will try to put down as much detail as possible but because i'm not reinstalling at the moment, it might be off.

1. Prepare hard drive for installation. Backup all important information in the hard drive you are installing into. If you want, you can remove the other hard drive just in case. Do not need to remove memory.
2. insert #####
3. insert SL disk, press F5, and install SL
4. Make sure hard drive is reformatted to GUID partition.
5. Install OSX, restart
6. insert ##### and select OSX
7. open up ##### but do not install yet
8. Install combo update 10.6.7
9. do not restart after combo update. Install #####
10. select ##### for now, with the voodoo PS2 options, SATA, ATI kernal, Macbook pro definition, and the OSX software (kexthelper etc)
11. Install chameleon and prefpane
12. Replace Extra folders into root of OSX drive
13. Restart
14. Install rest of Kexts (voodooHDA, Applehdadisabler, LAN, wifi)
15. Place DSDT in extra folder. in prefpane of chameleon, select DSDT that you will be using.

There is no need for the boot file anymore and the ATI rom file found in the original extra folder by Pavol is not needed.


Sigh....well I got greedy and went with UserDSDT and now I have a Mac install that goes into safe mode, but Kernel Panics when booting normally. I suppose it might just be better for me to start from scratch rather than trying to fix what I have going on right now. Alright, ##### it is then. I'll stick to the order you posted here in regards to copying extras over to root AFTER running #####.

#125
driftingbunnies

driftingbunnies

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

Ok let me state that after following driftingbunnies method sleep still does not work for me, and im still having issues finding any network that is running on wireless N. Sleep is honestly the biggest thing for me. Once i get sleep working Windows is getting completely removed off of my computer.

I did notice something different after adding DSDT in the prefpane. My monitor never came back on just like normal, but after i restarted my computer it began to restore back to how it was when i put it to sleep. only issue was my wifi, touchpad, keyboard, and usb ports were not working anymore.



Well the sleep doesn't work for anybody. Mine will "sleep" and on wake, I just have to restart it so there's no point in sleeping. Might as well shut it down. Also, the DSDT will only work if you have the same stuff as me. So it would be better if you patch your own DSDT or ask maldon to help you out. Someone mentioned a G73 patcher so maybe there's one out right now. I never was able to fix the wifi problem so I just went out and bought a compatible card. If you really want to get sleep to work, you can help us by learning DSDT edits and figuring out which what works for you. It would help out tremendously.

#126
RozZy_

RozZy_

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
After 3 constant days of learning Hackintosh and everything, i finally got this working. (IATKOS S3 v2)

Just 1 problem.

The WIFI (Atherosl1cethernet.kext) Doesn't wanna work (Doesn't even start even after installing the kext).
I know it's not working on N network, but i cant get it to even start.. i reinstalled the kext A LOT of times now.

And now I noticed that it randomly crashes while I'm in the os.
Should I re install the os again and do a clean setup instead of adding stuff in the installation?

#127
driftingbunnies

driftingbunnies

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

After 3 constant days of learning Hackintosh and everything, i finally got this working. (IATKOS S3 v2)

Just 1 problem.

The WIFI (Atherosl1cethernet.kext) Doesn't wanna work (Doesn't even start even after installing the kext).
I know it's not working on N network, but i cant get it to even start.. i reinstalled the kext A LOT of times now.

And now I noticed that it randomly crashes while I'm in the os.
Should I re install the os again and do a clean setup instead of adding stuff in the installation?



That kext is for the LAN. the WIFI kext is the IOfamily one.

#128
RozZy_

RozZy_

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

That kext is for the LAN. the WIFI kext is the IOfamily one.



ah.. but i've done the same thing with that one and no change:(

And I'm having these random crashes while I'm using the computer.. maybe a conflicting kext thanks to the IATKOS kexts?


Thanks in advance, you guys ROCK.

#129
QuistisTrepe

QuistisTrepe

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 11 posts
Followed driftingbunnies' prompts and now I finally have a stable Mac OS install after several days of many kernel panics.

By the way, anyone happen to know a kext for an Intel 6300 Ultimate-N wireless card? I ditched the Atheros {censored} when I learned it wasn't a dual-band card and a poor 2.4ghz N card at that.

Thanks again bunnies! Now I need to grab the LAN kext so I can get my Mac online.

#130
gregmattersen

gregmattersen

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 2 posts
Thanks to everyone who helped with this, I'm running 10.6.7 finally!

However, I can't seem to get wifi working. I installed the kext along with the LAN and audio kexts. They both seemed to work fine, but no luck with the wifi, any advice?

#131
QuistisTrepe

QuistisTrepe

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 11 posts
So I've run into one last brick wall. This is going to sound ridiculous, but how do you install individual kexts?

I'm trying to get an ethernet connection going on my machine, I've seen the kext for the Atheros AR8131, but I'm not sure how to install it. I've played around with the editor to no avail.

I think it went something like Atheros|1cethernet.kext Now I just need to figure out how to implement it.

#132
RozZy_

RozZy_

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

So I've run into one last brick wall. This is going to sound ridiculous, but how do you install individual kexts?

I'm trying to get an ethernet connection going on my machine, I've seen the kext for the Atheros AR8131, but I'm not sure how to install it. I've played around with the editor to no avail.

I think it went something like Atheros|1cethernet.kext Now I just need to figure out how to implement it.




I have the same problem with the WiFi. Intel N 6300. googled it. don't think theres any kext for it so we are pretty {censored}ed.
But i'm still having random crashes when i run a lot of processes, you get that blackscreen window that tells you to restart the computer.

Maybe some processor thing?

#133
driftingbunnies

driftingbunnies

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
I had the 6200 and i switched back to the stock card in order to get it to work. I'm not sure why you guys are all having trouble with the wifi. That's something that always worked for me. Is it because you only have a wireless N network? Wireless N networks do not work with the card. If you want your card to work flawlessly, I would suggest getting a dell 1510 and reinstalling. That way, it'll work 100% OOB. If you don't want to buy it, try setting your router to b/g and see if your wifi works.

To install kexts, use the kexthelper in your Applications folder. After you install, run the kext ultility to repair and then restart.

#134
gregmattersen

gregmattersen

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 2 posts

I had the 6200 and i switched back to the stock card in order to get it to work. I'm not sure why you guys are all having trouble with the wifi. That's something that always worked for me. Is it because you only have a wireless N network? Wireless N networks do not work with the card. If you want your card to work flawlessly, I would suggest getting a dell 1510 and reinstalling. That way, it'll work 100% OOB. If you don't want to buy it, try setting your router to b/g and see if your wifi works.

To install kexts, use the kexthelper in your Applications folder. After you install, run the kext ultility to repair and then restart.


This is exactly how I installed the kext, i get no airport options at all in osx, no network options for any wifi things whatsoever.

EDIT: I figured out my problem, I have the Intel Centrino Advanced N 6250 Wifi Card, not the Atheros. Can't find any kexts for it, ordering usb wifi, thanks again for all the help in this post!

#135
RozZy_

RozZy_

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Just realized i have the same card as him too, the intel N 6300..

So i bought the Asus USB-N13. Works like a charm, 27 bucks at Fry's.

#136
RozZy_

RozZy_

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Do you guys get your laptop keyboard and touchpad to work????

#137
driftingbunnies

driftingbunnies

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Make sure you have all the PS2 kexts installed.

#138
ditbonjour

ditbonjour

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:France
Hi all thanks for all the help to install osx on G73jh family.
But could someone post an archive with all the file needed to install correctly osx.
I think you could also post the solution on this : http://wiki.osx86pro...x.php/Main_Page.

Thanks to all !!!!

#139
marcos178

marcos178

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Spain
I'm got one dude, when I restart all Ok, but when I shutdown I only see one blue screen, and I need press the Shutdown button for Final Shutdown, and there are any fix for the sleep?

#140
spiderrobot

spiderrobot

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 2 posts
Hi I Have Every Thing Working KINDA...

Under The Specs And Stuff It Only Says ATI Radeon 5000 But I Have A 5870

Another Thing My Mac Install Once And A While When Im Using It It Will Kernal Panic (GO GREY)

And I Can Only Connect To None Secured Networks Over Wifi

I Dont Know How To Install The dsdt, what does it do, do i need it :( :) :wacko: ????

NOTE: I Followed This By Driftingbunnies

I basically did what Franula did.1. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]2. Install SL (partition according to tonymacx depending on what you want)3. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] into OSX after installation is done4. Boot up [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.4. don't install yet5. Install 10.6.7 combo update6. Install [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. (select ATI drivers, touchpad, all misc except EvOReboot and NULLCPU and USB 3.0)Select Macbookpro 6,17. Install chameleon8. Copy Extra folder over.9. Reboot10. Install audio drivers (probably need to install disabler too) and LAN driver.Except This:11. install chameleon prefpane. Copy DSDT to EXTRA folder and use the prefpane to link the DSDT to chameleon.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy