Jump to content

ATI MOBILITY 5650 WORKING FULL RES QE/CI ***FB EULEMUR***


  • Please log in to reply
51 replies to this topic

#21
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts

Any news atlee? I cant even get my external monitor to' work though I've got a dv6-3103sl which is very similar to yours.
Please help me get at least external monitor. This is what I've done:

1. From my other hack I installed 10.6.3 on my external hd
2. Then applied 10.6.6
3. Overwrite the 4 kexts with the ones provided here.
4. Installed cham, patched kernel and kexts

then i attached my to' laptop and tried to' boot, but i got only my laptop display to' work (without qe/ci)

what's wrong?


Nevermind, I got it working...Strange thing...As in your pictures I can't get the menu bar to be translucent...Why is that? Do we really have graphic acceleration?

#22
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
just got up and booting again, DSDT was a biatch for this system, without it my USB wouldn't work properly. Now to work on the 10.7 kexts, really want the LCD to glow :(

#23
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male

Nevermind, I got it working...Strange thing...As in your pictures I can't get the menu bar to be translucent...Why is that? Do we really have graphic acceleration?


Can you run Front Row or DVD player?

#24
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts

Can you run Front Row or DVD player?


No, I can't :)

#25
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
Front Row uses QE/CI so you don't have it. It happened the same to me with my mobility 4570. Framebuffer loads and HDMI port works (with 10.7 kext and modding 10.6 kext), all ATI's kext seems to be loaded but QE/CI isn't working. We have to do something more :(

#26
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
let me do more testing, retrying a few things with 10.6.6 kexts, megaloden, vervet, nomascus do not work. im using ati version of rc5 from this ati thread. i can get atiframebuffer, atiradeonx3000 and atisupport to load, just need ati5000controller to kick start :wacko:

#27
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male

let me do more testing, retrying a few things with 10.6.6 kexts, megaloden, vervet, nomascus do not work. im using ati version of rc5 from this ati thread. i can get atiframebuffer, atiradeonx3000 and atisupport to load, just need ati5000controller to kick start :wacko:


Is your ID in ati5000controller.kext?? If it is it should load.

#28
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia

Is your ID in ati5000controller.kext?? If it is it should load.


it's definitely in there, just going to fix my DSDT then retry with nomascus, will update here soon.

#29
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
How should one choose which fb to use? Are you trying randomly? Isn't it something specific to the video card?

While trying to extract my VBIOS with atiflash (unuccessfully) i read "Redwood" near my adapter. Then I found out that redwood is a fb. Am I wrong thinking that trying to get qe/ci working I should always use Redwood with AtiConfig (Kabyl's boot).

Has anyone managed to extract his Vbios to use it with kabyl's boot? ( http://www.insanelym...howtopic=231768 )

#30
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
If external get's QE/CI using Megalodon as FB, I'm going to try and create a DSDT fix to pump the same also into the LCD display. Will try and let you know ;) I'm back to 10.6.6 kexts.

#31
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
I'd be more than happy to have qe/ci at least on my external monitor ;)

#32
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia

I'd be more than happy to have qe/ci at least on my external monitor ;)


Install the ATI r700 bootloader, then add AtiConfig=Megalodon to your boot plist then install the 10.7 kexts I have here and you can get external monitor, As you can see in my picture I got QE/CI.

This is taking too much of my time up, have two units to study if someone wishes to mix and match FB's to get the correct one then go ahead :D

#33
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male

Install the ATI r700 bootloader, then add AtiConfig=Megalodon to your boot plist then install the 10.7 kexts I have here and you can get external monitor, As you can see in my picture I got QE/CI.

This is taking too much of my time up, have two units to study if someone wishes to mix and match FB's to get the correct one then go ahead ;)


Are you sure that you have QE/CI? I could do the xbench's test without having QE/CI. Can you use Front Row, DVD player, etc?

#34
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
i will go do a quick test and let you know, really dont have time to try all those huge list of FB's :D

Edit: Nope cannot use DVD or Frontrow, back to square one :/ will have to try a DSDT method.

The drivers displays via DisplayPort so if you have a laptop with a DP use it then do this trick either using 10.6.6 kexts or 10.7, i'm trying to do a DSDT that connects at GFX1, VGA0

I'm also guessing we are all using the wrong Framebuffer, my laptop only has 3 outputs, HDMI, Internal LCD and VGA so my Framebuffer needs to be either:
{"Quail", 3}, {"Raven", 3}, {"Shrike", 3},


{"Langur", 3}, {"Megalodon", 3},

{"Kakapo", 3},{"Gliff", 3}, {"Hoolock", 3},

{"Eulemur", 3}, {"Flicker", 3},

{"Baboon", 3},



One of these guys. So please go ahead and test them. 3 corresponds to how many outputs. Mine has 3 so it might be one of these framebuffers. Try with 10.6.6 kexts. Install all kexts except for ATI5000Controller and see if you can reach Desktop with GraphicsEnabler=Yes. 

#35
mojtabazarei

mojtabazarei

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:IRAN

i will go do a quick test and let you know, really dont have time to try all those huge list of FB's :(

Edit: Nope cannot use DVD or Frontrow, back to square one :/ will have to try a DSDT method.

The drivers displays via DisplayPort so if you have a laptop with a DP use it then do this trick either using 10.6.6 kexts or 10.7, i'm trying to do a DSDT that connects at GFX1, VGA0

I'm also guessing we are all using the wrong Framebuffer, my laptop only has 3 outputs, HDMI, Internal LCD and VGA so my Framebuffer needs to be either:
{"Quail", 3}, {"Raven", 3}, {"Shrike", 3},


{"Langur", 3}, {"Megalodon", 3},

{"Kakapo", 3},{"Gliff", 3}, {"Hoolock", 3},

{"Eulemur", 3}, {"Flicker", 3},

{"Baboon", 3},



One of these guys. So please go ahead and test them. 3 corresponds to how many outputs. Mine has 3 so it might be one of these framebuffers. Try with 10.6.6 kexts. Install all kexts except for ATI5000Controller and see if you can reach Desktop with GraphicsEnabler=Yes.


my 5730 have 4 port but i can see 2 external of theme vga and hdmi the display port is in laptop

i think 5650 is same as mine . & one is internal for lcd

what you mean of install 10.6.6

1.install 10.6.6 kext and install ATI5000Controller of 10.7 or don't install any

ATI5000Controller which one of theme ?

#36
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male

i will go do a quick test and let you know, really dont have time to try all those huge list of FB's :(

Edit: Nope cannot use DVD or Frontrow, back to square one :/ will have to try a DSDT method.

The drivers displays via DisplayPort so if you have a laptop with a DP use it then do this trick either using 10.6.6 kexts or 10.7, i'm trying to do a DSDT that connects at GFX1, VGA0

I'm also guessing we are all using the wrong Framebuffer, my laptop only has 3 outputs, HDMI, Internal LCD and VGA so my Framebuffer needs to be either:
{"Quail", 3}, {"Raven", 3}, {"Shrike", 3},


{"Langur", 3}, {"Megalodon", 3},

{"Kakapo", 3},{"Gliff", 3}, {"Hoolock", 3},

{"Eulemur", 3}, {"Flicker", 3},

{"Baboon", 3},



One of these guys. So please go ahead and test them. 3 corresponds to how many outputs. Mine has 3 so it might be one of these framebuffers. Try with 10.6.6 kexts. Install all kexts except for ATI5000Controller and see if you can reach Desktop with GraphicsEnabler=Yes. 


Really doesn't matter the number of ports of your FB. Now I'm using Vervet(4) modded with my senseID ports and HDMI is working and my Internal Display is detected but not working (black screen). The important thing it's that your connector type and sense ID are well detected.

If you can't run Front Row or DVD player you don't have QE/CI. The both uses it.

#37
mojtabazarei

mojtabazarei

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Location:IRAN
with installing 4 10.7 kexts without kalby boot loader and any FB i have external monitor working

without QE/CI

after installing kalby boot loader and FB graphic string in chameleon (com.plist)

laptop lcd doesn't work but

result for external monitor :


Alopias		work without qe/ci

Alouatta	   work without qe/ci

Baboon		 work without qe/ci

Cardinal	   work without qe/ci

Caretta		work without qe/ci

Colobus		not work

Douc		   not work

Eulemur		work without qe/ci

Flicker		work without qe/ci

Galago		 not work

Gliff		  work without qe/ci

Hoolock		work without qe/ci

Hypoprion	  work without qe/ci

Iago		   work without qe/ci

Kakapo		 work without qe/ci

Kipunji		work without qe/ci

Lamna		  work without qe/ci

Langur		 work without qe/ci

Megalodon	  work without qe/ci

Motmot		 work without qe/ci

Nomascus	   not work

Orangutan	  not work

Peregrine	  work without qe/ci

Quail		  work without qe/ci

Raven		  work without qe/ci

Shrike		 work without qe/ci

Sphyrna		work without qe/ci

Triakis		work without qe/ci

Uakari		 not work

Vervet		 not work

Zonalis		not work


you see there isn't any changes with boot loader and FB

#38
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts

with installing 4 10.7 kexts without kalby boot loader and any FB i have external monitor working

without QE/CI

after installing kalby boot loader and FB graphic string in chameleon (com.plist)

laptop lcd doesn't work but

result for external monitor :


Alopias		work without qe/ci

Alouatta	   work without qe/ci

Baboon		 work without qe/ci

Cardinal	   work without qe/ci

Caretta		work without qe/ci

Colobus		not work

Douc		   not work

Eulemur		work without qe/ci

Flicker		work without qe/ci

Galago		 not work

Gliff		  work without qe/ci

Hoolock		work without qe/ci

Hypoprion	  work without qe/ci

Iago		   work without qe/ci

Kakapo		 work without qe/ci

Kipunji		work without qe/ci

Lamna		  work without qe/ci

Langur		 work without qe/ci

Megalodon	  work without qe/ci

Motmot		 work without qe/ci

Nomascus	   not work

Orangutan	  not work

Peregrine	  work without qe/ci

Quail		  work without qe/ci

Raven		  work without qe/ci

Shrike		 work without qe/ci

Sphyrna		work without qe/ci

Triakis		work without qe/ci

Uakari		 not work

Vervet		 not work

Zonalis		not work


you see there isn't any changes with boot loader and FB


How are you using kalby's boot? Isn't the video card bios a requirement? From what I read in the source code mobility series aren't supported at all by kabyl's boot...

#39
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
I have tried every FB using 10.6.6 kexts, With GraphicsEnabler=Yes and No, No makes the desktop not load, Yes either causes freeze, restart, scrambled screen or 4 FB's switches to full resolution then black screen.

10.7 kexts get to the desktop with Yes or No Enabled, i'm sure 10.7 has support just have to retry all fb's :rolleyes: anyway i got some work to do with school but i will test more later.




you dont need the cards bios to boot your card.

#40
hjs89

hjs89

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male

I have tried every FB using 10.6.6 kexts, With GraphicsEnabler=Yes and No, No makes the desktop not load, Yes either causes freeze, restart, scrambled screen or 4 FB's switches to full resolution then black screen.

10.7 kexts get to the desktop with Yes or No Enabled, i'm sure 10.7 has support just have to retry all fb's :rolleyes: anyway i got some work to do with school but i will test more later.




you dont need the cards bios to boot your card.


Maybe 10.6.6 kext are working with QE/CI but you have a problem with framebuffer.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy