Jump to content

[HowTo] Get the 2nd gen. EAX1600XT SILENT working (black heatsink)


  • Please log in to reply
88 replies to this topic

#1
tha_toadman

tha_toadman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 336 posts
  • Gender:Male
Asus EAX1600XT PCIe Full Support Solution

Credit goes out to borisbadenov for getting the official Apple drivers to work with X1600 cards (and dealing with all my PM's too).

- X1600 cards have been known to work (and may work for X1800 too)
- 10.4.6 and the JaS 10.4.7 update have been tested and work
- DVI support (worked for me), also Sleep, Rotation, etc...all working!

Also note you need a 10.4.6 (and/or 10.4.7 update) installation, and an ATI X1600 (or X1800-based card.)

How to Apply the Patch:

1)Remove all GeForce and ATIRadeon kexts from /System/Library/Extensions EXCEPT:

ATIRadeonX1000.kext
ATIRadeonX1000GA.plugin
ATIRadeonX10000GLDriver.bundle
ATIRadeonX1000VADriver.bundle
ATINDRV.kext

2) Open a terminal and type:

sudo -s (and enter your password)
cd /System/Library/Extensions/ATINDRV.kext/Contents/
emacs Info.plist

Find where it says:
<string>IONDRVDevice</string>

and modify it to read:
<string>IOPCIDevice</string>

Now find where it says:
<string>ATY,Wormy</string>

and modify it to read:
<string>display</string>

Press and hold Ctrl key and press X then C to exit. Press 'y' to save the file before you exit.

Now time to clean up and get ready to boot.

Type:

rm /System/Library/Extensions.mkext
rm /System/Library/Extensions.kextcache
diskutil repairPermissions /

Reboot now and you should have full support. :D

Those of you with AGP cards, X1800 cards, etc. could help everyone out by posting your findings here. A thanks also goes out to 'barnz0432' in boris's thread for providing the info. I had almost given up and went with a Sapphire card but "patience is a virtue." :thumbsup_anim:

By the way, this all stemmed from this thread and the troubles we were having.

UPDATE: there's now a 3rd gen. ASUS card thats out and it sounds like people aren't having much luck with it. This method does not work and it's been reported that the Neophus method doesn't work either. I'll try to update this as more info is available.

#2
Superhai

Superhai

    InsanelyMac Legend

  • Retired Developers
  • 1,425 posts
I cannot see any difference from earlier posts.

#3
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male
No editing of ATIRadeonX1000.kext or ATIRadeonX1000GA.bundle

#4
DrXenon

DrXenon

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
I don't see any difference from earlier posts, either. That said, I just did it and IT WORKS!!! If I was a hot girl, I would totally sleep with the Toadman.

#5
tha_toadman

tha_toadman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 336 posts
  • Gender:Male

No editing of ATIRadeonX1000.kext or ATIRadeonX1000GA.bundle


exactly...no editing of those. just the ATINDRV.kext is it.

as always, milage may vary but this solved my issues (and I hope it does for others too).

#6
bofors

bofors

    ConvertIt2Mac.com

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,462 posts

- DVI support (worked for me), also Sleep, Rotation, etc...all working!
...
Reboot now and you should have full support. :thumbsup_anim:


Does your VGA output work too?

How about dual displays in extended desktop mode?

#7
tha_toadman

tha_toadman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 336 posts
  • Gender:Male

Does your VGA output work too?

How about dual displays in extended desktop mode?


I believe VGA was working as well but I don't have a 2nd monitor to test the extended desktop.

With my mobo though, I thought that maybe if I needed it, I'd add an ADD2 card later but for now the ASUS is working great.

#8
DrXenon

DrXenon

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
I can confirm that the VGA output works; I'm using it with my CRT.

#9
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male

No editing of ATIRadeonX1000.kext or ATIRadeonX1000GA.bundle


I'd like to point out that this has been proposed before but didn't get much attention:

http://forum.insanel...&...st&p=153492

#10
bofors

bofors

    ConvertIt2Mac.com

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,462 posts

I can confirm that the VGA output works; I'm using it with my CRT.


Do you have a second monitor to try extended desktop mode with?

#11
tha_toadman

tha_toadman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 336 posts
  • Gender:Male

I'd like to point out that this has been proposed before but didn't get much attention


I know this and that's why I put his name in at the end of the post. I gave him credit for it and that method worked for me so I'm sharing the info with everyone here and the others in the thread below that who were having the same issues as I was.

I gave the credit where it was due and am trying to help roughly 10 or 15 others in that thread so maybe this should have gotten more attention than it was given, perhaps? check the thread cuz we were all struggling with it. heck i even pm'ed boris about all of this.

#12
DrXenon

DrXenon

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

Do you have a second monitor to try extended desktop mode with?


Sorry, no second monitor.

#13
Superhai

Superhai

    InsanelyMac Legend

  • Retired Developers
  • 1,425 posts

I'd like to point out that this has been proposed before but didn't get much attention:


I know, I have always said this about the .bundle files. It is no use to edit them. The X1000.kext is not needed to edit if your pci id is already there...

I think why it is working now is because you have not deleted your extensions files or/and been sloppy with the permissions.

#14
Jemm

Jemm

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
This most definitely does not work with my EAX1600XT Silent. I tried it along with all the other solutions and patches, along with every possible combination of kexts and edits and OS versions.

It is great to hear that it works for some, but if you find that it does not, you may find that the solution requires flashing your card, as I have described elsewhere.

Trying this first is undoubtedly less dangerous.

Jemm

#15
bofors

bofors

    ConvertIt2Mac.com

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,462 posts
How can we tell which EAX1600XT Silent's this will work on? Which ones are "newer"? Does it depend on the firmware version?

#16
tha_toadman

tha_toadman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 336 posts
  • Gender:Male

By the way, this all stemmed from this thread and the troubles we were having.


look at the hyperlink in the word 'thread' above

in that thread, we'd already established that there's 2 versions of this card. this post was for the cards with the black heat sink on them (which i have). this was intended for that crowd. i hope i'm not confusing people now.

as for the firmware, i haven't checked my version yet. i figured that was a windows utility but if there's a way i can provide that here, someone let me know, i'd be more than happy to share it with you, bofors.

edit: bofors, here's what I have discovered...when i rebooted and took the DVI out, i went with VGA. i booted into a nasty 800x600 but i could change the resolution and such. now, when i connected the DVI to VGA adapter into the DVI port...my screen went blue and then came back (not sure what to think but something happened). perhaps this extended desktop will work so I will be trying here soon to get a male/male VGA adapter for my video card and will try to display the video on my wife's laptop as a 2nd display. i hope it works but we might be on to something...

#17
bofors

bofors

    ConvertIt2Mac.com

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,462 posts

... so I will be trying here soon to get a male/male VGA adapter for my video card and will try to display the video on my wife's laptop as a 2nd display. i hope it works but we might be on to something...


Great, looking forward to hearing your results. Thank you.

#18
tha_toadman

tha_toadman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 336 posts
  • Gender:Male

Great, looking forward to hearing your results. Thank you.


Bummer. I get dual displays of a single desktop. I don't have 'mirror' - it's "off" and thats about it. I wished I had better news for ya, bofors. It was worth a shot though.

#19
torque64

torque64

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
thanks again toad!

Just wanted to add that even though it was pointed out that it indeed was discussed before, that never the less it was really good of you to distill and refine the method into a clear and accessible guide. I know that I myself went through most of the forums searching for as much info on the Asus X1600XT and missed that section... which inst surprising considering theres over 60pages of forum threads to go through.

So yeah, thanks for taking the time to post this. I myself am STILL waiting for my Asus EAX1600XT to arrive after being delayed in transit... apparently. So I'll post my experiences with it when I finally get it in a few days time.

Jemm - can you provide some more information as to what model you have as well as what 'distribution' of MacOSX your using?? (eg. 10.4.6/7 Jas VS 10.4.5 Myzar). And any other relevant info.

Its kindof annoying when someone lists a problem yet doesnt make it clear what specs they have and what circumstances the problem arose in. It may very well not have anything to do with the card.. and might just be the different distribution... or it may be the problem of the new vs old cards.

Either way, the only way we can all figure out solutions together is if we are all being clear with our problems. :(

#20
bofors

bofors

    ConvertIt2Mac.com

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,462 posts

Bummer. I get dual displays of a single desktop. I don't have 'mirror' - it's "off" and thats about it. I wished I had better news for ya, bofors. It was worth a shot though.


Mirroring is better than nothing. Thanks for trying.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy