Jump to content

64 bit on Asus G51JX-A1


  • Please log in to reply
5 replies to this topic

#1
sparkythewondersquid

sparkythewondersquid

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 209 posts
  • Gender:Male
  • Location:Chouteau, Montana
Hello all
After many days I finally got SL working on my ASUS G51JX but if I boot into 64 bit it gets to firewire and booting goes no further any ideas? any one?
**EDIT** It would seem the appleRTC.kext is not loading in 64 bit mode any ideas any one?

#2
bigbang29

bigbang29

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Hello all
After many days I finally got SL working on my ASUS G51JX but if I boot into 64 bit it gets to firewire and booting goes no further any ideas? any one?
**EDIT** It would seem the appleRTC.kext is not loading in 64 bit mode any ideas any one?


The problem for me was LegacyAppleRTC.kext in /E/E when running in 64 BIT . Delete it or everything with RTC in E/E . Then use NullCPUPowermanagement.kext . It will disable Other RTC kext in /S/L/E.

Run pfix , boot with -f...

Then if you got problem with restart or shutdown try to use EvoReboot.kext, with sleep -> sleepenabler.kext.

I would also recommand you to use latest Chameleon (with Cstate and P State generating). If you want an installer try "Chameleon RC5 trunk 619" you will see a post from this great site !




or find dsdt fix ... ;) and delete everything with RTC in /E/E

#3
sparkythewondersquid

sparkythewondersquid

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 209 posts
  • Gender:Male
  • Location:Chouteau, Montana
Thank you for the reply the problem seemed to have worked out itself (sort of) I did a fresh install used "arch=x86_64" from first boot did the update to 10.6.4 added the boot prompt to boot.plist and its good now any word on the sound? I had it working but had to turn the mic down at every boot looking for a better solution

#4
sparkythewondersquid

sparkythewondersquid

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 209 posts
  • Gender:Male
  • Location:Chouteau, Montana
After installing on an Asus 1201PN netbook it worked I had the same problem and deleted the RTC kext from extra/extensions and it booted into 64 bit fine the first boot was very slow but now booting normally thank you again I had to return the G51 and exchange it something was wrong with it so when I reinstall I will know what to do

#5
redhead22

redhead22

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
where can I get the OSX86 software? I would like to put it on my ASUS G71GX laptop?

#6
sparkythewondersquid

sparkythewondersquid

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 209 posts
  • Gender:Male
  • Location:Chouteau, Montana
Use retail install method its a little more work (these days not that much at all) is yours the one with Nvidia GTX 260M (rx05) if so it is not hard at all I think there is a version of that with ATI post your specs there are alot of very helpful people here ;)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy