Jump to content

Sony Vaio VPCF115FM Discussion: DSDT Injection


  • Please log in to reply
776 replies to this topic

#41
mathewthegreat

mathewthegreat

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Guys, i am in the same boat but with VPCCW21FX.

Successful install with install from Empire EFI 1.85 R2 + retail dvd.

Updated to 10.6.3 with combo update and also macbook pro update 1.3.

Now booting using chameleon v2.0 - RC5pre7 r141, can use internal display by default but with no QE.

Using bootflags: /mach_kernel -x64 GraphicsEnabler=YES

GraphicsEnabler=YES gives me QE over VGA on my external monitor which is detected as Acer "H233H" (correct) and i get all resolutions.

What doesnt work:

QE w/Internal LED display

Atheros 9285 wireless

Marvell Yukon 88E8057

Nvidia/Intel realtek HD audio



Pretty sure this is a DSDT issue, any assistance would be greatly appreciated, what do you need from me if you were to assist me?

Thanks much!

Mat

#42
goila

goila

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Yes I can but I think it best to wait for results from Mammoth, gi�49 & PlumberGr. If the result is promising, I will modify your DSDT.


OK! :(

thanks

#43
cloud03

cloud03

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

I forgot one thing, sorry. :P Please provide me your graphic card ROM file. You can obtain it using GPU-Z application in windows. This is to construct correct NVCAP. Do you have display on internal LCD with both GraphicsEnabler=No & GraphicsEnabler=Yes? If yes, I think I can get it to works.

I'll start working on it. I hope you have better luck than other VAIO owner. :)


Unfortunately I haven't been able to retrieve the vga bios, using both GPU-Z and latest nvflash, it simply tells eeprom not supported (unknown), is there any other way to retrieve it? I've google it but haven't found other option to do this...

And without GraphicsEnabler I got a working internal LCD with no QE/CI, and max res at 1280 x 1024, with GraphicsEnabler=yes it turned off the internal lcd..

#44
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

Unfortunately I haven't been able to retrieve the vga bios, using both GPU-Z and latest nvflash, it simply tells eeprom not supported (unknown), is there any other way to retrieve it? I've google it but haven't found other option to do this...

And without GraphicsEnabler I got a working internal LCD with no QE/CI, and max res at 1280 x 1024, with GraphicsEnabler=yes it turned off the internal lcd..

There is another way. Please follow instruction from this thread to dump your graphic card bios to file.

#45
cloud03

cloud03

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
thanks kizwan, I've finally managed to retrieve the vga bios, and here it is:

Attached File  0649.006C.006F.vga.zip   37.09KB   28 downloads

#46
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

thanks kizwan, I've finally managed to retrieve the vga bios, and here it is:

Attached File  0649.006C.006F.vga.zip   37.09KB   28 downloads

These are two set of modified dsdt.aml file for Sony VAIO AW190JAH:-
http://www.mediafire.com/?deo3gzndyij

Test both dsdt.aml with GraphicsEnabler=No & GraphicsEnabler=Yes. If you have external monitor, connect it during testing. Please let me know the results & post here the ioreg dump for both dsdt.aml using IORegistryExplorer. Good luck.

#47
cloud03

cloud03

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Both DSDT with GraphicsEnabler=Yes only works with external monitor and I think QE is working cause the top menu bar is transparent (and it also supports the full LCD native res which is 1440x900), with GraphicsEnabler=No internal LCD works but no QE and only at 1280 x1024 (stretched) max , here is the ioreg dump from both DSDT:

Attached File  ioreg.zip   1.24MB   15 downloads

#48
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

Both DSDT with GraphicsEnabler=Yes only works with external monitor and I think QE is working cause the top menu bar is transparent (and it also supports the full LCD native res which is 1440x900), with GraphicsEnabler=No internal LCD works but no QE and only at 1280 x1024 (stretched) max , here is the ioreg dump from both DSDT:

Attached File  ioreg.zip   1.24MB   15 downloads

According to ioreg dump, you're using framebuffer disabler kext & enabler/injector kext for graphic card (it inject different NVCAP). Please remove them & test again.

#49
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts
Hi cloud03, these are another two sets of dsdt.aml (R3 & R4) for Sony VAIO AW190JAH. As usual please test both dsdt.aml with GraphicsEnabler=No & Yes. Make sure framebuffer disabler kext & graphic card injector/enabler kext (NVEnabler.kext, ATY_Init.kext, EVOEnabler.kext or similar) are removed or not installed.
http://www.mediafire.com/?mmwyiqj5zjt

#50
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts
WOW! I just had someone post an incredible list of Sony specific information and links on my thread.

Check it out!


http://www.insanelym...p...t&p=1473253

#51
Phantom Thief Dark Mousy

Phantom Thief Dark Mousy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
Kizwan,


I want you to know that mediafire isn't allowing the DSDT files to be downloaded, is there a way you can post it somewhere. I'd like to test it as I have the laptop with me for the weekend

#52
cloud03

cloud03

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Hi cloud03, these are another two sets of dsdt.aml (R3 & R4) for Sony VAIO AW190JAH. As usual please test both dsdt.aml with GraphicsEnabler=No & Yes. Make sure framebuffer disabler kext & graphic card injector/enabler kext (NVEnabler.kext, ATY_Init.kext, EVOEnabler.kext or similar) are removed or not installed.
http://www.mediafire.com/?mmwyiqj5zjt


R1 and R2 DSDT gives me the same result, GraphicsEnabler=Yes only display on external lcd with QE CI, and with "No" it shows on internal LCD but no QE CI

R3 with both Yes and No, it only display on external lcd with QE CI

R4 somehow failed displaying on both LCD and on both option ("Yes" and "No")

I've uploaded all the ioreg dump with the FrameBufferDisabler.kext removed:
http://www.mediafire.com/?3mmdd0zowte

#53
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

Kizwan,

I want you to know that mediafire isn't allowing the DSDT files to be downloaded, is there a way you can post it somewhere. I'd like to test it as I have the laptop with me for the weekend

It seems anybody else was able to download dsdt from mediafire. This is dsdt R11 for Sony Vaio VPCF115FM (the same release posted earlier).
Attached File  DSDT_Patcher1.0.1e_Mammoth_R11.rar   369.14KB   3 downloads
Can you try the same thing I ask PlumberGr to do at post #37? I haven't got this results yet.

#54
jlvaio

jlvaio

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 220 posts

It seems anybody else was able to download dsdt from mediafire. This is dsdt R11 for Sony Vaio VPCF115FM (the same release posted earlier).

Can you try the same thing I ask PlumberGr to do at post ? I haven't got this results yet.

don't waste time read my post i know the problem since 3 years this is not problem of nvcap ;edid

the problem is az module called snc for sony notebook control that mask ,enable or not the internal screen,backlightand other feathures

nothing will happen since tey were issue for snc driver contact the user ryuuu from vaio p topics because he had give a try with pcifix, vaiop enabler that don t work for screen look at evosx86.com there was pere that shows how to patch vaio phoenix bios but there s no fix for internal screen

but maybe can help i have find this documentation on three years search i m the first who find existence of sonypi but no one heard me because i m noob contact krazubu and fassl from project osx.cvom they know a lttle the problem contact diabolik who made nvkush if think its the way of success read posts from linux because they've find issue

read my post
thanks to understand what i ve said the need is only one driver for all vaio the snc driver because on xp there is one driver for all vaio

thats all

#55
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

R1 and R2 DSDT gives me the same result, GraphicsEnabler=Yes only display on external lcd with QE CI, and with "No" it shows on internal LCD but no QE CI

R3 with both Yes and No, it only display on external lcd with QE CI

R4 somehow failed displaying on both LCD and on both option ("Yes" and "No")

I've uploaded all the ioreg dump with the FrameBufferDisabler.kext removed:
http://www.mediafire.com/?3mmdd0zowte

Are you sure you don't have enabler/injector kext or EFI strings for graphic card installed? I see different NVCAP injected on some of the ioreg dump.

I'll post another modified dsdt for you in a couple of minutes.

#56
cloud03

cloud03

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Are you sure you don't have enabler/injector kext or EFI strings for graphic card installed? I see different NVCAP injected on some of the ioreg dump.

I'll post another modified dsdt for you in a couple of minutes.


I'm pretty sure there is no other enabler/injector/disabler installed, cause I'm using vanilla SL and using myHack (with chameleon rc3) as bootloader, and there was indeed FrameBufferDisabler.kext on Extra\Extensions folder before, but I've removed it and repair disk permissions, and re-dump the ioreg. I didn't found any enabler on Extra\Extensions\ and S\L\E. I'm using chameleon rc4 right now by the way.

#57
dancefloordan

dancefloordan

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
Hey Kizwan, you mentioned that the Alc275 fix hasn't been implemented yet. Does that mean you've found a possible fix for it?

#58
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

Hey Kizwan, you mentioned that the Alc275 fix hasn't been implemented yet. Does that mean you've found a possible fix for it?

I need to see the codec dump first before I can say I can make it to works. If it is possible to make it to work, I will patch the AppleHDA.kext or legacy kext. Also with HDEF injection in DSDT (so that we will not need HDAEnabler.kext). If you can give me ALC275 codec dump, I will examine it to know for certain either I can make it to work or not. Other solution is using VoodooHDA.kext but I don't know if it support ALC275 or not.

#59
Mammoth

Mammoth

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 625 posts
I JUST now found this, so have not had a chance to try it yet; could this be helpful to our shared cause?

http://forum.voodoop...hp?topic=1227.0

#60
cloud03

cloud03

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Are you sure you don't have enabler/injector kext or EFI strings for graphic card installed? I see different NVCAP injected on some of the ioreg dump.

I'll post another modified dsdt for you in a couple of minutes.


Hi kizwan, are there any new dsdt that need to be tested?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy