Jump to content

CHAMELEON2 RC4 (e derivate: RC5pre8, Asere 1.1.8, AnV, PC_EFI 10.6, Prasys-EFI 10.6)


  • Please log in to reply
205 replies to this topic

#161
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Qundi Smith@@ aggiungo nel c.a.b.p.

<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

Risistemo il DSDT in questo modo

Scope (_PR)
{
Processor (CPU1, 0x01, 0x00000810, 0x06) {}
Processor (CPU2, 0x02, 0x00000000, 0x00) {}
Processor (CPU3, 0x03, 0x00000000, 0x00) {}
Processor (CPU4, 0x04, 0x00000000, 0x00) {}
}

e cosa più importante, basta aggiungere il file "boot" presente nel pacchetto di iFabio ??

#162
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Ho fatto una prova proprio come ho scritto nel post precedente ma il Chameleon non parte prorio ..boh esce la scritta Darwin .. e poi si ferma tutto

#163
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands
Dalle veloci prove fatte ieri notte ho dovuto rinominare le CPU in P00x, altrimenti nisba... ma forse avete ragione nn influisce piu' di tanto...

buoo non basta sostituire il boot... il nuovo chameleon ha bisogno almeno dei tre binari....
(hanno cambiato le dimensioni)
Usa l'installer del pacchetto e sei servito...

@ smith@@
allora a breve vado in pensione io ... :)

PS...
Come sempre... provate voi stessi... le nostre modo sono comunque differenti...

#164
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Scusa Fabio ma installando questo pacchetto il vecchio Chameleon viene sovrascritto totalmente?
Prima di installarlo c'è qualche procedura da fare per rimuovere il vecchio?
Ricordo in passato che quando installati Chameleon RC4 su Chameleon RC3 al riavvio avevo ancora Chameleon RC3.

#165
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands
Revision. 204.


@ buoo
ha me l'ha installato senza problemi.
backup e' consigliato.


Fabio

#166
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Grazie Fabio

#167
scrax

scrax

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,704 posts
  • Gender:Male
Oggi non credo di arrivare, domani sistemerò il primo post.

A me come a molti funziona bene dopo le correzioni dei primi errrori.

Non serve più rinominare le CPU però il codice Scope (_PR) dev'essere all'inizio del DSDT altrimenti non lo trova

in c.a.B.p:


<key>DropSSDT</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

se non mettete DropSSDT rischiate di aver conflitti sui c-state

per fare il debug e vedere i problemi che potreste avere:

<key>Wait</key>
<string>Yes</string>

Basta sostituire il file di boot se averte una RC5 recente (anval, ecc) altrimenti eccovi un installer della rev206:
Attached File  MozodojoCameleon2RC5r206.zip   1.61MB   18 downloads

#168
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Grande funziona!!!!!!!!!

Grazie Fabio grazie Scrax

#169
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Raga problema!

Oltre ad essere molto lento il boot, in informazioni su questo mac alla voce ATA-seriale ho questo messaggio "Si è verificato un errore durante la ricerca dei dispositivi Serial-ATA."
Quando arriva alla scrivania a volte stenta a venir fuori la barra, per il resto non ho riscontrato problemi con la ram ne con lo speedstep che funziona bene.

#170
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
GRANDE!!!!!!!!!!!!

Non fa più il matto ...chissà forse si doveva assestare ....adesso va una bomba

#171
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands
Ciao a tutti....

Sara' la tarda ora....
dalla rev 204 sulla mia piattaforma fa i capricci
ok con la rev213 la memoria ora viene riconosciuta correttamente (il vendor e il modello) ma la frequenza ancora no

per le nuove funzioni il P-stategenerator mi manda in riavvio continuo al boot....

Ho valido e utilizzabile solo dropssdt=y e GenerateCStates=Yes (con le CPU rinominate in CPU0, CPU1 ecc)

Se non rinomino le CPU e le tengo in P001,P002,ecc il sistema sembra gestirle meglio e non da errori di C-state anche dando negativo il valore del GenerateCStates in c.a.B.p
e avvio normalmente...

???
Cosa mi sfugge???

Fabio

#172
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Fabio io invece con la 204 non mi spiego come mai dopo i primi 5 - 6 riavvii il boot era lentissimo, poi la barra in alto faticava a uscir fuori, i Device sta non venivano riconosciuti e una parte delle informazioni per la ram non me le dava.
Poi all'improvviso tutto funziona ....boh

#173
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Ho sostituito il file boot con il nuovo rev214, questa è la ram, sembra un po' strano sto numero seriale

Posted Image


ho notato che adesso prima della schermata del chameleon appaiono un paio di scritte ...come se facesse un test sulla ram.
Altra nota positiva, adesso boota a 64 bit

#174
Mela quadrata

Mela quadrata

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 736 posts

Altra nota positiva, adesso boota a 64 bit


E' già da un po' che il boot avviene a 64bit, non certo da quest'ultima versione... :(

#175
scrax

scrax

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,704 posts
  • Gender:Male

E' già da un po' che il boot avviene a 64bit, non certo da quest'ultima versione... :)


Per me non è una nota positiva... :)
preferirei i 32 di default come fa Apple.
Infatti il mio c.a.B.p di default ha arch=i386 fisso...

#176
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy

E' già da un po' che il boot avviene a 64bit, non certo da quest'ultima versione... :(


..ma guarda un po ...non lo sapevo

#177
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Rilasciata la rev241, l'ho compilata ed impacchettata. Adesso prima della schermata del Chameleon non escono più quei messaggi del rilevamento della Ram

Attached Files



#178
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands

Adesso prima della schermata del Chameleon non escono più quei messaggi del rilevamento della Ram


Il rilevamento se non erro, ora viene fatto dopo l'avvio e non prima dell'avvio di chameleon com e avveniva dopo la rev.204.
Ti accorgi di questo leggendo i dati in verbose quando viene rilevata la CPU modello family ecc.
rileva anche i banchi e il tipo di ram...

Lo sviluppo va(so che sono ripetitivo) ad una velocita' impresionante.

Fabio

#179
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy

Il rilevamento se non erro, ora viene fatto dopo l'avvio e non prima dell'avvio di chameleon com e avveniva dopo la rev.204.
Ti accorgi di questo leggendo i dati in verbose quando viene rilevata la CPU modello family ecc.
rileva anche i banchi e il tipo di ram...

Lo sviluppo va(so che sono ripetitivo) ad una velocita' impresionante.

Fabio


Hai detto bene! Stanno facendo i danni LOL
Va bene che apparivano e scomparivano molto velocemente, ma mi sono accorto di questa cosa lasciando il Wait nel c.a.b.p.

#180
alexandros7

alexandros7

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 247 posts

Hai detto bene! Stanno facendo i danni LOL
Va bene che apparivano e scomparivano molto velocemente, ma mi sono accorto di questa cosa lasciando il Wait nel c.a.b.p.


1. perchè se installo questa versione di chameleon poi non mi va più la scheda wifi? ho una tplink 551.. atheros.. mi dice che non è più installata nessuna scheda airport, se rimetto l'rc4 funziona! non riesco a capire..

2.il dsdt va bene se lo faccio fare tutto dal programma dsdt patcher?

3. come faccio a capire se funziona lo speedstep ?

gigabyte p35 ds3 - Q8200

grazie a chi mi risponde





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy