Jump to content

Snow Leopard on VAIO P(VGN-P90HS) working!


  • Please log in to reply
528 replies to this topic

#461
Nenad

Nenad

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Hi, now it works!!

********** snow **********
VAIO P(VGN-P90HS)
o CPU: Intel ATOM Z540
o US15W:
o ATA(+SATA SSD)
o USB(EHCI,UHCI)
x GMA500(1600x768/no QE/QI)
o ALC262(VoodooHDA)
x LAN:Yukon2( AppleYukon2.kext but Ultra2 revision is not supported)
o WLAN:Atheros AR928X/AR5B91
o Memory Stick :-p
o SD card
o Bluetooth
o WebCAM
o 3G modem/WWAN/GPS <- need install drivers below
o suspend/resume(?: deep sleep/hibernate)
o 10.6.1/2 update
o vanilla speedstep

o:working/x:have problem/?:not yet tested

- kext and patch tool sets
--US keyboard: ( not tested )
http://www.mediafire...p20100327us.zip
--JP keyboard:
http://www.mediafire...p20100327jp.zip

- WWAN driver
http://www.option.co...modems/icon225/
# thx, maccosmo

o 10.6.2 update see->
http://www.insanelym...p...t&p=1331304

o suspend/resume see->
http://www.insanelym...p...t&p=1430885

For non-vaiop GMA500 based netbook users, GMA500Enabler is here
o 10.6 http://www.insanelym...p...t&p=1310737
o 10.5 http://www.insanelym...p...t&p=1311449

********** 10.5 leopard **********

VAIO P(VGN-P90HS)
o CPU: Z540
o US15W:
o ATA(+SATA SSD)
o USB(EHCI,UHCI)
x GMA500(1600x768/no QE/QI)
x ALC262(noisy sound with VoodooHDA)
? LAN:Yukon2?
x WLAN:Atheros AR928X/AR5B91 <- I gave up binary patching to AirPortAtheros... and will buy Dell 1510
o Memory Stick :-p
o SD card
o Bluetooth
o WebCAM
o 3G modem <- see post #28( maccosmo )
? Suspend/resume

o:working/x:have problem/?:not yet tested

Files you need: http://www.mediafire...iop-alpha-0.zip
ioreg: http://www.mediafire...ioreg-vaiop.txt

*** update ***
For 10.5.7
http://www.mediafire...iop-alpha-1.zip
- this "boot" also work with 10.5.6 and can read /DSDT.aml and /Extra kexts.
(but needs kernel option "Graphics Mode")
- Improve USBEHCI stablity( based on 10.5.7 IOUSBFamily )
- brightness can adjustable through PCIFix.kext's Info.plist
***



[boot options]
- need "cpus=1"
(with 10.5.7 boot also need "Graphics Mode" )


hello, i'm owner of asus eeepc 1008ha... and i see that you success to make working wifi card atheeos AR9285 on snow? Can you share your solution for me? i would like to try it on asus if it works..

thank you in advice..
p.s. sorry for my bad english

#462
ryuu123

ryuu123

    InsanelyMac Protégé

  • Donators
  • 85 posts

hello, i'm owner of asus eeepc 1008ha... and i see that you success to make working wifi card atheeos AR9285 on snow? Can you share your solution for me? i would like to try it on asus if it works..

thank you in advice..
p.s. sorry for my bad english


NO.

VAIO P's wifi is AR9280.
Snow Leopard support AR9280, but not Leopard.

AFIK AR9285 ,there is no solution.
You should replace the MiniPCIExpress wifi card or use USB dongle.

#463
uguom

uguom

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
this thread is dead

NO

this is the answer to all questions? :blink:

#464
p11z

p11z

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi all,

this thread is for beginners very frustrating!

After many many many many hours (i think round about 25 hours!) reading ant trying i installed 10.6 on my Vaio P11.
The needed information was in post 209

Nice, it works...

Then, i read more and more and more before i try an Update to 10.6.4

in Post 227 in this thread wrote ryuu123

10.6.2 vanilla kernel doesn't boot.

You can find patched kernel some where.

and I wote small utility to make patched kernel.

1)Before update to 10.6.2, backup current kernel.

sudo cp -p /mach_kernel /mach_kernel.1061

2)update to 10.6.2

3)after reboot. specify the kernel at chameleon's screen
(At os select screen, type mach_kernel.1061)

4)make patched kernel
sudo ./binchg.rb /mach_kernel ./1062atom64.xml
(this take some minitue)

5)replace kernel
sudo mv /mach_kernel /mach_kernel.1062
sudo mv /mach_kernel.patched /mach_kernel
sudo touch /System/Library/Extensions

6)enjoy 10.6.2!

Posted Image 1062atom64.zip ( 1.31K ) Number of downloads: 353






in Post 426

Looong time no see :unsure:

Here is patchKernel.sh for 10.6.4.

Posted Image patchKernel.zip ( 1.04K )





I had make a Backup of my Kernel and updated the OS X
After the Update it was not possible to boot up OS X with any kernel. I tested the original, the updated, the patched and more from internet (error -> "still waiting for root device").

and now:

i´m on point 1!
i now Format my HDD and install 10.6 again (i installed often before because no easy tutorial here).



Why just 2 Rows?

Looong time no see :wacko:

Here is patchKernel.sh for 10.6.4.


Why not some words more how to Use it? Ist just a couple of minutes for you to type a "howto" but many hours for beginners...

I´m really frustrated!

I thank Ryuu123 very. His great work helped me to install OS X on Vaio P11. I wish only a better documentation...

P11Z

#465
EC.

EC.

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Thank you for your very fast reply Ryuu123. Mbook m1(Koujinsha PM1) finally boot up snow leopard from external USB
Memory. Mbook m1 does not equipped with pointing device except touch panel. But, the touch panel is working upside down. Its very hard to control mouse pointer. I will try to fix it.


Are you still around here? I am working on what you could call the M1's sister model (hw very similar inside) the Viliv N5, and would like to know what EXACT steps you did to get it installed on the M1 THANKS!

#466
EC.

EC.

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Try 10.6 :angel:

Since I moved to 10.6,
I thrown away 10.5 development environment.

so I don't know work or not, compiled for 10.5 ->
for 10.5.

@auauhiro
you can flip Y-axis modding Info.plist.
Look carefully some PS2Mouse/Trackpad's Info.plist



Is there info as to where/what to do with the GMA500enabler?

#467
EC.

EC.

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Posted Image


This is what I get now.

Hardware is (Viliv N5):
Intel Atom 1.3GHz (Z520)

USB Sandisk 16GB

Basically done same as everyone says DVD to USB with restore (I did GUID btw!) and followed this:
http://www.corsino.com/blog/?p=73

Comments please?

Never mind, a simple restart and VOILA:

Posted Image


For anyone who runs across this N5 content and interested more about it maybe here is better (to not mess up this Sony thread) http://forum.pocketa...ead.php?p=52296

#468
InX

InX

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Is it possible o use any of these pocketable hackintosh computers to boot as Mac and do presentations using Microsoft PowerPoint 2004 via VGA video out? Thanks.

#469
ol macca

ol macca

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 7 posts
hi everyone i am new to this forum, i own a sony vaio vgn-p39vl, and am very interested in going hackintosh route i already own a MacBook which i think can help in this process. thing is i have never worked with osx console, i was a windows user previously and did some programming in vb. and am willing to learn is there a chance that someone could post a detailed how to, cause the ones i have read so far are a bit vague to me, basically i need help with this

#470
elpekos

elpekos

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I've installed successfuly your kext to my eee pc 1101HA with SL 1.6.4

1) I've no video output in VLC (YUV, OpenGL...) Do you have the same behaviour on Vaio P ? (and MPlayer works sloooowly)

2) I'Ve a 80 conductor cable not detected, any idea ?

Anyway thanks to Ryuu123 for this amazing work.

#471
src8

src8

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hi guys,

I'm installing 10.6 retail to my Vaio P.
I've copied retail dvd files to gparted usb stick, updated it with all .kexts from post #1, also copied /Extra folder, installed latest Chameleon via dd in linux.

So, I have a bootable install usb stick and everything goes well. One strange thing: with -v option I got a kernel panic "mis-match of kernel and CPU PM". Everything works ok without any startup options. Just want to understand this issue.

Thanks

#472
ol macca

ol macca

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 7 posts
hi everyone.
Got osx and win 7 dual boot, installed the drivers from sony. got instant mode working. havent tried wwan on osx yet but will post soon on it.Thanks for making this beauty even nicer. made 3 partitions(32+32+64), 3rd one fat so that i can use with both os's for media content

Would like to thank everyone that has contributed to this threads and special thanks to ryuu123 for all the work to make this possible. smile.gif

#473
Anton Wax

Anton Wax

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hello, I successfully built a hackintosh in the music studio (Quadcore Mac Pro Monster) so i have some experience with OSX86, but for this Sony Vaio P11Z I cant find the problem why the OSX Install USB Drive cannot start correctly...

I followed the rules, means I prepared a USB Drive with SL Install Image, Chameleon 2 RC3, and Ryu´s Files
I get with bootoptions -v cpus=1 only to the point where there is written

Loaded HFS+ file: DSDT.aml
Patched ACPI Version 2 DSDT
Starting Darwin X86

Then screen turns black

if i dont use -v screen goes white with apple

machine freezes

any ideas?

is it maybe not allowed to do the chameleon install on a hackintosh with EFI?

#474
ryuu123

ryuu123

    InsanelyMac Protégé

  • Donators
  • 85 posts

any ideas?


If you use 10.6.3 Install Disk, you must patch the kernel.

#475
Anton Wax

Anton Wax

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

If you use 10.6.3 Install Disk, you must patch the kernel.


yes indeed i am using 10.6.3 install disk, and i patched it with the 10.6.2 patch, now kernel panic, system uptime in nanoseconds... , is there a kernel patch for 10.6.3, i will search now?

thats where i am at the moment, thanks for your reply...

EDIT:

it seems that its booting now, but i have that problem with the USBEHCI unable to get device memory
i am looking for the correct IOUSBFamily.kext what i shall use...

EDIT:

ok found it, i was using a 10.5.7 IOUSBFamily.kext i downloaded somewhere...
deleted the old one and copyed the new one
now the installer is launching finally, BUT:

i cant see my internal drive... something about the atapatch?
hmm how to apply it to a OS X Install USB drive to see my internal drive?
i have a big hackintosh which i can use, but i have to change on the atapatch, that it does not patch my big hackintosh

EDIT:

i am trying a lot according to ataPatch.sh, but its not working out...
i simply never see my internal harddisk when the installer starts up :)
i think its not enough to make a patched version of it . dont i have to move it
to USBROOT/System/Library/Extensions/.... somewhere and maybe delete sth there?

EDIT:

yes true i had to replace the AppleIntelPIIXATA.kext inside /System/Library/Extensions/IOATAFamily.kext/Contents.... with the thing supplied in vaiop20100327us

installing right now to internal 60 GB Harddisk on P11Z

#476
Anton Wax

Anton Wax

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
i am installing since 2 hours and the progress bar always says 29/30 minutes and did not reach 50% yet
the internal disc is flashing yellow so i think there is something happening, did someone experience the same?

EDIT, after totally 3:15 hours... still installing, now around 65% and 23min to go - i guess that will be more :D

EDIT, after totally 6:10 hours... still installing, now around 75% and 18 min to go - haha

EDIT, after totally 9:30 hours... still installing, now around 85% and 15 min to go - what did i make wrong?

EDIT, after totally 13:00 hours.. still installing, now around 98% and 10 min to go - looks like i can go to bed :)

#477
Anton Wax

Anton Wax

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
okay i made it, i came to the point where all of you are... everything woking, but no QE/CI :)

ryuu123, may i donate sth to you? just send me a PM if yes :)

anyone got the WWAN Drivers? the old link is only showing Windows Drivers :/

SOLVED: Use any of those infos at option webpage: IMEI 354505026201509 / Serial DR2988G8XB

but driver does not load :) failed to register

SOLVED: reboot helped

#478
src8

src8

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I'm here looking for QE/CI. Anyone can develop a working video driver with QE/CI support?

#479
Anton Wax

Anton Wax

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
GMA500 driver -> go here and support
http://www.insanelym...howtopic=193987

#480
lemer

lemer

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I just bought the usb dual monitor adapter, Diamond BVU190, and it works very well with the P/SL. I now have SL extended from the P onto my 22" Syncmaster via usb--very cool!
Full screen video is a no go. However, it doesn't work on the PC/XP side either so....





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy