Jump to content

sehr niedriges Ergebnis bei xBench DiskTest


  • Please log in to reply
8 replies to this topic

#1
wickedfella

wickedfella

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Hallo Community

Ich nutze meinen Vostro1510 jetzt schon länger ausschließlich mit 10.5.5, habe aber gestern erst zum ersten mal xBench durchlaufen lassen.
Daraufhin habe ich die Testergebnisse mit den vielen Werten im Internet verglichen und mir ist aufgefallen, dass mein System bei allen "Disziplinen" des Disktest unterdurchschnittlich schlechte Werte aufweist.
Sieht insgesamt wie folgt aus:

Results 65.07
System Info
Xbench Version 1.3
System Version 10.5.5 (9F33)
Physical RAM 3072 MB
Model MacBookPro4,1
Drive Type ST9250320AS
CPU Test 55.77
GCD Loop 93.69 4.94 Mops/sec
Floating Point Basic 45.23 1.07 Gflop/sec
vecLib FFT 36.91 1.22 Gflop/sec
Floating Point Library 84.41 14.70 Mops/sec
Thread Test 161.76
Computation 164.33 3.33 Mops/sec, 4 threads
Lock Contention 159.27 6.85 Mlocks/sec, 4 threads
Memory Test 148.27
System 142.43
Allocate 206.61 758.75 Kalloc/sec
Fill 125.42 6098.31 MB/sec
Copy 121.22 2503.78 MB/sec
Stream 154.60
Copy 143.92 2972.58 MB/sec
Scale 144.37 2982.55 MB/sec
Add 167.31 3564.00 MB/sec
Triad 166.07 3552.68 MB/sec
Quartz Graphics Test 109.46
Line 105.09 7.00 Klines/sec [50% alpha]
Rectangle 124.80 37.26 Krects/sec [50% alpha]
Circle 196.13 15.99 Kcircles/sec [50% alpha]
Bezier 48.40 1.22 Kbeziers/sec [50% alpha]
Text 418.49 26.18 Kchars/sec
OpenGL Graphics Test 107.98
Spinning Squares 107.98 136.97 frames/sec
User Interface Test 53.42
Elements 53.42 245.18 refresh/sec
Disk Test 25.25
Sequential 82.25
Uncached Write 74.16 45.53 MB/sec [4K blocks]
Uncached Write 76.14 43.08 MB/sec [256K blocks]
Uncached Read 93.17 27.27 MB/sec [4K blocks]
Uncached Read 88.65 44.55 MB/sec [256K blocks]
Random 14.91
Uncached Write 4.59 0.49 MB/sec [4K blocks]
Uncached Write 57.80 18.50 MB/sec [256K blocks]
Uncached Read 48.02 0.34 MB/sec [4K blocks]
Uncached Read 81.10 15.05 MB/sec [256K blocks]

Mir erscheint das Testergebnis in Relation zu meiner Systemkonfiguration auch etwas niedrig.
Es handelt sich um einen Vostro1510 2,0Ghz C2D, 3GB RAM. Zu den anderen relevanten Komponenten kann ich jetzt leider nichts genaueres sagen :P

Kann es also sein, dass die langsamen Zugriffs- und vor allem Schreibgeschwindigkeiten eine Art Flaschenhals darstellen und das gesamte System etwas ausbremsen?
Bei mir dauert das Booten auch ungefähr 1:30 Minuten, ich habe hier schon von Startups gelesen, die in etwa 4mal so schnell waren.

Habt ihr eventuell eine Idee, an was das liegen könnte?

Vielen Dank bereits im voraus und gute Nacht

#2
Mogana

Mogana

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hier mal meine Werte zum Vergleich, mac mini 2,0.

Results 148.10
System Info
Xbench Version 1.3
System Version 10.5.7 (9J61)
Physical RAM 4096 MB
Model Macmini3,1
Drive Type WDC WD3200BJKT-00F4T0
CPU Test 133.81
GCD Loop 232.76 12.27 Mops/sec
Floating Point Basic 112.81 2.68 Gflop/sec
vecLib FFT 92.88 3.06 Gflop/sec
Floating Point Library 167.63 29.19 Mops/sec
Thread Test 281.59
Computation 398.47 8.07 Mops/sec, 4 threads
Lock Contention 217.73 9.37 Mlocks/sec, 4 threads
Memory Test 180.30
System 199.84
Allocate 245.09 900.05 Kalloc/sec
Fill 165.42 8042.86 MB/sec
Copy 204.65 4227.01 MB/sec
Stream 164.24
Copy 156.20 3226.16 MB/sec
Scale 155.11 3204.43 MB/sec
Add 175.04 3728.75 MB/sec
Triad 172.64 3693.18 MB/sec
Quartz Graphics Test 189.47
Line 151.99 10.12 Klines/sec [50% alpha]
Rectangle 199.40 59.53 Krects/sec [50% alpha]
Circle 162.12 13.22 Kcircles/sec [50% alpha]
Bezier 158.96 4.01 Kbeziers/sec [50% alpha]
Text 428.02 26.78 Kchars/sec
OpenGL Graphics Test 130.11
Spinning Squares 130.11 165.05 frames/sec
User Interface Test 269.15
Elements 269.15 1.24 Krefresh/sec
Disk Test 71.34
Sequential 110.81
Uncached Write 127.08 78.02 MB/sec [4K blocks]
Uncached Write 124.31 70.33 MB/sec [256K blocks]
Uncached Read 74.99 21.95 MB/sec [4K blocks]
Uncached Read 146.01 73.38 MB/sec [256K blocks]
Random 52.61
Uncached Write 19.00 2.01 MB/sec [4K blocks]
Uncached Write 166.19 53.20 MB/sec [256K blocks]
Uncached Read 92.93 0.66 MB/sec [4K blocks]
Uncached Read 151.10 28.04 MB/sec [256K blocks]

#3
wickedfella

wickedfella

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Ja, die verhalten sich zueinander in etwa so, wie ich es bei anderen Vergleichen mit xBench-Ergebnissen schon gesehen habe.
Mich wundert einfach, warum beim CPU-Test und beim Disk Test bei mir so niedrige Werte rauskommen.
Immerhin pocht in meinem Vostro ein C2D T5870 @ 1,8Ghz (anstatt 2Ghz). Was mich nicht wundert/stört, sind die relativ niedrigen Scores bei den Graphic Tests, weil ich nur eine 8400M GS habe und die ist gelinde gesagt Sch****.

Kann sich niemand vorstellen, woran das liegen kann? Ich habe wie gesagt auch eine unheimlich lange Bootzeit.
Ich habe auch schon gelesen, dass manche Leute durch Änderungen im BIOS den Multi erhöhen konnten, aber wenn ich bei mir z.B. SpeedStep deaktiviere, dann bleibt er beim Booten am Apfel-Logo hängen, etwa 10 Sekunden nach dem Bootloader...

#4
zuz_242

zuz_242

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts
mach dir wegen dem disk bench keine zu grossen sorgen. der ist bei hacks meist unterdurchschnittlich.
ich glaube nicht, dass dieser test wirklich die reale (gefühlte?) performance wiederspiegelt.

du kannst ja mal nach anderen hack xbench resultaten suchen und wirst merken, dass die meist recht niedrig sind (hängt tw. von der verbauten marke der festplatte ab).

du könntest natürlich experimentieren, andere treiber/kext für dein chipset zu installieren und evtl im bios sata / ide modi umschalten. :(
aber immer mit der gefahr, ein funktionierendes system zu zerschiessen (evtl. auch ein parallel inst. windows). wenn du eine gute datensicherung hast, kannst die die risiken natürlich minimieren ;)

ps: wegen dem langsamen booten: ich konnte mein system um 30sec beschleunigen, indem ich meinen IOKitWait timeout gefixt habe ..

:unsure:
viel glück

#5
wickedfella

wickedfella

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Vielen Dank, hab mir hier ausm Forum die gefixte IOATAFamily.kext geholt und es ist zumindest subjektiv schneller. (ich hab leider keine Zeiten genommen)

aber wo du schon gefühlter/realer Performance redest:
Gemessen an der Ausstattung kommen mir bestimmte Sachen schon sehr langsam vor. Firefox mindestens 7-8 Sekunden, Pages ungefähr 13 Sekunden, jDownloader ca. 20 Sekunden. Das sind schon irgendwie astronomische Werte.
Ich habe mir auch andere hacked OSX-Systeme angeschaut, die ebenfalls mit einer Seagate Momentus 5400 ausgestattet sind, aber die haben beim DiskTest alle höhere Werte. Vielleicht sollte ich mich mal direkt an Dell melden und die fragen, ob die verbaute Platte fehlerhaft (somit langsamer) sein könnte. Dafür muss es doch irgendwelche Diagnosetools geben. Dazu würde ich meinen Laptop ausnahmsweise sogar mal von der Vista-Partition booten :(

#6
riws

riws

    InsanelyMac V.I.P.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 6,081 posts
Bench mal eine andere Partition, als die Leo System Partition.

#7
wickedfella

wickedfella

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Ok, habe ich gemacht. Und zu meiner Überraschung waren die Messwerte hier sogar noch schlechter. Over all result: 33,7

Disk Test 10.78
Sequential 15.74
Uncached Write 8.01 4.92 MB/sec [4K blocks]
Uncached Write 13.65 7.73 MB/sec [256K blocks]
Uncached Read 34.03 9.96 MB/sec [4K blocks]
Uncached Read 37.58 18.89 MB/sec [256K blocks]
Random 8.19
Uncached Write 2.47 0.26 MB/sec [4K blocks]
Uncached Write 23.26 7.45 MB/sec [256K blocks]
Uncached Read 47.62 0.34 MB/sec [4K blocks]
Uncached Read 52.25 9.70 MB/sec [256K blocks]

Da kann doch mit der HD einfach was nicht in Ordnung sein. Ich mein Sequential Uncached Write mit 4,9 MB/sec is schon ordentlich langsam...

Sehr sehr mysteriös die ganze Geschichte...

#8
zuz_242

zuz_242

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts

Ich habe mir auch andere hacked OSX-Systeme angeschaut, die ebenfalls mit einer Seagate Momentus 5400 ausgestattet sind, aber die haben beim DiskTest alle höhere Werte. Vielleicht sollte ich mich mal direkt an Dell melden und die fragen, ob die verbaute Platte fehlerhaft (somit langsamer) sein könnte. Dafür muss es doch irgendwelche Diagnosetools geben. Dazu würde ich meinen Laptop ausnahmsweise sogar mal von der Vista-Partition booten :D


Unter Windows gibt es etliche Tools, z.B. H2bench. Wenn unter Windows die Festplatte auch so geringe Werte zeigt, liegt es wirklich an der Festplatte oder den Bios Einstellungen.
Wenn nicht, an OSX bzw. den KernelEXTensions. Welches Chipset hat dein Rechner? Intel GM965 mit ICH-8? Suche darüber Informationen und neue Kext´s.

Ich würde mir vorher Sicherkeitskopien von den installierten Kexts (osx86tool) und am besten der ganzen Installation machen, dann schraubt es sich entspannter.. :D

dass schon gesehen?
http://www.hackint0s.../f145/51985.htm

EDIT:
Ich habe übrigens mal meine Werte angehängt:

Attached Files



#9
wickedfella

wickedfella

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Tausend Dank für die Tipps. Der Link ist auch super!

Ich muss am Donnerstag zum Spanischcolloquium antreten und deswegen vorübergehend meinen Kopf in ein paar Bücher stecken, werd mich dann aber mal intensiver mit der Sache befassen.

Schönen Abend noch!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy