Jump to content

[Guide] Intel D101GGC Motherboard + P4


  • Please log in to reply
32 replies to this topic

#21
fumocamel

fumocamel

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
  • Interests:Intel Desktop Board D101GGC
i have onboard video card and i want to change resolution, now i have only 1024x768, what i have to do?

thanks

#22
chris lopo

chris lopo

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

i have onboard video card and i want to change resolution, now i have only 1024x768, what i have to do?

thanks

Here I am trying to do this again. Once a year I try to install (maybe the Xmas spirit?) ;)

Well:
Using Myzar 10.4.5 (I tried JaS 10.4.6 and 10.4.8 and Uphuck 10.4.9 without success)

So what we need:

IN THIS PARTICULAR CASE don't patch the ATI ATA in the beginning, I will explain later my problem.

The Hardware:
Motherboard: Intel D101GGC
Video: PCI-e ATI X300/SE

The release:
Myzar's 10.4.5

The drivers:
Sound: Azalia Audio
Video: koverg or here (koverg worked for me perfectly)

Lan is working out of the box, doesn't need patch.

Now the problem: ATA Driver.
I've tried this method using this kext, but one thing is not right:
- check the permission:
chown -R root:wheel /System/Library/Extensions/AppleOnBoardATA.kext
chmod -R 755 /System/Library/Extensions/AppleOnBoardATA.kext
There is not any "AppleOnBoardATA.kext" in "/System/Library/Extensions/". So, I delete "AppleGenericATA" and "AppleOnBoardATA" from "IOATAFamily.kext/Contents/Plugins"/ and the system crashes in the first boot.

I've done this a few times to be sure that was not my mistake. It seems it's not. :P

Any help?

fumocamel:
Edit* this file: /Library/Preferences/SystemConfiguration/com.Apple.Boot.plist
Include the following code:
<key>Graphics Mode</key>
<string>1280102432</string>

*If you are not into terminal, just double click on <Your HD>/Library/Preferences/SystemConfiguration/ and copy com.Apple.Boot.plist to the desk, edit the file using any Text Editor, save (Command + S), quit (Command + Q) and copy back to /Library/Preferences/SystemConfiguration/. By this time your password will be required.

Reboot your system and let's see what happens. The worst thing that can happen is you get 1024x768 again. ;)

PS: x200 - Use Callisto beta 3 (fixed) to get ... resolution

#23
P3Y0

P3Y0

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
  • Gender:Male
Can somebady help me?, i install Kalyway 10.4.10 in this board, install runs perfectly, but when installer ask to reebot, system reboots, an reboots in a loop, appear the Vesa 3.0... message, next the Darwin message, then reboots.
I disabled LEGACY USB from bios for working with mi PS2 mouse n Keyb. I'm usig SATA 160GB HD. OS X is installed in the second partition. XP in the first.

INTEL D101GGC mobo
P4 3.06HT 533fsb
1.5 GB DDR1 RAM
SEAGATE SATA HD 160GB 7200rmp
XFX nVidia Geforce 7300GS 256MB

#24
alisabki

alisabki

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Malaysia

Im having similar problems with the same board. I used the 10.4.6 Goatsecx dvd and the onboard lan, sound and video work perfectly. My problems are I cant boot with usb enabled, I tried to disable "Legacy" and Osx86 just hangs in Darwin.



so, my problem is same with this... im using this Intel D102GGC2 MoBo. by the way, after im disable legacy USB on BIOS, i can install osx but with no usb support.

#25
Dark Prince

Dark Prince

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hey Guys,

I am using D102GGC2 motherboard with 1GB (512 x 2) Memory, 120GB IDE HDD and 7300GT nVidia GPU. I am trying to install Leopard as stand alone (I've formatted the whole 120 GB to HFS). But when system boots into the DVD, the Vesa 3.0 text appears followed by darwin loader and then restarts. I not yet tried disabling the USB. I'll try it today and let you know the issues.

#26
immy

immy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
HII GUYSSS.....i am very new to this mac on pc thing .. i have downloaded KALYWAY 10.5.2 and i have a intel motherboard D101GGC,
and P4 2.66ghz,, and ram of 1gb... but my problem is when i am booting the dvd after the darwin's promt the installation stops by saying,
'' STILL WAITING FOR THE ROOT DEVICE'' ..PLZ PLZ PLZ help me out guys........thank you

#27
badkidforum

badkidforum

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Interests:say video games, n say Pc's .. geek networking professional .. loves wasting time on PC :D...
I'm also one more idiot using D101GGC + P4 3.06 Ghz.

my hardware.

Motherboard : Intel D101 GGC
Processor : Intel P4 3.06 Ghz 533FSB 1 MB L2C
RAM Hynix 1GB DDR PC 400
HDD : 320 + 250 Segate SATA2
Writer Normal DVD Writer.
Graphics : Nvidia 8600GT 512MB DDr2
OSX Distrubution Used : ToH Kernel based named " Leopard Patched for PC Use "
-------------------------------------------------------------
Installing Leopard the first time .... cant explain ...
took one month besides of the powercuts n all ..... huh !!1 atlast it was a reward.


I can advice all my friends out there with D101GGC board ... some mistakes not to be repeated again.

Most Careful
Burn With Nero ... n lowest possible speed ..... waiting for some time is better than getting a faulty n error prone installtion in near future.
i used Nero 6.xxxx with 4x speed.

once waited 'll help u reduce errors.
---------------------------------------------------------
Look n remembe wat ur performing : dont just read the forum n go flyin : u also need 2 learn : better take some notes for future : grab a pen n a white paper.

----------------------------------------------------------
PROBLEM : STILL WAITING FOR A ROOT DEVICE.

As ToH kernel installer dosent detect SATA drivers initially ... use IDE2SATA convertor.
n make sure all your Devices are "Master" otherwise u'll get Waiting for root device error.

Partiton.
Leave the partition scheme default. Juss goto Diskutility .. select the partition u want for Leopard.
Erase it :
Name it : "Leopard" u can also use other names. but i'll refer Leopard.


Getting directly booted from the installtion n partition scheme : Now. goto Terminal
make a path to ..
CD Drive ..
goto usr
goto misc
there is a script named "./script.sh"
Syntax :
> usr/msic: --- somewhat like in directory----
now use < ./script.sh Leopard> ; Leopard, is the name of partitoin ur using. change the name if u used some other.
now apply that script : remember TWICE ... not once ... or u'll get stuck @ boot.


Close terminal goto setup.
customize the setup as ur requirements.
Start install n enjoy a sleep . mine took 3.xx hours.

......................


Now after the install remove the disc .. n boot to leopard.

.......................

Making Drivers Work: Good part bfore u get rewarded.

Sound : Realtek ALC861 : Thanks to targua. : find a Installer not a kext. than 'll do work automatically
Download : AppleAzaliaAudio.pkg file from in this site.
Sata working : only find . ATI PATA ' keyword ' any other thing can screw u up.

NTFS Fuse n Core named utilty 'll help work NTFS read write. I dont really remember the exact name

Nvidia Graphics : best n easy part.
Goto Google : search "nvinject _ _ _ _(ur Card series n Name)
you 'll be directed to the best possible link .... n download the drivers for ur series only. Run installer restart n Enjoy.

Keyboard n Mouse PS/2 problems : solution wat i prefer : get a few bucks n buy USB K/B n Mouse
otherwise search for ApplePS/2.kext patched .... i don t think dats a good way.

Webcam : cant help mine is also not working .- Creative Live Cam Pro.
TV Tuner : Cant Help Mine is also not working yet - Leadtek TV 2000 XP RM ..
Tried everything for them that exists.
Hope some one can help me also


atlast : as Leopard is makin compromise with our Machines n Hardware .. we shud do the same :angel: .. Humanity sake :( :) ...
if u plan to buy new hardware , make sure it is compatible with MAC, if u get addicted to it.

-------------------
Makin Basic Windows '.exe' running ;
Tool 1: Darwine. - FREEWARE
Tool 2:CrossOverGames - SHAREWARE - Easy to use .. GUI mode .. better one - users Darwine as backend.
Buy them if u like them
-------------------
Hope u'll never wish to retuen to windows. if ur some .exes can work in MAC too ... :)

::::: Dont juss go with the kexts urself, use 'KEXTHELPER" a free tool that 'll ease the work. google it.


Hope i can help some one further.


remember
Google : is a friend of mine,
it also applies on you.



Good Luck to all my friends. have a happy H/M"A'C'K"INTOSH.

alos giving two Drivers here working on mine.
Hope they'll work for u guys.

one is for ALC861 sound.
Other for ATA ddevice on D101GGC

hv nice time.

Attached Files



#28
badkidforum

badkidforum

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Interests:say video games, n say Pc's .. geek networking professional .. loves wasting time on PC :D...
badkid again ...
Sound : For a working sound : Juss run the aboce installer provided.
For working SATA :

Goto MACDRIVE > SYSTEM > LIBRARY > EXTENSIONS > Enable Folder Actions ( Right Click ..More ) .. to authenticate provide ur password. and juss
put the AppleonBoardPCATA.kext ... file in the ATI_X200 ..... ZIP in there.

Reboot with the SATA cables on .... you 'll have working SATA.


hv gud time again.

#29
badkidforum

badkidforum

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Interests:say video games, n say Pc's .. geek networking professional .. loves wasting time on PC :D...
Got Creative Live Cam working
thanks 2 MACAM. ( GR8 Software ) supports most of the webcams.

a kext update for leaopard 10.5.2 V 3.0.8 .. providing the link also.

Just run the installer to update IOUSB.kext ....
install MACAM ... n restart .....

Everything wotks now ..
my cam works perfect on 25 fps

Hope 'll work for u guys also.

Attached Files



#30
vinavinay

vinavinay

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
sir i am sorry but i am trying to install mac leopard on intel 101 ggc with 1 gb ram 250 gb sata hard disc or 40 gb ide hard disc but my hard disc does not get detected in disc utility please helppppppppppppppp pleaseeeeeeeeeeeeee

#31
shanif

shanif

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male

sir i am sorry but i am trying to install mac leopard on intel 101 ggc with 1 gb ram 250 gb sata hard disc or 40 gb ide hard disc but my hard disc does not get detected in disc utility please helppppppppppppppp pleaseeeeeeeeeeeeee



IF U ARE USING IDE HARD DISK JUST SET A JUMPER IN YOUR HARD DISK BECAUSE TO DETECT THE DISK IN DISKUTILITY YOU HAVE TO THE HARD DISK AS MASTER(IF U DON'T KNOW WHERE TO SET JUMPER JUST LOOK ON THE LABEL SHET OF THE HARD DISK)

Edited by shanif, 15 September 2009 - 03:12 PM.


#32
level70steve

level70steve

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
Sorry to bump, but after running everything I could think of, I did obtain a Leo4All distro. It runs with minimal install and at least two open USB ports from a USB PCI card. But it won't run long with my GeForce 8600GTS graphics card installed as it heats up of course. I installed as many kexts as I could, but System Profiler keeps saying that no kext is loaded. I tried loading kexts from kernel flags and that doesn't work either. EXACTLY what do I have to do to achieve a 1600x900 resolution?! And btw, it's not as simple as using the "Graphics Mode" kernel flag either.

#33
level70steve

level70steve

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
Nevermind, it's not as simple as it looks. I was able to view the resolution options I had at the time, but none of them were widescreen resolutions my card was able to run. I was able to get up to 1280x1024 but that was about it.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy