Jump to content

Working ALC272 HD Audio Kext!


  • Please log in to reply
33 replies to this topic

#1
lkelly2006

lkelly2006

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
Hello All,

Attached is a working kext for ALC272 HD Audio. This was created by Mysticus, please enjoy!

Attached File  AppleHDA_ALC_272.zip   280.59KB   4204 downloads

Update: Above pkg only works on Leopard. Causes kernel panic on SL.

SL instructions below.

#2
brambo

brambo

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi IKelly2006,

I downloaded the kext you found, and installed it with kext helper on my aspire D150.

After rebooting my netbook, the drivers are loaded, but no sound appear. i checked the log,
no errors regarding sound, in the Sound PrefPane, the audio card can be selected as input and
output device, the icon is in the menu bar. Everything seems ok.

Is there somewhere a configuration that needs to be done? Where can I get in touch with Mysticus?

I'm running XxX 1.5.6 Final V2.

Brambo


Hello All,

Attached is a working kext for ALC272 HD Audio. This was created by Mysticus, please enjoy!

Attached File  AppleHDA_ALC_272.zip   280.59KB   4204 downloads



#3
lkelly2006

lkelly2006

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male

Hi IKelly2006,

I downloaded the kext you found, and installed it with kext helper on my aspire D150.

After rebooting my netbook, the drivers are loaded, but no sound appear. i checked the log,
no errors regarding sound, in the Sound PrefPane, the audio card can be selected as input and
output device, the icon is in the menu bar. Everything seems ok.

Is there somewhere a configuration that needs to be done? Where can I get in touch with Mysticus?

I'm running XxX 1.5.6 Final V2.

Brambo


Hello Brambo,

Your headphones will default as your sound device, under the options make sure that your Output is your default device and that should solve the issue.

Let me know if you experience any further issues.

#4
brambo

brambo

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi,

I verified the settings of in the Sound prefpane, and it is OK, but I have still no sound :hysterical:

In my System logs, the only references to the HDA are:

Apr 11 18:53:35 brams-aspire-one-2matcacpi kernel[0]: HDAEnabler: Copyright 2008 by Kabyl
Apr 11 18:53:35 brams-aspire-one-2matcacpi kernel[0]: HDAEnabler: 05/05/2008 Added SPAudio support:Taruga

Via System profiler:
Intel High Definition Audio:

Device ID: 0x1025019C
Audio ID: 12
Available Devices:
Speaker:
Connection: Internal
Microphone:
Connection: 1/8 inch Jack

And the loaded kext's:
AppleHDA:

Version: 1.3.3
Last Modified: 12/12/08 18:38
Get Info String: 1.3.3a1, Copyright Apple Inc. 2005-2007
Location: /System/Library/Extensions/AppleHDA.kext
kext Version: 1.3.3a1
Load Address: 0x218c5000
Valid: Yes
Authentic: Yes
Dependencies: Satisfied
Integrity: Kext has no receipt

AppleHDAController:

Version: 1.3.3
Last Modified: 12/12/08 18:38
Get Info String: 1.3.3a1, Copyright Apple Inc. 2005-2007
Location: /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAController.kext
kext Version: 1.3.3a1
Load Address: 0x20f91000
Valid: Yes
Authentic: Yes
Dependencies: Satisfied
Integrity: Kext has no receipt

Is there a place where I can find more debug information? ;)

Kind regards,
Brambo


UPDATE: For what it is worth, when I start up, I hear in de headphones some plops,


Hello Brambo,

Your headphones will default as your sound device, under the options make sure that your Output is your default device and that should solve the issue.

Let me know if you experience any further issues.



#5
BetaHal

BetaHal

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male

Hello All,

Attached is a working kext for ALC272 HD Audio. This was created by Mysticus, please enjoy!

Attached File  AppleHDA_ALC_272.zip   280.59KB   4204 downloads


It looks like Brambo tried this with no luck. I don't have a d150 myself, but I would be glad to pass a little bit more information onto the acer aspire one user forum, where people seem to be waiting for such a working kext. Would you mind telling us on which platform and version of OSX does it work? Would it be too much asking for an installation procedure?

Thanks :(

#6
docgd

docgd

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hello All,

Attached is a working kext for ALC272 HD Audio. This was created by Mysticus, please enjoy!

Attached File  AppleHDA_ALC_272.zip   280.59KB   4204 downloads


It just worked for me on a Toshiba Qosmio Laptop! :P
Just wanted to say great Job,Mysticus :thumbsup_anim:

#7
birdtales

birdtales

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I also could not get it to work on my D150. No errors, just no sound.

#8
brambo

brambo

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Hello All,

Attached is a working kext for ALC272 HD Audio. This was created by Mysticus, please enjoy!

Attached File  AppleHDA_ALC_272.zip   280.59KB   4204 downloads



OK,

I did some new test. My bro has also the aspire one D150, so I installed from scratch on his machine,
but with the same results. No errors, no sound, the only sound you hear are some plops during startup;

Since it seems to work on the Toshiba, perhaps other components are impacting the behavior.

Can it be related to the chipsets? The aspire has:

00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)

I did not load any special kext yet since they always mention stuff for the ICH8-10.

Anyone more info on this?

Brambo

#9
yohko101

yohko101

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

OK,

I did some new test. My bro has also the aspire one D150, so I installed from scratch on his machine,
but with the same results. No errors, no sound, the only sound you hear are some plops during startup;

Since it seems to work on the Toshiba, perhaps other components are impacting the behavior.

Can it be related to the chipsets? The aspire has:

00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)

I did not load any special kext yet since they always mention stuff for the ICH8-10.

Anyone more info on this?

Brambo


Hey Brambo,

Question: Will we need a matching ALCInject.kext along with the AppleHDA.kext? I've seen them doing something similar with the A150 model?

Thanks!

#10
lkelly2006

lkelly2006

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male

Hey Brambo,

Question: Will we need a matching ALCInject.kext along with the AppleHDA.kext? I've seen them doing something similar with the A150 model?

Thanks!


That could be it. I'm running mine on a Qosmio x305-701 and everything is working fine. You may have to do some minor modifications for your specific chipset.

#11
premiatech

premiatech

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Any update on this? or about needing ALCInject?

#12
Memfys

Memfys

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hello! I created kext for Acer Aspire One D150 (ALC272). Full working! With autodetect :-)
http://www.mediafire...72_AAO_D150.zip

added: removed knock-knock in speaker, HDAEnabler inside AppleHDA.kext

#13
Julien49

Julien49

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Location:France

Hello! I created kext for Acer Aspire One D150 (ALC272). Full working! With autodetect :-)
http://www.mediafire...72_AAO_D150.zip

added: removed knock-knock in speaker, HDAEnabler inside AppleHDA.kext


Thanks! It works great for me. ;)

I just had to remove VoodooHDA.kext and HDAEnabler.kext from /System/Library/Extensions and then I have used Kext Helper to install your AppleHDA.kext.

I now have sound output and internal mic input working on my Acer Aspire One D150. Wonderful!!! Thank you! :(

#14
waneto

waneto

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Nanjing,China
http://www.mediafire...72_AAO_D150.zip

this link is unvalid, please someone upload the kext????

thanks!!

#15
Julien49

Julien49

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Location:France
Here's the file.

Attached Files



#16
waneto

waneto

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Nanjing,China

Here's the file.

thank you so much!!

but when I download the file, use winrar to open it , I find that this file is not a kext, emm, help me ,or could you please send this kext to my email,

waneto@sina.com

I appreiate your job!!

#17
Julien49

Julien49

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Location:France

thank you so much!!

but when I download the file, use winrar to open it , I find that this file is not a kext, emm, help me ,or could you please send this kext to my email,

waneto@sina.com

I appreiate your job!!


Please use Mac OS X Leopard to unzip the file. Just double click on it in the Finder.

#18
waneto

waneto

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Nanjing,China
Julien49,thank you so much!!
B)
PS: Do you have the kext for snow leopard or leoaprd 10.5.8, this kext seem to work on 10.5.6.

#19
Memfys

Memfys

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Julien49,thank you so much!!
:)
PS: Do you have the kext for snow leopard or leoaprd 10.5.8, this kext seem to work on 10.5.6.

If you to me, here is .kext for 10.5.8 If you need .kext for Snow Leopard, please ask me in ICQ


http://www.mediafire.com/?jtdtnmzlrwm

#20
mentex

mentex

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi Memfys,

i used your kext for my aspire one d250 with 10.5.8.
first everything worked...!

but on the second reboot i get a kernel panic...

you have any idea??

thanks..





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy