Jump to content

[GUIDE] Installing Snow Leopard/Leopard retail DVD on the GA-E7AUM-DS2H


  • Please log in to reply
758 replies to this topic

#701
leppy700m

leppy700m

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts

hi shawndoggy, attached: chameleon2.1-rev1666 patched for our board (IGP + more than 2GB RAM). With this version 10.7.2 + iCloud should work. Formarly com.apple.Boot.plist in /E must be renamed to org.chameleon.Boot.plist now. The keys for RAM in smbios.plist will not be read correctly - use the key "UseMemDetect", value "Yes" in org.chameleon.Boot.plist instead. This will show you the RAM in System Profiler. BTW: For dualboot with Win7 boot0md may be useful. Good luck! Update: And a new image for a ChameleonBoot stick


This stuff rocks, thanks olegischinski. I just did a complete reinstall using this method, Lion and installed your patched Chameleon, and it's flawless - except no sound (expected). Now I just need to go patch that, and I am all set. Thanks - good work.

#702
scoobydu

scoobydu

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts

And for the last time:
Sound over HDMI will NOT work with AppleHDA (patched or unpatched).


Out of interest why?

I've just got it working on my hd3000 rig and was going to try this one again with my new knowledge :)

Is it a waste of time ?

#703
e60

e60

    InsanelyMac Geek

  • Donators
  • 118 posts
  • Gender:Male
@scoobydu
My last DSDT should be ok for HDMI Audio. In my opinion AppleHDA.kext is the reason why this thing isn't working. Unfortunately I have no idea how to patch this kext and not much desire to learn it. ;) So if there is anyone out there who knows what to do with AppleHDA.kext, it would be perfect if "the one" ;) could help us to manage this thing.

#704
e60

e60

    InsanelyMac Geek

  • Donators
  • 118 posts
  • Gender:Male
I'm not sure if this might be interesting for anybody, but Mountain Lion works flawless with our Mainboard :)

#705
e60

e60

    InsanelyMac Geek

  • Donators
  • 118 posts
  • Gender:Male
Hey guys,

bonami2k asked me if I could upload a newer Chameleon version for our Board because he is having some trouble installing Mountain Lion, so here we go. The Zipfile contains the Chameleon trunk version 2.1svn r2030 and some updated Kexts. You have to install it using Terminal, but maybe Oleg will create an updated version of his easy to restore image. :)

#706
LJSeinfeld

LJSeinfeld

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
  • Gender:Male

I'm not sure if this might be interesting for anybody, but Mountain Lion works flawless with our Mainboard :)


Maybe it would be good to start a new thread about installing Mountain Lion on the board? This topic is now 36 pages long, and difficult to follow/search sometimes...

Just an idea..

#707
e60

e60

    InsanelyMac Geek

  • Donators
  • 118 posts
  • Gender:Male
@LJSeinfeld
Good idea! By the way, I'm currently working on a new and user friendly Mountain Lion Guide. :)

#708
olegischinski

olegischinski

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
hello,

here comes an update for the ChameleonBoot stick ready for Mountain Lion
and Chameleon rev. 2050 patched for our board.

Same procedure as here

Onboard audio will work with patched AppleHDA.kext form Lion or try out the ML preview version by toleda (in this case use the DSDT from the additional folder of the image).

There are some nice kexts for monitoring in the additional folder too, but you don't need them. (Credits to Slice and others on projectosx.com)

Good luck!

Attached Files



#709
shawndoggy

shawndoggy

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
well shoot. I messed up my install (don't ask!) and now I'm having trouble reinstalling lion. I've created the lion install media according to the guide, but I'm hanging at "[ PCI configuration begin ]". So I can't get the system to boot far enough to get to the install process. Any thoughts on what I'm doing wrong?

#710
adidasprince

adidasprince

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

hello,

here comes an update for the ChameleonBoot stick ready for Mountain Lion
and Chameleon rev. 2050 patched for our board.

Same procedure as here

Onboard audio will work with patched AppleHDA.kext form Lion or try out the ML preview version by toleda (in this case use the DSDT from the additional folder of the image).

There are some nice kexts for monitoring in the additional folder too, but you don't need them. (Credits to Slice and others on projectosx.com)

Good luck!


CONFIRMED!!! w/ Niresh12495's usb bootable image and http://www.alexpage....-tool/download/

GREAT JOB!

#711
shawndoggy

shawndoggy

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
Yeah I got ml working finally too. Created the usb bootable image from the ap store download with ###### then booted with chameleonmlboot and was off to the races.

I use USB audio, so basically everything worked right out of the box.

#712
scoobydu

scoobydu

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts

@scoobydu
My last DSDT should be ok for HDMI Audio. In my opinion AppleHDA.kext is the reason why this thing isn't working. Unfortunately I have no idea how to patch this kext and not much desire to learn it. ;) So if there is anyone out there who knows what to do with AppleHDA.kext, it would be perfect if "the one" ;) could help us to manage this thing.


Ok thanks will take a look.

hello,

here comes an update for the ChameleonBoot stick ready for Mountain Lion
and Chameleon rev. 2050 patched for our board.

Same procedure as here

Onboard audio will work with patched AppleHDA.kext form Lion or try out the ML preview version by toleda (in this case use the DSDT from the additional folder of the image).

There are some nice kexts for monitoring in the additional folder too, but you don't need them. (Credits to Slice and others on projectosx.com)

Good luck!


Have audio working on 2050 previously, but not HDMI audio; is that still not going to work?

Cheers

#713
olegischinski

olegischinski

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

Have audio working on 2050 previously, but not HDMI audio; is that still not going to work?

Cheers

hi scoobydo

I'm afraid, audio via HDMI for 9400 chipset will never work on OSX. Don't waste your time.

Cheers

#714
e60

e60

    InsanelyMac Geek

  • Donators
  • 118 posts
  • Gender:Male

@LJSeinfeld


Good idea! By the way, I'm currently working on a new and user friendly Mountain Lion Guide. :)


Hey guys,

unfortunately it seems like I've bit off more than I can chew. ;) I am becoming a father and because time is precious, I won't be able to finish a understandable and easy to use Guide in in the near future. I hope you guys won't be disappointed with me.

#715
rblissitt

rblissitt

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Location:Dallas, TX
Congrats, e60! Thanks for all your help hackintoshing the e7aum, from which I'm writing this post. :)

#716
LJSeinfeld

LJSeinfeld

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
  • Gender:Male
OK- I'm back on hackintoshing the E7AUM.

First, congrats to e60 --and thanks for all your help with getting things working ont this board!

I've managed to get 10.8.2 up and running on my system, using the onboard gpu and the boot file from olegischinski's chameleon boot image. My question is: Will we always need a specially patched chameleon/chimera bootloader to get things working with this board?

#717
olegischinski

olegischinski

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
hi LJSeinfeld,

as usual: with onboard GPU and more than 2 GB RAM the BIOS reports a wrong memory map that has to be corrected by the boot loader.
So if you stick to these restrictions, ###### method should be possible (never tested).

Good luck!

#718
LJSeinfeld

LJSeinfeld

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
  • Gender:Male

hi LJSeinfeld,

as usual: with onboard GPU and more than 2 GB RAM the BIOS reports a wrong memory map that has to be corrected by the boot loader.
So if you stick to these restrictions, ###### method should be possible (never tested).

Good luck!


Thanks for the reply (and also for all your help with this board as well) :) -- could this also be accomplished via other means in the boot.plist? (sorry if this is a dumb question, but it goes a little beyond my current level of understanding)

#719
olegischinski

olegischinski

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
no, there is no boot option nor key for this. Chameleon contains some code to rearrange the memory map, but it's not active by default. That's why we have to patch it for this board.

#720
LJSeinfeld

LJSeinfeld

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
  • Gender:Male

no, there is no boot option nor key for this. Chameleon contains some code to rearrange the memory map, but it's not active by default. That's why we have to patch it for this board.


Now I get it -- Thanks =D
I think I remember something about patched BIOS for this board now that I think about it.. is that a possible "permanent" fix to the problem? (I understand there is some risk in BIOS flashing)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy