Jump to content

[GUIDA] 2 schede video e 4 monitor su P5N-E SLI


  • Please log in to reply
42 replies to this topic

#1
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....
Scrivo questa guida in seguito al lavoro che ho fatto in questi ultimi 10 giorni e che mi ha tenuto molto impegnato; essendo venuto in possesso di una Asus P5N-E SLI, ho deciso di tentare di installare 2 schede grafiche (Nvidia) con 4 monitor, con QE/CI attivati, in Leopard 10.5.6.

La guida sarà divisa in 2 parti:

1) La prima riguarda l'installazione di Leopard 10.5.6 su Asus P5N-E SLI, funzionante al 100%, compresi audio in/out, LAN e Firewire. (ovviamente si potrà adattare a motherboard con lo stesso chipset nForce 650i SLI).

2) La seconda riguarda più specificamente il riconoscimento delle schede video e attivazione di QE/CI.

La seconda parte può essere utilizzata anche da possessori di altre schede madri SLI, anche con altro chipset, che abbiano installata una versione di Leopard 10.5.6. Inoltre chi possiede una scheda madre con 2 slot PCI-E per schede grafiche in tecnologia crossfire, con una versione di Leopard 10.5.6 e abbia la possibilità di provare 2 schede grafiche Nvidia, pu򠰲ovare la Fase 2): ogni feedback è assolutamente gradito, sia positivo che negativo, in quanto non ho avuto la possibilità di effettuare questa prova.

A questo scopo ho modificato NVinject 0.2.1 per poter funzionare come injector per 2 schede video Nvidia, supportate dai kexts (drivers) della 10.5.6. Sono supportate schede a 256, 512 e 1024 MB di RAM.

Le 2 schede video dovrebbero essere della stessa pezzatura di RAM (2x256 MB o 2x512 MB etc), in quanto non sono ancora riuscito a far riconoscere 2 pezzature diverse di RAM dal singolo NVinject. Comunque usando 2 schede con RAM differente, funzioneranno lo stesso avendo l'accortezza di usare il NVinject per la pezzatura maggiore di RAM (nel System Profiler verranno viste 2 Schede con ad es 512 MB di RAM, mentre una ne avrà realmente 512 e l'altra ad es 256,ma funzionerà normalmente, la dicitura del System Profiler è puramente estetica, ho provato con dei tests e le 2 schede con RAM diversa funzionano perfettamente).

Le schede video possono essere della serie 7,8 e, con i driver di aqua mac, 9, inoltre ho provato della serie 6 la 6600.

Le 2 schede video possono anche NON essere uguali (ad es una 8600GT + una 8500GT etc), ovviamente non andranno collegate col ponticello SLI.

Il ponticello SLI E' ININFLUENTE sul funzionamento in Leopard (mentre serve a chi ha sullo stesso PC Windows o Linux e voglia sfruttare la tecnologia SLI).

Due parole sulla tecnologia SLI: Le motherboard con tecnologia SLI hanno 2 slot PCI-E.
Tali slot, nella configurazione con una sola scheda video on board, sono dei normali slot con PCI Lane a 16 Bit. Nella configurazione con 2 schede video on board, ponticello SLI inserito e driver SLI caricati (ovviamente solo in Windows e Linux) la seconda scheda non viene vista, mentre la prima viene vista come scheda con PCI Lane a 16 bit e potenzialità di calcolo grafico teorica doppia rispetto alla singola scheda e con RAM doppia. In realtà la potenza di calcolo grafico è solo il 50-60% superiore a quella della singola scheda per una serie di motivi.
Nella configurazione con 2 schede video collegate in SLI ma senza driver (es Leopard sempre, Linux e Windows senza driver SLI caricati) o non collegate in SLI (qualsiasi SO), le 2 schede vengono viste come 2 schede separate con PCI Lane a 8 bit, ognuna con la propria dotazione di RAM.

Cosa vi occorre:

1) La iso di una delle 3 versioni di Leopard 10.5.6 (vedi Fase 1);

2) La cartella compressa con: tutto l'occorrente per fixare le 3 versioni di Leopard per la P5N-E SLI; le versioni patchate di NVinject kext. Link:
http://www.megaupload.com/?d=55APZL0D

3) Kexthelper7 (presente in tutte e tre le versioni tra le applicazioni).


Fase 1) Installazione di Leopard 10.5.6 su Asus P5N-E SLI:

Si possono installare varie versioni Leopard, a seconda della propria configurazione hardware, in particolare le 3 che ho scelto sono: iPC OSx86 PPF5 final; XxX 10.5.6 e iDeneb 1.4.

La versione del BIOS che ho utilizzato è la 1101, che non mi ha dato alcun problema, ma è testato anche con la 1301.

IPC OSx86 10.5.6:

Può essere installato da masterizzatore IDE o SATA su HD IDE o SATA. Consiglio di avviare l'installazione con -v in caso di eventuale errore.

Scelte da fare in fase di personalizzazione:

□ iPC OSx86 10.5.6 Base System: tutto;
□ Lingue disponibili: Italiano;
□ iPC OSx86 10.5.6 intel AMD SSE2 SSE3:
□ Kernels: nothing (default vanilla);
□ Video Drivers: nulla
□ Chipset Drivers: AppleNForce ATA nForce Drivers +
JMicronATA for JMicron IDE
□ Ethernet Drivers: nForce Ethernet Driver
□ Fixes and Patches: nulla

□ Alternate Bootloaders: Chamaleon with SMBIOS/DSDT
□ Applications: tutte.

Alla fine dell'installazione riavviate con -v, eseguite le operazioni preliminari di Leopard ed entrate nel sistema;
Aprite Kexthelper7, e con questo installate: AppleSMBIOS.kext, AppleNForceATA.kext
Chiudete Kexthelper7.
Installate Italian.pkg, installate ALC883Audio.mpkg e riavviate con -v
Fine Fase 1)


XxX 10.5.6:

Può essere installato da masterizzatore IDE su HD IDE o SATA. Consiglio di avviare l'installazione con -v in caso di eventuale errore.
Scelte da fare in fase di personalizzazione:

□ Optional Bootloaders: PCEFI_v9.0

□ DSDST Patcher: si

□ System kexts:
□ Essential System Kexts: tutti
□ Optional System Kexts: nessuno
□ 10.5.5 Kexts: nessuno
□ Optional Kernel:nothing
□ Chipset Support: AppleNForceATA Test + JMicron ? JMB360
□ Graphics Drivers: nulla
□ Audio Drivers: nulla
□ Network Drivers: nulla
□ PowerManagement: nulla:
□ Others: nulla
□ Legacy Kexts: nulla
□ Tools: tutti tranne Soundflower

Alla fine dell'installazione riavviate con -v, eseguite le operazioni preliminari di Leopard ed entrate nel sistema;
Aprite Kexthelper7, e con questo installate: seatbelt.kext AppleSMBIOS.kext
Chiudete Kexthelper7
Installate Italian.pkg, ALC883Audio.mpkg (non riavviate) e nForceEthernetDriver.pkg
E riavviate con -v
Fine Fase 1)

iDeneb 1.4:

Può essere installato da masterizzatore IDE su HD IDE o SATA. Consiglio di avviare l'installazione con -v in caso di eventuale errore.

Scelte da fare in fase di personalizzazione:

□ Lingue Disponibili: Italiano
□ Font Aggiuntivi: si
□ X11: si
□ iDeneb Essential System: tutto
□ Patches 10.5.6 Ready:
□ Alternate Essentials Patch: nulla
□ Audio: nulla
□ Chipset: AppleNForceATA Test + JMicronATA
□ Kernel: nulla (vanilla default)
□ Network: nulla
□ Fix: AppleSMBIOS (667 o 800 a seconda della vostra RAM)
□ System Utilities: nulla
□ Video: nulla
□ Applications: tutte
□ Netbook: nulla
Alla fine dell'installazione riavviate con ?s e al prompt dei comandi digitate:

mount -uw / <invio>
cd /System/Library/Extensions <invio>
rm -rf GeForce.kext <invio>
rm -rf NVDAResman.kext <invio>
rm -rf NVDANV50Hal.kext <invio>
reboot <invio>

e riavviate con -v eseguite le operazioni preliminari di Leopard ed entrate nel sistema;

Aprite Kexthelper7, e con questo installate: GeForce.kext NVDAResman.kext NVDANV50Hal.kext, seatbelt.kext AppleDecrypt.kext
Chiudete Kexthelper7
Installate ALC883Audio.mpkg (non riavviate) e nForceEthernetDriver
E riavviate con -v
Fine Fase 1)

Fase 2)

A questo punto, partendo da una delle 3 versioni installate su P5N-E SLI o da una qualsiasi 10.5.6 su altra motherboard SLI:

Per chi non ha usato la Fase 1) e giunge alla Fase 2) da un'altra installazione: cancellare l'eventuale Efistring presente nel com.apple.Boot.plist ed accertarsi di non avere Nvinject.kext, NVKush.kext, NVDarwin.kext o qualsiasi altro injector (in tal caso cestinateli)

Per tutti: aprite Kexthelper7 e installare il NVinject della RAM desiderata da una delle cartelle presenti nel file compresso scaricato, riavviate con -v -f e avrete 2 schede funzionanti con 4 monitor e QE/CI attivati.


Ogni vostro feedback o esperienza è gradita.


Allego 3 immagini di System Profiler e dei monitor funzionanti:

Attached File  scheda1.jpg   125.37KB   81 downloads

Attached File  scheda2.jpg   132.62KB   58 downloads

Attached File  monitors.jpg   278.1KB   126 downloads

Giorgio

#2
Luca70

Luca70

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Firenze (Italia)
Ciao Giorgio,
mi sono ritrovato con due schede video 8400gs (una xfx ed una gainward) credi che la cosa possa funzionare? Ho una Mo.Bo P5k. Eventualmente se non dovesse riconoscere le 2 schede il sistema credi che partirebbe comunque? Avevo provato anche solamente a cambiare la xfx con la gainward ma il computer partiva fino alla schermata della mela poi.... il niente!
Una domanda prima di tutte: come faccio ad avviare in -v -f? con il cd boot 123?

Grazie.

#3
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Ciao Giorgio,
mi sono ritrovato con due schede video 8400gs (una xfx ed una gainward) credi che la cosa possa funzionare? Ho una Mo.Bo P5k. Eventualmente se non dovesse riconoscere le 2 schede il sistema credi che partirebbe comunque? Avevo provato anche solamente a cambiare la xfx con la gainward ma il computer partiva fino alla schermata della mela poi.... il niente!
Una domanda prima di tutte: come faccio ad avviare in -v -f? con il cd boot 123?

Grazie.

Una cosa alla volta. Per provare con 2 schede video devi avere una 10.5.6 funzionante. poi basta eliminare qualsiasi injector tu abbia (nvinject, nvkush o efistring) e installare con kexthelper il nvinject modificato di questa guida.

Ripeto che con la tecnologia crossfire (come la tua motherboard) è da provare, teoricamente dovrebbe funzionare.

Giorgio

#4
Luca70

Luca70

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Firenze (Italia)

Una cosa alla volta. Per provare con 2 schede video devi avere una 10.5.6 funzionante. poi basta eliminare qualsiasi injector tu abbia (nvinject, nvkush o efistring) e installare con kexthelper il nvinject modificato di questa guida.

Ripeto che con la tecnologia crossfire (come la tua motherboard) da provare, teoricamente dovrebbe funzionare.

Giorgio


Per OSx siamo a posto, installato e perfettamente funzionante sulla mia P5K....

Siccome sono molto "acerbo" in materia di hackintosh chiedo le cose basilari tipo:
come faccio a riavviare con -x-f? con il cd boot che ho usato per l'installazione della retail?
per eliminare gli injector basta che li cerchi nella cartella "extension" vero?
visto che quando ho sostituito la xfx 8400gs con la gaiward 8400gs il risultato stata una bella schermata nera, se al momento dell'installazione dei nuovi kext mi ritrovassi alle solite come faccio a far ripartire il sistema senza dover reinstallare tutto?

Grazie della pazienza :-)

#5
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Per OSx siamo a posto, 蠩nstallato e perfettamente funzionante sulla mia P5K....

Siccome sono molto "acerbo" in materia di hackintosh chiedo le cose basilari tipo:
come faccio a riavviare con -x-f? con il cd boot che ho usato per l'installazione della retail?
per eliminare gli injector basta che li cerchi nella cartella "extension" vero?
visto che quando ho sostituito la xfx 8400gs con la gaiward 8400gs il risultato è stato una bella schermata nera, se al momento dell'installazione dei nuovi kext mi ritrovassi alle solite come faccio a far ripartire il sistema senza dover reinstallare tutto?

Grazie della pazienza :-)

Io farei una cosa alla volta. Per far partire con -v -f o con qualsiasi altro flag non occorre il dvd, quando appare il darwin bootloader col conto alla rovescia premi un tasto qualsiasi poi metti -v -f

Per cancellare basta mettere nel cestino come hai detto tu.

In Hackintosh rischiare è la norma.
Il nuovo nvinject lo installi con Kexthelper
molto strano lo schermo nero sostituendo una scheda con un'altra identica ma di altra marca. Controlla che gli id delle 2 schede siano uguali.

Giorgio

#6
Luca70

Luca70

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Firenze (Italia)
Grazie mille giorgio, adesso provo ma... il conto alla rovescia? non ci ho fatto proprio caso... il sistema parte in un battito di ciglia!
Il problema (per controllare gli id delle schede) che se installo la seconda mi ritrovo sempre con la schermata nera.... forse partendo in -x -f riesco a vedere qualcos?
vado di corsa a provare!

Grazie ancora!

ps: in un altro topic chiedevi per il funzionamento delle memorie a 1066... io non sono riuscito a farle andare ma, come vedi, la mia "esperienza" nello "smanettare" su di un pc molto limitata.... se vuoi darmi qualche consiglio per provare a forzare le memorie da bios vai pure....

#7
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....
Se parte subito la mela e non vedi il conto alla rovescia vuol dire che in com.apple.Boot.plist non c'è l'opzione Timeout, ma queste cose esulano dalla guida, apri un topic nell'altra sezione. Bisogna rimanere in argomento, prima risolvi gli altri problemi a basso livello, poi prova il salto con 2 schede.

Giorgio

#8
Luca70

Luca70

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Firenze (Italia)
Ok, grazie comunque. a presto.

#9
empty skull

empty skull

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,544 posts
  • Gender:Male
  • Location:Italy
hahahahha e io che pensavo di essere fuori di testa con 3 pc in camera e 4 monitor !!!!!!

#10
Mr_Ale

Mr_Ale

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
Ciao a tutti!il mio problema è il seguente spero possiate aiutarmi: quando vado a installare ideneb mi appare subito il segnale di divieto sulla mela. Avviando con -v mi da questo errore: SAM MULTIMEDIA: read or write failed poi error firewire unable ti determinate security mode defaulting to fullsecure infine still waiting for root device. Non so che fare ho seguito le guide ma niente!

Configurazione hardware: -P5n-e sli- 2gb ram- intel quad q6600- asus engts250 -soundblaster audigy 2.

Grazie a tutti per l'aiuto!

#11
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Ciao a tutti!il mio problema è il seguente spero possiate aiutarmi: quando vado a installare ideneb mi appare subito il segnale di divieto sulla mela. Avviando con -v mi da questo errore: SAM MULTIMEDIA: read or write failed poi error firewire unable ti determinate security mode defaulting to fullsecure infine still waiting for root device. Non so che fare ho seguito le guide ma niente!

Configurazione hardware: -P5n-e sli- 2gb ram- intel quad q6600- asus engts250 -soundblaster audigy 2.

Grazie a tutti per l'aiuto!


Ciao, dovresti cortesemente leggere il regolamento ed adeguarti, altrimenti nessuno ti può rispondere (punto 8).

Giorgio

#12
Mr_Ale

Mr_Ale

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
Ok, scusa ora dovrei essere in regola! :unsure: Ripropongo il problema:Ciao a tutti!il mio problema è il seguente spero possiate aiutarmi: quando vado a installare ideneb mi appare subito il segnale di divieto sulla mela. Avviando con -v mi da questo errore: SAM MULTIMEDIA: read or write failed poi error firewire unable ti determinate security mode defaulting to fullsecure infine still waiting for root device. Non so che fare ho seguito le guide ma niente!
Grazie a tutti per l'aiuto!

#13
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Ok, scusa ora dovrei essere in regola! :unsure: Ripropongo il problema:Ciao a tutti!il mio problema è il seguente spero possiate aiutarmi: quando vado a installare ideneb mi appare subito il segnale di divieto sulla mela. Avviando con -v mi da questo errore: SAM MULTIMEDIA: read or write failed poi error firewire unable ti determinate security mode defaulting to fullsecure infine still waiting for root device. Non so che fare ho seguito le guide ma niente!
Grazie a tutti per l'aiuto!

Perfetto.

Che masterizzatore hai? (SATA o IDE?)

Che versione di iDeneb? 1.4 1.5 o 1.6 Lite?

PS: se ti interessa è uscita la guida per installare Snow Leopard su P5N-E SLI
http://www.insanelym...howtopic=207164

Giorgio

#14
Mr_Ale

Mr_Ale

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
Masterizzatore sata e la versione ideneb dovrebbe essere la 1.4 se metto il dvd e vado su risorse del computer c'è scritto Layne Osx 86. forse ho sbagliato versione.

Grazie!

#15
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Masterizzatore sata e la versione ideneb dovrebbe essere la 1.4 se metto il dvd e vado su risorse del computer c'è scritto Layne Osx 86. forse ho sbagliato versione.

Grazie!


Se leggi bene la guida vedrai che iDeneb va installato da Masterizzatore IDE.

Per installare da masterizzatore SATA devi usare IPC 10.5.6

Giorgio

#16
Mr_Ale

Mr_Ale

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
Ok!Grazie proverò,avendolo gia scaricato ieri sera!Ti farò sapere grazie per la disponibilità!

#17
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Ok!Grazie proverò,avendolo gia scaricato ieri sera!Ti farò sapere grazie per la disponibilità!



ideneb da SATA su questa motherboard non si installa.

Giorgio

#18
Mr_Ale

Mr_Ale

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
Ciao! sono riuscito ad installare come hai detto te iipc ho spuntato personalizza ho scelto le cose elencate nella guida tutto ok!al riavvio alla schermata con la mela e il caricamento dopo un pò diventa grigio ed esce una scritta che dice di riavviare. Una volta riavviato però mi da sempre lo stesso errore anche riavviando con -v o -x. Consigli? Grazie!

#19
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Ciao! sono riuscito ad installare come hai detto te iipc ho spuntato personalizza ho scelto le cose elencate nella guida tutto ok!al riavvio alla schermata con la mela e il caricamento dopo un pò diventa grigio ed esce una scritta che dice di riavviare. Una volta riavviato però mi da sempre lo stesso errore anche riavviando con -v o -x. Consigli? Grazie!



Riavvia con -v e posta una foro dello schermo al blocco.

Giorgio

#20
Mr_Ale

Mr_Ale

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
ciao!non riesco piu ad avviare mac perche ho installato xp nell'altra partizione!ho provato la modifica del boot.ini col chain ma niente!poi ho reinstallato mac e mi dava errore hal.dll all'avvio del mac nel boot. ho cancellato xp reinstallato mac ma non va più. finita l'installazione si ferma su una schermata grigia col caricamento e non si riavvia.se riavvio col bottone non va!Grazie per l'aiuto.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy