Jump to content

ATI 3850 HD AGP 512 GDDR3 DEVID 9505 with CI / QE & dual screen 10.5.6


  • Please log in to reply
13 replies to this topic

#1
Mohammadkoush

Mohammadkoush

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
First this might work with the same card but PCIE
motherboard ASUS p4p800 deluxe
cpu 3.0 GHZ
video ATI 3850 HD AGP GDDR3 512 MB
distro ideneb ver 1.4 10.5.6
ok, i have tried so many stuff out there , none seams to work for me , (or they did, but i had the bios wrong at that time, i don't know) but here is what happened

if i have the aperture in bios at:
6 MB card gets detected but no CI/QE
64 MB card gets detected with CI/QE
128 MB disco screen at startup
256 MB disco screen at startup

found out this info after lots of restart and freken permission repair and lots of distros
i used the latest agpgart Link @ mediafire, thanks to people behind agpgart
i don't remember where i got this but here is a link to the card driver Link @ mediafire

thank to all people working on this drivers, i'll will not name them bc i know i will forget some ,
thanks to all people bihind ideneb, netkas, skage, .... and who ever made this a possibility
please who ever use this tip and benefit from it, report back to see how many people did benefit from my experience
Posted Image

#2
Qwert

Qwert

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
This is great!
I have a 3650 AGP card and I'm trying to install ideneb 1.4 with no succes! I know it's not the same card but can you give me some advice?
During the installation process have you selected any driver or fix for this card or you have started in vesa 3 and installed all the thinghs separately?

(sorry for my bad english.. :laser:)

#3
Mohammadkoush

Mohammadkoush

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
@ qwert

at install i did not select any video card to install, but never the less ati drivers were installed , i would suggest to after install, to boot using -x for safemode, then go to your extentions folder and delete all files start with ati*, and then reboot and try the files i found.

good luck

update: i have tried to install ipc 10.5.6 destro but it is still too bugy for me

#4
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,192 posts
  • Gender:Male
  • Location:Moscow
Thank you for the good report!
AGPGart 2.7.1 can be downloaded here

#5
Mohammadkoush

Mohammadkoush

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
i'll keep it up to date as long as there is some one benefiting from it



thanx for the link slice

#6
Mohammadkoush

Mohammadkoush

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
bump to keep this up top to help ppl out

#7
scleone1987

scleone1987

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
how can it work with my Sapphire Radeon hd 3850 AGP (512 mb gddr3, dev id 9515?) thanks

#8
Mohammadkoush

Mohammadkoush

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
please see your pm

#9
JeWy85

JeWy85

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Thailand

how can it work with my Sapphire Radeon hd 3850 AGP (512 mb gddr3, dev id 9515?) thanks

I have sapphire 3850 AGP as well can you tell me how to install this thanks
Where do I put those kext???

#10
t1mman

t1mman

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hey there, just woundering if you could give me a hint on this one, basicaly, I have the same hardware
P4P800
Prescott 3.0Ghz
ATI 3850
I've tried numerous time to install iDeneb 1.4 but to no avail. So, I would realy be thankfull if you gave me some info on wich options you used for the install and what settings in the Bios.

Thanks a million times!

#11
edgecrush3r

edgecrush3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
Can anyone please please specify "what" exactly needs to be installed to get the 3850 AGP card working?
I downloaded and installed both kexts (AGPG271 and ATI_NEW), but still nothing seems to be HW accelerated at all.
Please help.

#12
edgecrush3r

edgecrush3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male

Can anyone please please specify "what" exactly needs to be installed to get the 3850 AGP card working?
I downloaded and installed both kexts (AGPG271 and ATI_NEW), but still nothing seems to be HW accelerated at all.
Please help.


I got my card working now (Device-id 9515: Radeon 3850 AGP) with full HD resolution (1920x1080p) :P !!!

to change the device id open a Terminal.
1. Edit the /System/Library/Extension/ATIRadeonX2000.kext/Contents/Info.plist
2. Replace 0x95051002 with 0x95151002 (adding is also an option)
3. Save
4. Edit /System/Library/Extension/Natit.kext/Contents/Info.plist
5. Find and replace 0x9505 with 0x9515 (or add an entry)
6. Save

7. Set the right permissions (chown -R root:weel /System/Library/Extensions/*)
8. Rebuild the kextcache (kextcache -k /System/Library/Extensions/)


PS: Hardware Acceleration is still not functioning (Core Image: Software). Does any1 know how to fix this????

Cheers,
Tony

#13
Frakke

Frakke

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
I get a white screen :)

#14
fukmondo

fukmondo

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Does anyone have this card working in snow leopard and how?

Many many thanks for this topic, flawlessly functioning under iDeneb 10.5.6 updated to 10.5.8.

On snow far as I go was boot in safe mode agp gart 2.71 finds card but no go after that, aty netkas agp enabler finds it like pci card in slot 1 and there story stops, and with original kext and aty init from snow x2000 kext I got full boot but graphic was garbled with bricks but it seems like it could work? so close so far bah.

anyone have snow working?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy