Jump to content

[How to] Intel GMA 900 done right: full QE/CI for leopard


  • Please log in to reply
116 replies to this topic

#21
piggor

piggor

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Coooooooool ! :)

#22
clemsyn

clemsyn

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
This works great on my D610! I have to use the AppleIntelIntegrated Framebuffer because the original from 10.5.6 gives me a blue screen. I also changed some settings on the AppleIntelIntegreated buffer to control the brightness. Anyone interested for D610 brightness control, let me know :)

#23
simkard

simkard

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hey why not ?!
post it anyway, i'm sure it will be fine for some people :(

thanks by the wey for these excellents KEXTs !!!!!

#24
scorpyo69

scorpyo69

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi Guys...


:( It doesn't work!!! I'm desperate!

i've tried with the attached framebuffer and I had a black screen with the pointer. Then I tried with the latest from leopard 10.5.6 from my other mac and no success either: the computer is working fine but instead of the blue screen i have the Apple grey screen stuck.

So i revert to the tiger one. 10.4.7. Either no success. BLACK SCREEEEEEN.

In all the cases the computer is working.

the id is 0x2582

Any help is really appreciated. My sister is going to kill me if I don't fix her "Mac"!!!

pleeeese.. :)

#25
scorpyo69

scorpyo69

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Did It!!!

Thank you! I had to download and install the leopard graphics package upgrade for 10.5.2. Reboot it and.. now QE/CI is working great! Still I can't change the res, but i won't quit...

good work!!!

#26
Stlouie65

Stlouie65

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

What is it? This is an enabler kext which gives your Intel GMA900 (i915) graphic card hardware acceleration (QE/CI) support under Leopard. This is not a patched or modified kext. It is supposed to be used in addition to the GMA950 kexts that come with leopard.

Details: There are a lot of patched kexts floating around for GMA900 support in Leopard. dfe aka David Elliott has made a great enabler kext which allows GMA900 cards to use stock GMA950 kexts. This means NO patching or hacking is required and you can keep using Apple software updates and take advantage of updated graphic kexts.

How to use -

Install these two kexts. Reboot. That's all.

This works for all GMA900 device IDs (0x2582, 0x2592, 0x2792)


Notes

  • You must have all stock kexts. If you are using patched kexts currently, please revert all AppleIntelGMA* to the ones that came with your version of Leopard.
  • The framebuffer is old. Some people may be able to use stock framebuffer too, but most often you will need this older framebuffer kext.
  • Resolution changing and mouse artifacts are related to framebuffer. So if you are trying to fix those, the framebuffer kext is what you want to experiment with first, followed by original GMA950 kexts.
  • Please no OpenGL.framework hacking either. Everything should be original Leopard version.
I have not made these kexts, the work is dfe's, I am only bringing it to the OSx86 community and therefore cannot offer any support except maybe adding any new device IDs


Thanks Mercury, this works perfect. I had to extract the Leopard Graphics update and your kexts worked.

#27
lazetime

lazetime

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
Awesome. It works on my Acer Extensa 2600 Laptop with 10.5.6.
Thanks a lot.

#28
asofan

asofan

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:yemen
Hey Guys,

I installed IDeneb 1.3 (10.5.5) on my m55-s3293 laptop with the following specs:

http://www.clearance...om.cgi?sku=4935

the laptop has an intel 900 display, but after I installed the kexts you provided, I don't get support for Quartz Extreme nor Core Image. I am able to change resolutions though so I don't know what I did wrong.

attached is a screenshot of system profiler of the Graphics driver as well as another screenshot of the extentions folders showing the kext files I have installed.

Thanks in advance guys!

(By the way, it took me a while to get to this point, so if anyone needs help installing iDeneb 1.3 on a similar system, let me know. I will be happy to help)

Attached Files



#29
asofan

asofan

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:yemen
bump! anyone?

#30
tivimac

tivimac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Gender:Male
  • Location:Dominican Republic
You didn't need the paperclip trick if you use the file attached. It's not my work though is from another post in this forum.

Tested on Dell Inspiron 2200 (my old lappy) Using stock 10.5.5 with Voodoo Kernel

Man, we have been waiting MONTHS and some even YEARS for this...

"yeah 900 GMA...not going to happen, get a better graphics card" and then you come and conjure up this piece of work.

Awesome job. Gonna try it out after ccc, andy4life, h2a's method. I wonder if it comes with no paperclip/external monitor support.

Again, nice job!

Attached Files



#31
kroeger

kroeger

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts

You didn't need the paperclip trick if you use the file attached. It's not my work though is from another post in this forum.

Tested on Dell Inspiron 2200 (my old lappy) Using stock 10.5.5 with Voodoo Kernel

tivimac could you let me know what method you used to install leopard on your 1525 please?

I have the same model except with Dell 1395 wireless. I have tried a Kalyway install updated to 10.5.5 but always have problems with shutdown, cpu fan always on etc.

#32
beast01

beast01

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
great , great , simply great fix , thx mercurysquad


no paperclip needed to boot , detect displays works fine and QE is supported in iDeneb v1.3 10.5.5

will test how video and apps behave , for now i see only some artefacts in the search field of itunes , hope

it's not the case with cs4

thx again

#33
tivimac

tivimac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Gender:Male
  • Location:Dominican Republic

tivimac could you let me know what method you used to install leopard on your 1525 please?

I have the same model except with Dell 1395 wireless. I have tried a Kalyway install updated to 10.5.5 but always have problems with shutdown, cpu fan always on etc.



On my Inspiron 1525, I use a Retail DVD (10.5.4) + Boot 132 .... The only problem that I have is a SHUTDOWN when I on BATTERY... always give me KP ...

#34
moly82

moly82

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts

It works! But since I'm using speedstep, I don't know if it hinders the performance of videos and audio. With the other method (the not done right method), the videos seemed to be okay. Or it could be something else.

Which is one requires more resources? This method or andy4life, h2a's, ccc's etc. method?



hi down.. can you tell me which speedstep kext you are using on your install?

I get the speedstep working with the kext by mercurysquad, but it works only when I am connected to the power.. not on battery....



bye!

#35
aaronwang

aaronwang

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I can enable QE/CI now,thanks alot!

but I can't contral backlight with Fn + F4(F5) with this driver

#36
Himself(themanhimself)

Himself(themanhimself)

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Works perfectly on Sony Vaio FS715 with the 915 chipset. Thanks to both of you!

#37
asdf1smith

asdf1smith

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
Hello

I ve installed the packages and it didnt work. Furthermore, i reverted back to my old kexts, where I had QE+CI working, and, for some reason, I dont have them working anymore :wacko:. I just wanted to get the rid of the annoying paperclip...

Could anyone please post their AppleIntelGMA950.kext and GA plugin, VADriver and GLDriver bundles from 10.5.2????
Thank you! If anyone has these kexts from newer versions, would it be also possible to use them on my system?????? I just dont want to reinstall the whole system to get the good-old kexts :censored2:

Thanks

#38
mercurysquad

mercurysquad

    InsanelyMac Legend

  • Retired Developers
  • 521 posts
  • Gender:Male
  • Location:India

You didn't need the paperclip trick if you use the file attached. It's not my work though is from another post in this forum.

Tested on Dell Inspiron 2200 (my old lappy) Using stock 10.5.5 with Voodoo Kernel

The framebuffer kext I attached in the original post also doesn't require any paperclip.

#39
tivimac

tivimac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Gender:Male
  • Location:Dominican Republic

The framebuffer kext I attached in the original post also doesn't require any paperclip.



Hello Sir, my respect, I test the AIF in the first post and didn't work on my particular test laptop (i2200) but you know how crappy and picky are the dells.

Anyway the AIF that I post is not my work either. but is working on my rig. Thanks. This old lappy (i2200) is working at 100% (only the modem miss :D ) Using your kernel and speedstep kext.

#40
srknylmz

srknylmz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
it worked for me on dell isnpiron 6000

thanksss

(iatkos 5i 10.5.5)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy