Jump to content

Guide Installation Sony VAIO VGN-NR10E/S OSX 10.5.2 Kalyway-> combo update 10.5.5 et Winxp SP3


  • Please log in to reply
30 replies to this topic

#1
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
Bonjour,

Mise à jour du 20/01/2009
A la fin du guide, il y a également la méthode pour mettre à jour OSX vers la 10.5.5



Un petit guide pour installer Leopard 10.5.2 Kalyway sur un Sony VGN-NR10E/S :


1) Partition du disque de 160Go.
- Pour ma part, j'ai effacé la partition de sauvegarde Vista du portable. Vous n'êtes pas obligé.
- Création de deux partitions : le 1er OSX et le 2nd WINXP

2) Rendre la 2nd partition WINXP Bootable
- Utiliser Gparted pour rendre la partition WINXP bootable

3) Installation de Win XP SP3 sur la 2nd partition WINXP
A ce stade, le laptop doit démarrer correctement sur XP

4) Installation de Leopard 10.5.2 Kalyway sur la 1er partition OSX
- Formater la 1er partition OSX avec l'utilitaire dans le programme d'installation Leopard 10.5.2 Kalyway.
- Selectionner la partition OSX pour l'installation
- Les options :
Kernel speedstepkernel
Carte graphique Intel X3100
Audio Intel NVIDIA VIA ATI HDAudioController
Pas d'option Ethernet ni Wifi
Mobo_Chipsets, Thirds_Applications et Patches je coche tout on se sais jamais
SSE2 et AMD ne sont pas cochés
Attention parmi les applications à avoir Third_Application il faut le kextHelperB7 pour aisement installer les drivers.

- Lorsque le programme d'installation vous demande de redémarrer
Ouvrir le terminal, ceci bloquera le décompte de redémarrage

L'objectif est de supprimer le driver de la carte graphique Intel GMAX3100
taper :
cd /Volumes/OSX(nom de votre partition Leopard)/System/Library/Extentions
mkdir SAUVE
cp -r *GMA* SAUVE/
rm -rf *GMA*
diskutil repairPermissions /Volumes/OSX



5) Faire reconnaitre la carte graphique GMAX3100
- Rebooter
Si vous rebooter sur Winxp alors il faut utiliser GParted pour changer le boot sur la 1er partition. Pour ma part il a démarrer correctement sur la 1er partition OSX avec Darwin qui propose en pressant F8 le choix entre Winxp et OSX.

- Leopard 10.5.2 Kalyway doit démarrer sans carte graphique reconnu avec une résolution de 1024x768
- Créer votre compte
- Une fois sur le bureau, ouvrir un terminal (voir répertoire application/utilitaire)
- ajouter un mot de passe à root en tapant sur le terminal: sudo passwd root
- ouvrir kextHelperB7
- ajouter les drivers GMAX3100 qui se trouve dans
/Volumes/OSX(nom de votre partition Leopard)/System/Library/Extentions/SAUVE ou les dernier drivers GMAX3100
- ajouter également le driver ethernet AppleYukon
- taper dans kextHelperB7 votre mot de passe root
- cliquer sur easy install

- Rebooter
Normalement, Leopard démarre avec un écran noir mais avec la musique d'accueil. Bizarrement le moniteur du VAIO ne permet pas d'afficher la résolution 800x600 60Hz avec Leo.
- Connecter sur le port VGA, un deuxieme moniteur, il apparait comme un fenêtre secondaire (bureau étendu).
- Avec un peu de chance vous pouvez faire glisser le Finder sur cet écran
- Aller sur application et choisir "Préférence systeme"
- sur la partie Moniteur, choisir la résolution 1027x768 60Hz
Normalement l'ecran de votre ordinateur doit afficher la fenêtre principale du bureau Mac os

Youpiii....

Pour basculer sur une résolution 1280x800, il faut installer SwitchResX, et ajouter/appliquer la résolution supplémentaire 1280x800 60hz

Surprise, Leopard avec la résolution 1280x800, QE/CI ok
Pour ce qui est de l'ethernet, il suffit de renouveler le DHCP dans réseau.

Malheureusement la carte wifi Atheros AR5007EG n'est pas reconnue par Mac OS.
USB ok, j'ai pas encore tester le Firewire mais il aussi reconnue.
Pour ce qui est du son, je n'ai pas encore tout tester, mais il semble qu'il est préférable de le changer avec le driver ALC262.
Le mode Sleep ne fonctionne pas en attendant je vous suggère de le couper.

Enfin il manquait le clavier dont les touches ne correspondent pas toujours. La solution est de prendre le driver de la Logitech diNovo Keyboard Mac® Edition

http://www.logitech....c261_dinovo.zip

Seules les touches > et < sont positionnées sur la touches ²

Mais après c'est parfait.


Voilà...

Update 10.5.5 avec le combo update 10.5.5 de Apple.

1) télécharger le combo update apple 10.5.5
2) récupérer les drivers GMAX3100 fonctionnant avec la 10.5.5
3) ouvrir un terminal
4) taper ces lignes
sudo su -
while sleep 1 ; do rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext ; done


Laisser de coté le terminal. La boucle a pour objectif de supprimer AppleIntelCPUPowerManagement.kext à sa mise en place par le combo update 10.5.5.

5) Lancer l'installation du combo update en double-cliquant dessus

A la fin de l'installation ne pas rebooter

6) Dans le terminal, ctrl+C pour arrêter votre boucle.
7) ouvrir /System/InstallAtStartup/scripts/1
8) Remplacer dans le fichier Don't Steal Mac OS X.kext par dsmos.kext

Il faut de nouveau supprimer le pilote de la carte graphique Intel GMAX3100 dans /Volumes/OSX(nom de votre partition Leopard)/System/Library/Extentions/

Rebooter

et voilà Leopard en 10.5.5.
Il vous suffit d'installer le nouveaux pilote de la carte graphique Intel GMAX3100 avec la même méthode décrite plus haut.


A+Opodeu

#2
cparm

cparm

    InsanelyMac Legend

  • Retired
  • 997 posts
  • Gender:Male
au lieu de demarrer en mode 800x600 a tu essayé d'éditer le fichier com.apple.boot.plist pour l'obligé a démarrer dans la résolution que tu desire ?

et je n'ai pas tres bien compris pour les drivers GMAX3100, tu les déplace immédiatement après l'installe, ensuite tu re-injecte les mêmes, est-ce que c'est parce qu'il ne fonctionne pas lors du premier démarrage ?

#3
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
En fait les drivers proposer par Kalyway fonctionnent, mais pour créer son compte il faut les supprimer. J'obtiens, quoiqu'il arrive, un ecran noir même le mode "sans echec" -x. En outre l'extention du bureau vers le second ecran ne fonctionne pas avec -x.
Une fois que j'ai créé mon compte... je replace ces drivers.

Non je n'ai pas essayé d'éditer com.apple.boot.plist... Mais pourquoi pas... Il permettrait peut-etre de demarrer directement avec 1024x800@60hz avec le driver... A essayer...

#4
cparm

cparm

    InsanelyMac Legend

  • Retired
  • 997 posts
  • Gender:Male
je me permet de deplacer ton post dans la partie TUTO, car je pense qu'il peut aider les personnes aillant la même machine que toi :)

#5
monix

monix

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Female
  • Location:Italy
Tres Bien :thumbsup_anim:

chez moi sur mon vaio vgn-nr11s, j'ai éditer le fichier com.apple.boot.plist mais ça n'a pas fonctionné et le systeme n'a pas démarrée avec ces lignes écrite dans le fichier de configuration du darwin bootloader...
(excusez mon petit francais)



kiss...





as asked your post is corrected, but the next time try to use a good translator, kiss kiss :D

#6
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
J'oublie , un grand merci à Monix qui m'a aidé à installer le VAIO et notamment la carte Graphique sur lequel j'ai ramé un bon moment... :) ;)

Pour la wifi je me demande si je ne devrai pas acheter cette petite clés USB tout simplement.

http://www.rue-montg...II-Wifi-Dongle/

Dans la liste des composants 10.5.2 il semblerait qu'elle fonctionne parfaitement (il y a egalement qu'un post en allemand)

#7
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
Bon finalement,

J'ai acheté une clés USB D-LINK DWA-110 elle fonctionne parfaitement avec OSX mais il ne faut pas prendre le driver du CD, mais le dernier qui est disponible :

http://www.ralinktec..._2007_11_26.dmg

avec http://www.rakis.net/~prasys/ralinkv015.zip

L'ensemble fonctionne parfaitement a chaque reboot contrairement au driver d'origine.

#8
anakyl

anakyl

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Bonjour à tous,

Moi je dispose d'un Sony Vaio VGN-NR21 E/S.

J'ai testé toutes les versions mac OS X 10.5.5 (en dual boot Vista/Mac) mais à chaque fois au reboot après l'installation, mon PC se retrouvait bloqué avec un écran bleu et pas moyen d'aller plus loin. Gros plantage quoi...

Je viens maintenant de tester avec la version 10.5.2 de Kalyway, cette fois-ci il y a un autre problème :

- Au reboot après l'installation, je me retrouve avec un écran tout noir sachant que le PC n'est pas planté : j'entends la présentation en anglais mais je ne peux pas faire grand chose puisque je ne vois rien... Je pense que la carte graphique a été désactivée.

Mais je ne comprends rien au tuto ci-dessus : je ne sais pas ou je dois aller pour taper les lignes de commandes, etc...

Si quelqu'un a une idée, je suis preneur..

Merci

#9
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
Bonjour,


L'écran noir signifie que ta carte est bien reconnue, malheureusement tu peux rien faire dans l'immédiat avec.
Normalement tu dois pouvoir redemarrer OSX en mode sans échec, lorsque le bootloader Darwin démarre, tape F8 puis -x. C'est le mode sans échec. Pour ma part ça ne marche pas suite à l'installation.

Sinon commence par suivre les instructions ci-dessous.

1) Insérer le disque Kalyway DVD 10.5.2
2) Ouvrir l'application Diskutility
3) Formater la partition où tu veux qu'OSX soit installée
4) Fermer Diskutility
5) Installation d'OSX
6) Sélectionner la partition OSX pour l'installation

- Les options :
Kernel speedstepkernel
Carte graphique Intel X3100
Audio Intel NVIDIA VIA ATI HDAudioController
Pas d'option Ethernet ni Wifi
Mobo_Chipsets, Thirds_Applications et Patches je coche tout on se sais jamais
SSE2 et AMD ne sont pas cochés
Attention parmi les applications à avoir Third_Application il faut le kextHelperB7 pour aisément installer les drivers.

7) ATTENTION : lorsque le programme d'installation vous demande de redémarrer, il y a un decompte de 60 secondes, il faut ouvrir rapidement le terminal (celui-ci se trouve parmi les applications comme Diskutility), ceci bloquera le décompte de redémarrage.

L'objectif est de supprimer le driver de la carte graphique Intel GMAX3100
taper :
cd /Volumes/OSX(nom de votre partition Leopard)/System/Library/Extentions
mkdir SAUVE
cp -r *GMA* SAUVE/

rm -rf *GMA*
diskutil repairPermissions /Volumes/OSX


Reboot

Normalement OSX démarre sans reconnaitre ta carte graphique, elle considère que tu as une carte générique sans QE/CI avec une résolution de 1024x768

Commence par ces étapes.

Pour la suite relis mon tuto : carte graphique, wifi, son et clavier
Courage...

#10
da23ad

da23ad

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Que me conseillez vous d'installer pour un VAIO VGN-TX5VN:
-Proc Intel Core Solo CPU U1500 1.33Ghz
-Intel Corporation Mobile 945GM/GMS - 943/940GML
-Realtek High Definition Audio
-Intel Corporation PRO/100VM Network Connection
-Intel Corporation PRO/Wireless 3945abg

???

J'ai testé iatkos v1.0i r3 .... mais pas d'internet, ni de wifi ... et résolution VESA .... :(

#11
anakyl

anakyl

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Bonjour a tous,

Opodeu c'est toi le meilleur !!
J'ai suivi tous tes conseils et ça a parfaitement fonctionné.
Javais tellement galeré que j'y croyais même plus.

Juste pour info pour qui seraient ammené a faire la même manip : lorsque j'ai tapé les lignes de commande sûr terminal, ca n'a pas fonctionné en inscrivant le mot "Extention". Je l'ai remplacé par "Extensions" et sa a marché.

Merci infiniment Opodeu !

J'aurai juste une dernière question ? Mac OS ne s'affiche pas sur l'intégralité de l'écran. C'est comme dans un encadré.
Est il possible le l'afficher sur la totalité de l'écran ?

Merci et bonnes fêtes a tous

#12
anakyl

anakyl

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Bonjour à tous,

Heu... Désolé pour la question sur l'écran.. j'étais pas allé jusqu'au bout du Tuto de Opodeu sur la config de l'écran...

Tuto suivi.. Problème résolu... Encore merci Opodeu...

Par contre, j'ai un réel problème.. Mes ports USB ne sont pas reconnus... J'ai une clé USB Wifi D-Link DWA-110, mais il m'est impossible de la faire fonctionner puisqu'elle n'est pas reconnu..

J'ai testé tous les ports avec plusieurs clés USB, et rien n'est reconnu...

Quelqu'un aurait-il une solution ??

#13
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris

Par contre, j'ai un réel problème.. Mes ports USB ne sont pas reconnus... J'ai une clé USB Wifi D-Link DWA-110, mais il m'est impossible de la faire fonctionner puisqu'elle n'est pas reconnu..


Joyeux noël à tous,

Pour ce qui est des clés USB, il est claire que ça ne marche pas toujours super bien...
Un test à faire : insérer une clés USB de stockage 1Go par exemple et redémarrer Normalement tu devrais le voir.

Sinon vérifie dans Application/utilitaire/Information system (ou system profil) dans le menu latéral USB si ta clés semble connectée...

Sinon pour la clés USB wifi DWA-110 il faut :

1) installer les deux pilotes

http://www.ralinktec..._2007_11_26.dmg

avec http://www.rakis.net.../ralinkv015.zip

2) Redémarrer avec la clés USB insérée

Normalement la LED orange se met à se moment à clignoter.
Il ne te reste plus qu'à configurer ton point accès.

Bonne chance.




Que me conseillez vous d'installer pour un VAIO VGN-TX5VN:
-Proc Intel Core Solo CPU U1500 1.33Ghz
-Intel Corporation Mobile 945GM/GMS - 943/940GML
-Realtek High Definition Audio
-Intel Corporation PRO/100VM Network Connection
-Intel Corporation PRO/Wireless 3945abg

???

J'ai testé iatkos v1.0i r3 .... mais pas d'internet, ni de wifi ... et résolution VESA .... :wacko:


Bonjour,

Ton portable est un peu éloigné du mien... mais bon..
Sony

Télécharge plutôt Kalyway 10.5.2

carte graphique : Intel GMA950 tu devrais un peu chercher sur ce site.
Ethernet : Tu peux essayer le pilote AppleYukon c'est celui que j'utilise sur mon VAIO
Audio : ALC262 avec AppleHDA ça doit fonctionner
Wifi : 3945abg je ne suis pas sure que ça fonctionne. A vérifier sur le site.

Mais je te suggère de procéder comme sur mon tuto pour commencer... Et après rectifier le tire pour chacun de tes composants...

#14
da23ad

da23ad

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Bonjour,

Ton portable est un peu éloigné du mien... mais bon..
Sony

Télécharge plutôt Kalyway 10.5.2

carte graphique : Intel GMA950 tu devrais un peu chercher sur ce site.
Ethernet : Tu peux essayer le pilote AppleYukon c'est celui que j'utilise sur mon VAIO
Audio : ALC262 avec AppleHDA ça doit fonctionner
Wifi : 3945abg je ne suis pas sure que ça fonctionne. A vérifier sur le site.

Mais je te suggère de procéder comme sur mon tuto pour commencer... Et après rectifier le tire pour chacun de tes composants...


Alors... j'ai installé kalyway 10.5.2 que j'avais déja sous la main ... j'ai suivi ton tutoriel sauf que j'ai mis le driver GMA950 aulieu de X3100 .... je les ai supprimé puis remis comme tu l'a fait ..... j'ai pluggé mon écran 22" et ai modifié la résolution .... avec switchresx j'ai pu crééer la resulution qui va bien sur mon écran ....
A ce niveau là c'est un grand succès car j'ai enfin un affichage en 16/10 sur mon écran vaio .... MERCI ! :D

Pour le son j'ai mis ALC262_AppleHDA___Code_Dump et ça marche au casque , pas les hauts parleurs intégrés.


La suite est moins bonne .... j'ai lancé l'application KextHelperB7 (avec laquelle j'avais remis les drivers GMA950) et ai installé le driver yucon localisé dans /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIn/AppleYucon2.kext

J'ai installé AppleIntel8255x.kext et c'est un peu mieux .... l'interface ethernet est visible .... Mais elle est en Etat Inconnu (Ethernet:Aucune adresse IP). Il semblerait qu'elle ne récupère pas d'IP distribué par mon routeur wifi (branché en directe sur une interface du routeur donc ip privé en 192.168) et idem si je la connecte directement à ma Freebox (adresse publique en 88. ) :(

Par contre l'ethernet fonctionne très bien en safe mode ( boot flag -x) .... ;)

#15
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
Salut,

Si le driver est reconnu, alors essaye ça :
cliquer sur Préférences Systeme sur le dock
cliquer ensuite sur Réseau
Sélectionnes Adaptateur Ethernet
Choisir configurer Via DHCP
Cliquer sur Avancé...
Tu dois avoir Configurer IPv4 : Via DHCP et IPv6 : Automatiquement
Cliquer sur Renouveler le bail DHCP

Croisons les doigts...

Attached Files



#16
Vinsouille

Vinsouille

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
Bonjour.

Se que je trouve dommage dans ton tuto, c'est le faite que la carte wifi intégré ne fonctionne pas :'(
Y'a t'il une solution autre que acheter une clé wifi qui fonctionne ?

#17
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
Bonjour,

il semblerait que la carte AR5007EG fonctionne en updatant vers la 10.5.5...
J'ai presque réussi à la faire fonctionner :( ... Je cherche encore...

#18
Vinsouille

Vinsouille

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
Question bête mais la carte wifi du VGN NR10E est la même que le VAIO VGN NS12M ?




#19
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
Good news et bad news

j'ai réussi à faire fonctionner la Wifi. mais une fois rebooter, ça ne marche plus... :unsure:
Va falloir chercher dans tes docs ou sur google, car sur le site sony il ne l'indique pas le composant audio du VGN-NS12M

#20
opodeu

opodeu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 317 posts
  • Location:Paris
Pour faire refonctionner la wifi, il faut supprimer Extensions.mkext, réparer le disque, et rebooter.
Pour l'instant c'est le seul moyen connu en attendant un driver plus efficace.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy