Jump to content

{TUTO} EFI Boot Partition (nouvelle methode Retail)


  • Please log in to reply
111 replies to this topic

#61
promethee54

promethee54

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
Félicitations pour toi si tout marche
Pour ma part j'ai aussi une G33 et ce soir je viens de reformater et reinstaller proprement OSX V.0 et j'ai tout de suite Fait une MAJ vers V.5, depuis plus possible de booter meme avec le 132 ....
Je desespère .....

#62
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
tu as essayé de booter en mode "-x" ?

pour boot 132 tu utilise quoi ?
moi j'ai pris l'iso pour p35 ds4

ensuite, j'ai pris les kext pour ichx (voir le tuto de PM!)
de là je pouvais booter mais j'avais mon erreur de résolution de DNS
j'ai donc rebooter en "-x" et j'ai modifié mon paquet de kext, maintenant tout fonctionne :censored2:


voici le paquet de kext pour Gigabyte GA G33m DS2R:
http://www.mediafire.com/?nmjmzmgermj

il te faudra patcher le son avec un dump (voir tuto PM!)
et rajouter les strings pour ta carte graphique via osx86 tools

et là tout devrait vraiment fonctionner :censored2:

pour pousser le vice de la perfection, rajoute ça à la fin de ton fichier boot.plist
<key>Graphics Mode</key>
    <string>1680x1050x32</string>
<key>Timeout</key>
<string>5</string>

(pense à changer la résolution si nécessaire !)
ça te fera booter automatiquement, et tu auras la taille de la pomme grise à la bonne résolution :)

#63
promethee54

promethee54

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
Toujourspas :

Package 0 didn't get HTEP (je crois)

#64
alexcooltranquille

alexcooltranquille

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,412 posts
  • Gender:Male
  • Location:Nancy, France
HS

Y 'a plus qu'à mettre un autocollant EFI-X sur une clé USB et c'est parti

Perso j'ai pas réussi à le mettre sur une clé usb selon la méthode sous windows :thumbsup_anim:

#65
haroldc

haroldc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
  • Location:paris
Oui c'est galère cette histoire.
J'y suis arrivé mais c'est fastidieux. (je garde bien précieusement ma clé maintenant...)
D'ailleurs, y'aurait pas moyen de compiler ou d'exécuter syslinux sous X11 ou le terminal ? (j'ai essayé mais sans succès.)
Y'a un dossier unix dans l'archive mais en dehors de ./configure / make /install, je suis assez mauvais.

#66
pipolas

pipolas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts

Il te faudra toujours réinstaller le bootloader après une restauration. Time machine est bien, mais tu peux aussi utiliser Carbon Copy Cloner.
Dans un premier temps tu dois isoler les kexts dont tu as besoin, notamment graphique, son et réseau. Pour le reste j'ai ce qu'il faut, je pourrais te filer un coup de main (mais sur un autre topic, ouvres en un pour l'occasion), ça pourrait servir de méthode à d'autres. Fait une archive avec les injecteurs son, réseau et audio (et kernel si tu en utilise un non-vanilla) en précisant les modèles. Je t'expliquerais comment faire ton ISO de boot et préparer l'installation du bootloader avec les kexts/kernel.


Bon, je suis passé acheter le dvd de léopard, donc je suis pret à me lancer dans l'affaire.
Je vais ouvrir un nouveau topic.

Bonne soirée

#67
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels
Si vous pouvez poster vos dossier Extentions avec la référence de carte mère je peux les regrouper dans le topic.
J'en ai fait un pour la P5K.
@+

PM!

#68
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
en voici un fonctionnel pour la GA G33m DS2R
http://www.mediafire.com/?nmjmzmgermj

il fonctionne parfaitement, même si je préfère le qualifier de "beta", car pour le moment, le about me ne détecte pas le type de carte mère
ce 'n'est qu'un détail, mais je préfère le signaler :D

#69
Eromejir

Eromejir

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:liege
Voila j'aimerai avoir un dualboot sur un et unique disque dur (500Go):
- partition n°1: Windows Vista Ultimate (32bit) (=> 100Go)
- partition n°2: Mac OS X Léopard retail (grace a cette méthode) (=> 300Go)
- partition n°3: partition de sauvegarde de logiciel et jeux (accecible pour les 2 OS) (=> 100Go)

J'ai essayé de partionner mon disque dur avec l'aide de l'utilitaire de disque du mac: => j'installe mac ensuite vista (problème: apres l'installation du boot de cette méthode, je n'arrive pas a installer vista sur la partion n°1) et vise versa quand je le fai via Windows Vista...

#70
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
il te faudra un disque dur avec une table MBR et non GUID (sinon pas de boot pour vista), du coup tu peux laisser tomber la méthode 132, qui se met dans la partition caché d'une table GUID

à moins de créer la partition manuellement et lui assigner le secteur de boot, car après tout les deux sont en HFS+
ça peut valoir le coup d'essayer :)

dommage que je n'aime pas windows, j'aurais pu essayer ^^(je n'ai que mac os x, en ce qui me concerne :P )

#71
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels

Voila j'aimerai avoir un dualboot sur un et unique disque dur (500Go):
- partition n°1: Windows Vista Ultimate (32bit) (=> 100Go)
- partition n°2: Mac OS X Léopard retail (grace a cette méthode) (=> 300Go)
- partition n°3: partition de sauvegarde de logiciel et jeux (accecible pour les 2 OS) (=> 100Go)

J'ai essayé de partionner mon disque dur avec l'aide de l'utilitaire de disque du mac: => j'installe mac ensuite vista (problème: apres l'installation du boot de cette méthode, je n'arrive pas a installer vista sur la partion n°1) et vise versa quand je le fai via Windows Vista...

Tu peux uploader ton dossier Extensions pour ta Asus ? Et citer quel iso de boot132 tu as employé ? Merci d'avance,

Sinon pour ton problème je pense à Grub, mais le problème c'est que ce dernier s'installe dans la MBR et je ne sais pas s'il supporte les tables GUID... Bref, je ne peux pas vraiment t'aider, faudrait tester...
PM!

il te faudra un disque dur avec une table MBR et non GUID (sinon pas de boot pour vista), du coup tu peux laisser tomber la méthode 132, qui se met dans la partition caché d'une table GUID

à moins de créer la partition manuellement et lui assigner le secteur de boot, car après tout les deux sont en HFS+
ça peut valoir le coup d'essayer :P

dommage que je n'aime pas windows, j'aurais pu essayer ^^(je n'ai que mac os x, en ce qui me concerne :P )


On est sur la même longueure d'onde :) Dis moi t'as reçu ma requête concernant ton dossier Extensions dans l'autre topic ?
EDIT : OK merci !

#72
Eromejir

Eromejir

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:liege

Tu peux uploader ton dossier Extensions pour ta Asus ? Et citer quel iso de boot132 tu as employé ? Merci d'avance,

Sinon pour ton problème je pense à Grub, mais le problème c'est que ce dernier s'installe dans la MBR et je ne sais pas s'il supporte les tables GUID... Bref, je ne peux pas vraiment t'aider, faudrait tester...
PM!


J'utilise les .kext du cd iso boot132 générique (voir le topic de sonotone au sujet du boot 132)
==> 2 problèmes:
1er: pas de reconnaissance du port lan (toujours pas de solution!)
2eme: pas de reconnaissance du son (j'ai suivi cette méthode: http://forum.insanel...howtopic=107942) mais n'ai pas reconnu le récapitulation a propos de ce Mac ("pas de carte audio intégrée")

Sinon tout le reste est correctement reconnu!!!

Merci quand même!

#73
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels
Pour le son il faut que tu utilises le AppleHDAEnabler + HDA patcher avec le bon dump. Ce ne sera donc pas du full retail mais c'est mieux que pas de son.
Comme je suis sympa je te file le tout déjà patché :( tu n'as plus qu'à te servir de kexthelper :D
(en espérant que ce soit bien du ALC662)

Attached Files



#74
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
tiens j'ai un petit soucis :(

lorsque j'ai finis mon installe tout fonctionnait super bien, à savoir shutdown et sleep
sauf que là ils fonctionne à moitier :(
ils éteindront pas complètement la machine contrairement à avant !

même si je connais la réponse, quelqu'un a quand même une idée ? :D

#75
Cyberdog !

Cyberdog !

    InsanelyMac Sage

  • Donators
  • 280 posts
  • Gender:Male
  • Location:France, Lorraine, Pont-a-Mousson
Pour rester en full retail, on devrait pouvoir gérer le son comme cela dans CE TOPIC
Pas essayé !

#76
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
PM! et moi avons essayé: mais ne fonctionne pas :D

#77
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels

PM! et moi avons essayé: mais ne fonctionne pas ;)


Inexact, ce n'est pas que ça ne fonctionne pas, c'est que ça fonctionne moins bien. On perd la sortie de ligne qui est très utile pour garder ses conversation téléphoniques (skype) à l'abris des haut-parleurs :P et des oreilles de toute la zonmé (t'as vu).

Mais bien tenté ;)

#78
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts

Inexact, ce n'est pas que ça ne fonctionne pas, c'est que ça fonctionne moins bien. On perd la sortie de ligne qui est très utile pour garder ses conversation téléphoniques (skype) à l'abris des haut-parleurs ;) et des oreilles de toute la zonmé (t'as vu).

Mais bien tenté :P



Mais le sortie ligne fonctionne maintenant avec les nouvelles versions.
m'enfin.

#79
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels

Mais le sortie ligne fonctionne maintenant avec les nouvelles versions.
m'enfin.

J'allais modifier mon post pour dire que je n'avais pas testé les nouvelles versions. Ca sera fait cet aprèm sur une GA-EP35-DS3R <_< Je te dirais quoi, comme on dit par chez moi.

#80
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)

tiens j'ai un petit soucis :wacko:

lorsque j'ai finis mon installe tout fonctionnait super bien, à savoir shutdown et sleep
sauf que là ils fonctionne à moitier -_-
ils éteindront pas complètement la machine contrairement à avant !

même si je connais la réponse, quelqu'un a quand même une idée ? :blink:


en manque d'idée là, si quelqu'un a déjà rencontrer ce soucis :unsure:





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy