Jump to content

Asus G2P Lappy


  • Please log in to reply
143 replies to this topic

#21
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Never tested Voice Over ...
The thing with the resizing partition: the partition scheme has to be GUID, the resize thing you do it from Disk Utility. Does not resizes NTFS partition, only HFS or HFSJ.
To make a partition active from mac you have the Terminal instructions here or simply use OSx86 Tools Remember that the latest version of OSx86 Tools have another interface that does not alow to select the EFI partition. Use this version if you like just hope that PCWiz, THE COPYRIGHT OWNER will not be mad on me because i send you back to an older version of his product.
Cheers


hah =) I just forgot that now I'm using GUID... on my previous mac Disk Utility can't resize anything. Now it can. Thanks.
So... It seems that all problems solved, except wi-fi (which not nesessery at this moment) and shutdown (it's annoying, but not much)
;)

#22
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
hmmm... Don't think it will help much, but may be it'll be useful someway...
So, I left my G2P with unpluged AC power, so it went to the sleep. Sleeping is also dont work on hackintosh - display turns off, but rest of hardware continues working. Then I force powered off all of this and turned on again - and system bring self back after sleep! Display still was black, but system works - I hear sounds and etc. And it was waking-up, not reboot - for rebooting it spends much more time.
So... Maybe there are some problems with display integration in hackintosh? Because it seems that when it go to sleep it turn off display "forgetting" all other hardware, and when it wakes up - all goes well, but it "forgets" display.
It's just my thinking - I may not be right

#23
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania
More informations about sound:
Taruga made a grate job and i am so sorry about his health state. The patcher did a grate job and helped to get the sound working 90% of its values. (No internal Mic and no Bass)
This are the files used now: Attached File  AppleHDA.kext.zip   318.96KB   11 downloadsAttached File  HDAEnabler.kext.zip   8.84KB   6 downloads
Here is the linux dump using Ubuntu: Attached File  Ubuntu_882.txt   9.05KB   4 downloads
and following this how to of THe KiNG i successful obtained the Verbs and the connection graph
Attached File  HDA882_VistaVerbs_nojunk.txt   3.82KB   1 downloadsAttached File  Ubuntu_882.txt.svg.zip   22.23KB   1 downloads but is beyond my understandings how to move one.
Also i followed MadTux tutorial ...
I thanks to them that made me to understand better the sound problem. My fault i am not able to create the AppleHDAPlatformDriver Info.Plist and to move on.
If someone has more knowledges and can help ...
Also i'll send those wonderful guis a PM so that might take a look.

Greetings to al and thank you!

#24
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

More informations about sound:
Taruga made a grate job and i am so sorry about his health state. The patcher did a grate job and helped to get the sound working 90% of its values. (No internal Mic and no Bass)
This are the files used now: Attached File  AppleHDA.kext.zip   318.96KB   11 downloadsAttached File  HDAEnabler.kext.zip   8.84KB   6 downloads
Here is the linux dump using Ubuntu: Attached File  Ubuntu_882.txt   9.05KB   4 downloads
and following this how to of THe KiNG i successful obtained the Verbs and the connection graph
Attached File  HDA882_VistaVerbs_nojunk.txt   3.82KB   1 downloadsAttached File  Ubuntu_882.txt.svg.zip   22.23KB   1 downloads but is beyond my understandings how to move one.
Also i followed MadTux tutorial ...
I thanks to them that made me to understand better the sound problem. My fault i am not able to create the AppleHDAPlatformDriver Info.Plist and to move on.
If someone has more knowledges and can help ...
Also i'll send those wonderful guis a PM so that might take a look.

Greetings to al and thank you!


emmm... And what's new in this patches? I mean that old version works good, but no build-in mic and bottom speakers... So, what's new in this version?

#25
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania

emmm... And what's new in this patches? I mean that old version works good, but no build-in mic and bottom speakers... So, what's new in this version?

Nothing new ... just "more info about sound" for those that might give us some help getting a proper driver :)

#26
andersson paul

andersson paul

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
Righteye, I need your help for doing a dual boot Xp-Osx(ipc) on my G2p.

But i'dont know how...

Can you help me ?



Thanks

#27
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Righteye, I need your help for doing a dual boot Xp-Osx(ipc) on my G2p.

But i'dont know how...

Can you help me ?
Thanks


I'm not Righteye, but try to help =)
You can do it in 3 steps:
1) using install DVD of iPC format your HDD. Create partition for Mac and for xp (using DiskUtility from tools menu).
2) Install xp
3) Install Mac (make sure that any bootloader, for example Chameleon choosen).

If you already have installed xp and mac on different partitions - just install Chameleon on mac partition (only chameleon - not whole mac system).

#28
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania
That could help ... Is the best way to install and dual boot XP and OSX86.
Also you can follow the files posted in this topic with the patched files ... Will save allot of problems and time consuming.
Sorry but this days i was busy with the barbeque ... and spend some time finding more about sound on our Laptops, and guess what ?
:(
4 Speakers working
Internal Microphone working
There is a small bug ... but that doesn't bother me
In the System Profiler comes just:
Intel High Definition Audio:

Device ID: 0x104313C4
Audio ID: 12
Available Devices:
Microphone:
Connection: Internal
Microphone:
Connection: 1/8 inch Jack
Speaker:
Connection: Internal
Speaker:
Connection: Internal
Headphone:
Connection: 1/8 inch Jack

and in the System Preferences:
Output
Internal Speaker
Internal Speaker
Headphone
Input
Internal Microphone (this is junk)
Internal Microphone (this works great internal or external)
Line In (this does not come up in the System Profiler)

I'll not explain what i did cause is like tons of readings but i'll make the story short:
I re-patched the AppleHDA and edited. This is the result Attached File  AppleHDA.kext.zip   353.7KB   26 downloads
To play with Quadrophonic simulation used this information
It is Taruga based driver and THe KiNG - MadTux understandings.
If you like and have some time try to "develop" more about this sound card ... The guis mentioned above have to much work to do and looks like there is no time to reply on my PMS, but they did a grate job on the forum and shared allot of informations there so I THANKS THEM ALLOT :P

If you need more informations or help ... post here and i'll try to do my best!

Cheers

#29
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

That could help ... Is the best way to install and dual boot XP and OSX86.
Also you can follow the files posted in this topic with the patched files ... Will save allot of problems and time consuming.
Sorry but this days i was busy with the barbeque ... and spend some time finding more about sound on our Laptops, and guess what ?
:guitar:
4 Speakers working
Internal Microphone working
There is a small bug ... but that doesn't bother me
In the System Profiler comes just:
Intel High Definition Audio:

Device ID: 0x104313C4
Audio ID: 12
Available Devices:
Microphone:
Connection: Internal
Microphone:
Connection: 1/8 inch Jack
Speaker:
Connection: Internal
Speaker:
Connection: Internal
Headphone:
Connection: 1/8 inch Jack

and in the System Preferences:
Output
Internal Speaker
Internal Speaker
Headphone
Input
Internal Microphone (this is junk)
Internal Microphone (this works great internal or external)
Line In (this does not come up in the System Profiler)

I'll not explain what i did cause is like tons of readings but i'll make the story short:
I re-patched the AppleHDA and edited. This is the result Attached File  AppleHDA.kext.zip   353.7KB   26 downloads
To play with Quadrophonic simulation used this information
It is Taruga based driver and THe KiNG - MadTux understandings.
If you like and have some time try to "develop" more about this sound card ... The guis mentioned above have to much work to do and looks like there is no time to reply on my PMS, but they did a grate job on the forum and shared allot of informations there so I THANKS THEM ALLOT :rolleyes:

If you need more informations or help ... post here and i'll try to do my best!

Cheers


Tried this - it's really works =)
but it's like joke - there is bottom pair working or top, but not both of them ))
However, bottom speakers much louder - so now watching movies more comfort.
And another thing - it seems that there is now no external mic support, or I just didnt find it...
So - it' really helpful patch - now when you're without external speakers you can watch movies with normal loud.
Thanks!

#30
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania

Tried this - it's really works =)
but it's like joke - there is bottom pair working or top, but not both of them ))
However, bottom speakers much louder - so now watching movies more comfort.
And another thing - it seems that there is now no external mic support, or I just didnt find it...
So - it' really helpful patch - now when you're without external speakers you can watch movies with normal loud.
Thanks!

The external mic works just plug in one ... Are working bout on same time ... I'll try to fix more about this sound but i need more time. Its more complicated that i thought :rolleyes:

#31
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

The external mic works just plug in one ... Are working bout on same time ... I'll try to fix more about this sound but i need more time. Its more complicated that i thought :censored2:


Main work already done - we have loud bottom speakers... For me it's the main thing =)
two mics working same time - it's funny )
Lucky you! and best wishes )

#32
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
what about 10.5.7? Righteye, did you try to update from retail mac?

#33
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania

what about 10.5.7? Righteye, did you try to update from retail mac?

same procedure as before ... have to do more tests with the audio
i posted already the patched files for video on here Also there is a new kext that has to be removed from Extensions folder: AppleTyMCEDriver.kext
Works also with it but you get a warning like MacBook Pro 4.1 test failed but boots fine ... No solution for Shutdown/Poweroff problem ... I'll come later with more info.

#34
andersson paul

andersson paul

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
Righteye are you ready for snow leopard ?? Joke...

#35
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania

Righteye are you ready for snow leopard ?? Joke...

To install it just follow this
The thing is that now the drivers for Ati are written in different way. No more ATINDRV. The ATiX1x00Controller, ATiSupport and ATiFramebuffer are following the ATiX1000Radeon.kext presence. As soon the Snow is released as a final ... someone will point us in the right direction.
As a personal statement: it is running smoother and quicker than 10.5.x (but for now no res change at al)

Cheers

#36
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

To install it just follow this
The thing is that now the drivers for Ati are written in different way. No more ATINDRV. The ATiX1x00Controller, ATiSupport and ATiFramebuffer are following the ATiX1000Radeon.kext presence. As soon the Snow is released as a final ... someone will point us in the right direction.
As a personal statement: it is running smoother and quicker than 10.5.x (but for now no res change at al)

Cheers


no res change - what do u mean?
It's always 1440*900 or something like 800*600?
If first than I think it worth to install - I dont need change resolution

#37
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania

no res change - what do u mean?
It's always 1440*900 or something like 800*600?
If first than I think it worth to install - I dont need change resolution

no res change is the default 1024*768 that canot be changed, and the only one that comes in display preferences.

#38
andersson paul

andersson paul

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
Wright, Snow leopard is not very important now .

#39
wiedzmin477

wiedzmin477

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
there is new Safari 4 for 10.5.7... So I decide to update...
Righteye, you already answered this question, but I didn't completely understand - should I install retail 10.5.7 as 10.5.6 (chameleon, extra folder, etc - everything again) or I can just update to 10.5.7 from standart Apple Update program? Now I have 10.5.6 retail.

#40
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania

there is new Safari 4 for 10.5.7... So I decide to update...
Righteye, you already answered this question, but I didn't completely understand - should I install retail 10.5.7 as 10.5.6 (chameleon, extra folder, etc - everything again) or I can just update to 10.5.7 from standart Apple Update program? Now I have 10.5.6 retail.

You can update using the apple update ... or downloading the update ... you can use the files from 10.5.6 retail patcher but in order to get the video working you have to use the ATi related files from 10.5.7 that i posted in a previous post ...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy