Jump to content

BCM5722D 2.3.6

File Information

  • Rate File: * * * * * 7 Votes
  • Submitted: May 24 2013 10:29 AM
  • Last Updated: Apr 25 2016 05:37 PM
  • File Size: 1.35MB
  • Views: 35544
  • Downloads: 9,126

Previous Versions

  • 18 Nov 2013 Download BCM5722D 2.3.5
  • 24 Jun 2013 Download BCM5722D 2.3.5
  • 13 Jun 2013 Download BCM5722D 2.3.4
  • 07 Jun 2013 Download BCM5722D 2.3.3
  • 28 May 2013 Download BCM5722D 2.3.2
  • 28 May 2013 Download BCM5722D 2.3.1
  • 24 May 2013 Download BCM5722D 2.3

Download BCM5722D 2.3.6



Screenshots
Ethernet Broadcom

This driver is for these devices with fix against stoping under an intense traffic
It work with Snow Leopard(x32,x34-thanks rals2007 for compilation), Lion(x64), and Mountain Lion(x64) and Mavericks(x64). Works in x32 and x64 mode as well.
The version 2.3.5 is only suitable for 64bit systems. If you need 32bit driver on lion. try the kext for Snow Leopard.
{ DEVICEID_BCM5722, "BCM5722 NetXtreme Server Gigabit Ethernet" },
{ DEVICEID_BCM5754, "BCM5754 NetXtreme Gigabit Ethernet" },
{ DEVICEID_BCM5754M, "BCM5754M NetXtreme Gigabit Ethernet" },
{ DEVICEID_BCM5755, "BCM5755 NetXtreme Gigabit Ethernet" },
{ DEVICEID_BCM5755M, "BCM5755M NetXtreme Gigabit Ethernet" },
{ DEVICEID_BCM5787, "BCM5787 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5787M, "BCM5787M NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5906, "BCM5906 NetLink (TM) Fast Ethernet" },
{ DEVICEID_BCM5906M, "BCM5906M NetLink (TM) Fast Ethernet" },
{ DEVICEID_BCM57788, "BCM57788 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5784, "BCM5784 NetLink Gigabit Ethernet" },
{ DEVICEID_BCM57785, "BCM57785 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM57781, "BCM57781 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM57780, "BCM57780 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5752, "BCM5752 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5761, "BCM5761 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5761E, "BCM5761E NetLink (TM) Gigabit Ethernet" },

#define DEVICEID_BCM5722				 0x165A
#define DEVICEID_BCM5754				 0x167A
#define DEVICEID_BCM5754M				 0x1672
#define DEVICEID_BCM5755				 0x167B
#define DEVICEID_BCM5755M				 0x1673
#define DEVICEID_BCM5787				 0x169B
#define DEVICEID_BCM5787M				 0x1693
#define DEVICEID_BCM5906				 0x1712
#define DEVICEID_BCM5906M				 0x1713
#define DEVICEID_BCM57788				 0x1691
#define DEVICEID_BCM5784				 0x1698
#define DEVICEID_BCM57785				 0x16b5
#define DEVICEID_BCM57781				 0x16b1
#define DEVICEID_BCM57780				 0x1692
#define DEVICEID_BCM5752				 0x1600
#define DEVICEID_BCM5761				 0x1681
#define DEVICEID_BCM5761E				 0x1680
If you find extra issues, please tell about it here
http://www.insanelym...river-3264-bit/
Cosmetic of DSDT and posible problems with "Built IN"
http://www.insanelym...00#entry1918594

What's New in Version 2.3.6 (See full changelog)

  • v2.0 problem with stoping during an intense traffic was solved
  • v2.1 Corrected four warnings. Now the code is clean.
  • v2.2 Added more devices. Now driver supports 13 devices
  • v2.3 fixed problem in Xcode that had impeded to compline it for x32 machines.
  • Added supporting for Snow_Leopard.
  • v2.3.1 added support of BCM5752
  • v2.3.2 added support of BCM5761
  • ver 2.3.3
  • Added support of BCM5761E
  • Improved resistance against cessation of driver
  • v2.3.4 big improvement. IOBasicOutputQueue outputPacket() synchronized to the work loop. Fix fails replaceOrCopyPacket() when it prepares the descriptor for reuse with the old buffer (mbuf). It's credit of Mieze
  • v2.3.5 solved reboot problem which had some users. Solved problem with unplugged cable where was incorrect status.
  • v2.3.6 Fixed the wakeup bug (I think). Only tested on a D630 and a Precison M4300 so far.




The Mavericks version works fine on a Dell Studio XPS 8100

Thx

Is working wonderful for the Ethernet on Acer Aspire 5741-3404  Yosemite 10.10.4   >>> Thanks

Mavericks version working on Lenovo Y460p with BCM57780  Yosemite 10.10 (Updating to 10.10.5 now).  Tried FakePCIID, but got the dreaded Cable Unplugged error.  This worked great the first time (remove FakePCIID kext first!)

 

Thanks!!!

Hi.

 

I corrected the wakeup bug when using 1000BaseT.

I tried to upload a new version but didn't work. It is considered as a new file : http://www.insanelym...e/549-bcm5722d/

It would be better to create a new version instead of this "new" submission. Can I do that ?

 

Regards,

Jief 

Hi Jief.

I add to this "topic" the ability (for you) to update new file...

 

Confirm it work.. pls

EDIT I upload your files here

 

ErmaC 

Hi ErmaC.

 

Small world !! :-)

 

I can see the button "Upload new version". So it does mean it works, doesn't it ? Thanks.

 

I think we should remove the files :

  BCM5722D_v2.3.5_SL_UB.zip
  Lion_BCM5722D.kext.zip
  MavericksBCM5722D.kext.zip
  ML_BCM5722D.kext.zip
  v2.3.5soursesBCM5722D.zip
because it's confusing and one can still download them from 2.3.5 version. It doesn't look like I can do that.
 
Regards.

39 user(s) are online (in the past 30 minutes)

10 members, 28 guests, 1 anonymous users


Glueeater, zx4357685, macos14, msa0011superior, remati, wishie, buyjoey, suete, titibmw, ntbinh

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy