Jump to content

Kalyway 10.5.1 boot problem


8 posts in this topic

Recommended Posts


I am trying to install a Kalyway Leo on a PC:

Gigabyte GA-P35-DS3R

Core 2 Quad Q6600

Biostar VR8603GT21 (nVidia GeForce 8600GT) PCIe

80GB Seagate Barr. sata

2GB DDR2 667@1200 PC5300

There is a WinXP present on a hard drive, so 16 gb was allocated for MAC OS and formated into fat32

Have booted into Kalyway bootCD, formated the fat32 partition to MAC Extended (not Journaled)

Installation was successful (thought some error messages appeared rapidly on the console just before the automatic reboot; had no time to look through them

After restarting, OS starts to boot, but stops at some point. Tried booting with -v -x -y; booting stopped at line

Extension: "com.apple.driver.iTunesPhoneDriver" has no explicit kernel dependency; using version 6.0

after some time a few more lines appear (destroying logs, getting new uuid) and thats all

In case of -v the booting goes a little further, to the point, when login window app starts, and then once again stops.


Could somebody please advise me of any possible solutions? Can this situation refer to driver mismatch: I have selected 2 versions of audio drivers in Customize section of Kalyway?

Thank you in advance

Link to comment
Share on other sites

Did you try installing without selecting any added sound/video drivers or kernels, just the default options ?


Also, try posting a picture/photo of the boot process, that'll give some more information as to why your system wont boot.

Link to comment
Share on other sites

mavvert, thank you. Tried it without any customization, only with bootloader installed to MBR, OS booted successfully, but no PS/2 keyboard support, no internet connection (cable connection, DHCP from Apple Extreme Base station). Haven't checked any other drivers, but suppose that no MB drivers are working, as well as video ones - only 1024x768 res. is accessible.

Also System profiler shows CPU as "Intel Core 2 Solo", but there are 4 CPU activity graphs in the Activity monitor...

Updated: Installation WITH Vanilla, but WITHOUT additional drivers don't boot also, stopping at this moment:


Link to comment
Share on other sites

Well, at least u got it to boot, even though some devices aren't working properly (yet) :(


Im not sure if its possible to use MBR partitions with a vanilla kernel.

I usually try to get my system to boot into osx, and then fix every non-working device one at a time.


Did you check your BIOS settings ?

This thread by karaakeha1 might help, some good screenshots in there.


IIRC some PS/2 stuff needs a special kext to work, search the forums for this.

The network controller on your board (Realtek RTL8111B) seems to be the same as the one on the DS3P, i attached the kext that is working for me.


Dont worry about the System Profiler info, it shows incorrect info quite often and it can be fixed by using different AppleSMBios.kext files.

Audio/Video can be fixed by using EFI strings, or ALCinject/NVinject kexts.


Check here for some info on enabling EFI strings.


Good luck!


Link to comment
Share on other sites

I had the same problem I'm using same motherboard Bios: F11, make sure you choose MBR during installation and not GUID which gives that restart issue, also choose different EFI, I can't remember which I chose since its been quite a while, but if your willing to reinstall again I would choose a the one u haven't tried yet.. Anyway if you have stability issues after installation (Crashes) Enable AHCI it'll fix it :P, only occurs if u have more then 2GB ram last I heard at least.. Anyway hope that helped a little, GL with it.

Link to comment
Share on other sites


  • Create New...