Jump to content

Atheros AR5005(G)


10 posts in this topic

Recommended Posts

Ok, got atheros 5005 MiniPCI working, also using 10.4.7 JaS.

edit: please note you have to have your wireless/airport device as en1, in my case my built in ethernet takes en0 so it works out fine. (make change in /library/systemconfiguration/networkinterfaces.plist)

  1. Download the official Intel 10.4.5 update from Apple (98MB) (http://www.apple.com/support/downloads/mac...45forintel.html)
  2. Backup your /System/Library/Extensions/IO80211Family.kext
  3. Extract the IO80211Family.kext from the 10.4.5 update (using pacifist?)
  4. open finder to /System/Library/Extensions
  5. drag the kext from 10.4.5 update into the /System/Library/Extensions folder
  6. enter passsword when prompted
  7. open the disk utility (/Application/Utilities/Disk Utility), then repair permissions on your Startup volume (may take a little while)
  8. open up terminal, and switch to root (enter sudo -s, enter your user password)

cd /System/Library/Extensions
  chmod -R 755 IO80211family.kext
  chown -R root:wheel IO80211family.kext

then list the contents

ls -l

make sure the IO80211Family line looks like this:

drwxr-xr-x   3 root  wheel  102 Feb  2  2006 IO80211Family.kext

check that the permissions propagated to subdirectories:

cd IO80211Family.kext/contents/plugins
  ls -l

should look like this:

total 0
  drwxr-xr-x   3 root  wheel  102 Feb  2  2006 AirPortAtheros5424.kext
  drwxr-xr-x   3 root  wheel  102 Feb  2  2006 AppleAirPortBrcm4311.kext

then test that the extensions works:

kextload AirPortAtheros5424.kext

should give a extension loaded successfully message


then you have to go to System Preferences>Network

a message should pop up telling you you have a new AirPort. from the Show: box, pick AirPort. you can set the options here, i suggest you check the Show airport status in menu bar, make sure you click apply now.


There you have it, fully working native Atheros card! :)




I have gotten to the part where there is a message telling me in the terminal that the IO80211family.kext has loaded successfully. Now when I go to the System Preferences>Network, there's no message telling me that I have a new AirPort. Anyone have this problem or can help me? Please!!

Link to comment
Share on other sites

I am currently using Atheros AR5006EG Wireless PCI Express Adapter (802.11b/g) Chipset. I'm using leo4allv2. Please help.

Well, it's manufacturer ID and device ID are 168c and 001c (from Google), which is already registered in Info.plist. Should work out of the box. Interesting.


TotalNoob, what's the name of the card? Abit Airpace?

Anyway, did you try change the interfaces (exchanging en0 and en1)? Or lower versions of AirportAtheros.kext?

Link to comment
Share on other sites

I can't seem to find the Atheros.kext. can you Link one to me please?

There's no Atheros.kext. It's AppleAtheros.kext.


I am trying to help you but your answers to my questions are not even answers. Please find the answer for the followings:

1. Kernel version and System version. (All4Leo is not the answer. For kernel version, open Terminal and type "uname -a" and post the result. For system version, open run About This Mac and post Mac OS X version.)

2. Manufacturer ID and Device ID. (The chipset is not the answer. For these two values which should be hexadecimal numbers, check Properties of the device under Windows or type "lspci" under Linux.)

3. Is your card Abit Airpace?

Link to comment
Share on other sites


  • Create New...