Jump to content

after bootcamp disaster, how to restore the MacOS to the previous state?


7 posts in this topic

Recommended Posts

hello everybody


I carefully read many threads that were similar to my problem, yet did not find a response. Here the details:


I have a MacBook Pro running the latest version of Leopard (bought in March 2008). On the hard disk I stored a lot of pictures that I don't want to loose (just in case you suggest reformat/erase and reinstall). My hard disk has 186 GB.

I used BootCamp to make a second partition for Windows: 171 GB for Mac OS and 15 GB for Windows XP. I startet then the Windows install from the BootCamp Assistant. The very familiar screens of the Windows installation followed, up to the point where Windows required me to choose a partition on which to install Windows. Contrary to my expectation of seeing exactly the 2 partitions I had previously made, the list just showed one partition of 131 GB which was shown as unformatted. I panicked because I understood that something went terribly wrong and I chose the F3 "Quit without installing" option.



After that I tried to reboot the computer without any CD in the CD drive and I got only a black screen with a cursor blinking in the left upper corner of the screen. When booting and holding the option tab down I get only an options - Windows- which brings me back to the blinking cursor screen.



I printed the Apple documentation for troubleshooting installations and I started the Disk utility from the MacOS installation disk. The recommandation was to go to First Aid and repair the volume. However, although my hard drive is shown, the logical volume is not shown in the First Aid tab, so that I cannot repair or check anything.


Definitely Boot Camp is the evil-doer. I think it messed up with my boot sector and that is why I do not see any partition now, I just see the physical disk (as in hardware list). I have the slight suspicion that my disk is in perfect state, except for the first sector that actually holds the key to how to read all the other sectors. Here the theory:


"The first sector is called the boot sector and contains the Master Boot Record (MBR). The MBR contains the information concerning the location of partitions on the drive and reading of the bootable operating system partition."


Would anyone happen to know a small command line utility that just repairs this sector? I wouldn't mind to have it restored to the initial status, that is with the OS X operating system and one big partition.



Please help me with an option which allows me to return to my previous installation of MacOS without loosing the data on the hard drive.


Thanks a lot.

Link to comment
Share on other sites

Ok I think I understand your problem. Ok to me it sounds like somehow during bootcamp setup your OS X partition got marked as not active. So lets get that solved. Ok so get into a terminal and type "sudo fdisk -e /dev/rdisk0" (no quotes) where disk 0 is the drive OS X/Windows are on. Now type "flag 1" where 1 is the partition OS X is on. Now type "write" then "update". Now type "quit" then "reboot". if this solves your problem then just reply back and if it doesnt then reply and tell me it didnt, because I have more solutions that may help you.

Link to comment
Share on other sites

thank you very much, this is exactly the kind of answer I was hoping for!


I have a bash_3.2 shell, and I get a "command not found" for sudo. When I do a find / -name "sudo" -print, I get no results.


However, find / -name "fdisk" -print gives me /usr/sbin/fdisk.


What shall I do next? do I have to execute sudo fdisk, or is it possible to do fdisk without sudo?

Link to comment
Share on other sites



I googled the sudo problem a bit and found out it's ok to do fdisk without it. So I followed your instructions to the letter and hurray! I got rid of the Windows options when I reboot. When I executed print under fdisk, I saw my big partition of 186 GB as disk0, but strangely enough it was labelled as DOS FAT 32 partition. When I reboot now I get a grey screen and I can move my mouse over the screen, but otherwise there is not much action. Wait! now there is some action! I see a blinking folder icon in the middle of the screen with a big question mark on it. I think it wonders what it should do know, as it finds no OS.


please help me with the other aces in your sleeve :-)

Link to comment
Share on other sites

a little bit more detailed:


Disk Utility is of no use, just shows me Partition Map Scheme unformatted, which means I can use nothing there (Repair Disk etc).


On a terminal, fdisk shows the MBR on disk0: one partition of type 04 (DOS FAT-16) starting at sector 1 with a size of 268435455 bits, which means 32 GB.


My question is: can I restore my sytem to what it was before (that is without losing data) by just manipulating the MBR table to show

-a partition 1 of type ab (Bootable Mac OS X)

- a partition 2 of type af (Normal HFS+ partition)


Does anyone have the exact numbers for the first and second partition? Maybe a screenshot of the fdisk print for a sane Mac OS installation?


I'd be very grateful for an answer!

Link to comment
Share on other sites

  • 9 months later...

  • Create New...