Jump to content

My Acer Extensa Laptop Install


13 posts in this topic

Recommended Posts

Just got my install of leo4all V.2 installed on my Acer Extensa 4420-5237! Only real issues I'am having is getting AUDIO to work. Any help in that regard would be appreciated.


Acer Extensa 4420-5237:


-Processor / Speed AMD Athlon 64 X2 dual-core mobile technologyTK-53/TK-55 (2 x 256 KB L2 cache, 1.7/1.8 GHz, 1600 MHz HyperTransport bus)


-Core Logic Chipset-ATI M690G chipset-RAM / Max RAMUp to 2 GB of DDR2 667 MHz memory, upgradeable to 4 GB using two soDIMM modules (dual-channel support)


-Video SubsystemATI Radeon X1250 with up to 896 MB of HyperMemory (256 MB of dedicated system memory, up to 640 MB of shared system memory), supporting Microsoft DirectX 9, PCI Express


-LCD Properties14.1" WXGA TFT LCD, 1280 x 800 pixel resolution


-Hard Disk Drive160GB Hard Disk Drive


-Optical Drive8X DVD-Super Multi double-layer or DVD/CD-RW Combo drive-Battery, Primary44 W 4000 mAh 6-cell Lithium Ion battery pack:3-hour battery life, 2.5-hour rapid charge system-off,3.5-hour charge-in-use


-Sound SubsystemTwo built-in Acer 3DSonic stereo speakersHigh-definition audio supportBuilt-in microphone, MS-Sound compatible


-PC Card Support -1Type II PCCard slot-Pointing DeviceTouchpad


-Peripheral Subsystem4 USB 2.0 ports, 1 IEEE 1394 port, 1 Fast infrared (FIR) port,1 External display (VGA) port, 1 S-video/TV-out (NTSC/PAL) portHeadphones/speaker/line-out jack Microphone jack, Line-in jack5-in-1 card reader (SD, MMC, MS, MS PRO, xD)


-Modem56K ITU V.92 PPT approved, Wake-on-Ring ready


-EthernetGigabit Ethernet, supporting ASF (Alert Standard Format) 2.0, Wake-on-LAN readyAcer InviLink 802.11b/g Wi-Fi Certified solution, supporting Acer SignalUp wireless technologyBluetooth 2.0+EDR Enhanced Data Rate (selected models)


-Operating Systems

Windows XP Home

Windows Vista Home Premium

Apple Leopard 10.5.2 (External HD)


Ok, just a couple of other thing that I notice dont work 100%. Mind you, I am happy just to have made it this far with the software, but some issues do exist. Let's see, there is no sound at all and no sound device listed in the system. Also when playing video clips like on youtube, ect, it will only play 2 seconds of video exactly at any given time. Wired ethernet is not working, but wireless is, thank god. I'am sure the audio issue can be patched in somehow, but I have never done it, been reading up on other posts regarding it, but I cannot seem to find my exact Realtek audio ID to know which installer I need.Been messing with this install for just about two weeks and I finally got a stable install, even went in an changed the code so it doesnt load in Verbose mode every time it starts up. Oh yea, start up time is about 2-4 minutes at times, is not consistent as far as length of time, but does boot every time.


If anyone can tell my how I might fix the alc268 audio chop problem I have. I can get the alc268 driver patch to make almost everything audio work, but the sound out of the speakers and the mic is very chopped up. Funny thing is if you run you finger across the touch pad it has some effect on making the audio less chopped up. ??????

Link to comment
Share on other sites

Well I have some degree of success with the audio patching. I have used the taruga alc862installer, and the alc268installer, with both I get audio from the microphone,headphones and internal speakers but it very choppy. Funny thing is when I play an song and I move my finger accross the touchpad at the same time it almost corrects the audio chop if keep my finger moving. What gives?


Thanks for any help.




Link to comment
Share on other sites

  • 6 months later...

Ahh, I have a Extensa 4420 as well. I used the iDeneb 10.5.4 install. Someone helped me with the customization. I used AMD Patch, Modbin Kernel, VIA-SB Chipset. Clicked on all the network and audio ones. My audio works fine, my CD Drive doesn't, also both my networks don't work so it just runs. I got stuck at the Do You Already Own a Mac screen. I used the work around on the internet. So that is the full install. Much thanks to ~Eureka. I will give you a update on what all I find.

Link to comment
Share on other sites

  • 1 month later...

i have an Extensa 4420-5239, i used ideneb 1.1 for instalation, and i had partial success on my install. Graphics 1024x768, very slow, dvd/cd rom OK, no audio (same problem using the 268 patch, when i move the mouse the sounds runs up!), no wireless, no lan, so, i need some help dudes... i need at least my wifi working.


maxiboom from brazil

Link to comment
Share on other sites

i have an Extensa 4420-5239, i used ideneb 1.1 for instalation, and i had partial success on my install. Graphics 1024x768, very slow, dvd/cd rom OK, no audio (same problem using the 268 patch, when i move the mouse the sounds runs up!), no wireless, no lan, so, i need some help dudes... i need at least my wifi working.


maxiboom from brazil



I finally got mine to work with Leo4All v2 on a USB drive. I had to install only the AMD Fix. No sound, yet, but the res is 1024x768 and the wireless works. Still haveto figure out how to fix the res so i can get 1200x600 then get the sound and wired lan to work. Plus try and see how i can put it on a partition on my SATA drive and actually boot up, so I can dump the USB drive altogether.

Link to comment
Share on other sites

Well I finally got MacOSx to run on my Acer Extensa 4420 WITHOUT having it run off a USB Drive.


Things you'll need: SATA to USB Connector, Screwdriver (to remove & replace your hard drive), and a Linux OS installed (For an easy way to manipulate a few files, a LiveCD may suffice), Partitioner Program (Like Partition Magic or gparted ) Leo4All v2 DVD (Only 1 I could get to boot!)


You'll need to take your drive out and plug it into a SATA to USB connector in order to install as Leo4All DVD does not recognize the SATA.


Boot the partitioner program and make sure you create a primary fat32 partition on your drive, and alloocate at least 15gb for it.


Boot Leo4All DVD. This make take a few tries, as sometimes it boots and sometimes it doesn't. Keep rebooting and it will happen.


Remember which partition you created and use Disk Utility in setup to convert it to an UNJOURNALED HFS+ File system. You cannot modify a Journaled HFS+ File system in Linux You can always make it journaled through OSX later if you choose.


Under customize select the AMD Fix and the Good Utilities at least! I wouldn't bother with the drivers. They're useless and take up space. Language files & fonts are optional but they add an extra 1.3gbs to the install. The install is going to take about an hour so go watch some TV or play with the kids!


After it completes, reboot into your Linux distro. You need to be logged in as root, or use sudo -i for root access in Terminal in order to manipulate files in an HFS+ partition.


Download the files found in the forums below:


http://forum.insanelymac.com/index.php?showtopic=66399&st=0SB600 SATA Kext (For SATA Interface)

http://rapidshare.com/files/175319673/IOAT...y.kext.zip.htmlIOATAFamily.kext (Dramatically Increases Boot up) – Can't seem to find thread I got it from.


Open up your MacOSX install partition and maneuver to '/System/Library/Extensions".


Copy the contents of the SB600.zip first, then do the same for the IOATAFamily.kext. It will overwrite the IOATAFamily from the SATA package but thats ok. They won't conflict. Update 12/21: make sure to restore the permissions on the folders you replaced. You can use another kext folder as a guide to what the permissions should be.


Now delete ALL KEXTs referencing ATI in the beginning of the filename. They don't work and waste space.


This is the entry I have in my menu.lst for the grub bootloader. You'll need to add an entry in your bootloader, be it Vista, XP or Linux in order for you to boot OSX:


title Mac OS X 10.5 ~ Leopard

root (hd0,1)

chainloader +1


Update 12/21: Unmount the MacOSX partition before you reboot. I found that not doing it eventually corrupts the HFS+ partition. Reboot your system, choose MacOSX and boot with the -f flag at the darwin prompt (F8). This, I believe, rebuilds the Extension.kext file adding in the updated kexts and removing the ATI drivers you've deleted.


If everything goes right you should see the setup gui very soon to complete your MacOSX Setup.


NOTE: Wireless works but doesn't seem to be very stable. Audio (ALC268 driver not working right, i get noise and i can't change the volume level), LAN and PCMCIA are inoperable (I have tried a PC card fix which appears to see the PCMCIA card slot but OSX won't boot to a GUI), and I have yet to get the res fixed to accommodate the widescreen. Also there's no battery monitor so watch your time otherwise your laptop will just shut off, not shut down, which could kill your partition.


But it boot & runs!

Link to comment
Share on other sites

Hello guys!


I'm new to this forum, sorry if the answer to my question is anywhere here, but I haven't found it yet. Sorry for my bad english ... I am from Germany.


I have successfully installed OSX Leopard (iAtkos v5) on my Acer Extensa 5220 and have Video-Support (Intel x3100) and Audio-Support. Thats great, but now I have Problems with the WLAN/Airpot. I don't exactly know which HArdware is build in, the Acer-website tells me something about an "Acer InviLink" ... Does anyone has any driver to install or can tell me how I can use it?

During the installation process I checked on all network-drivers and prayed for wireless Support ... I'm just asking with the Acer, but the way I use internet is a litte bit funny:

I have a Macbook Pro and connected it with the Extensa via FireWire.


I haven't testet the LAN-port yet but I think it won't work ... edit: no, it doen't work!

Link to comment
Share on other sites

  • 3 weeks later...

Hello to all, i've been working with an acer extensa 5420 since last january

Specs Turion X2 sb600 chipset X1250 video alc268 audio broadcom 4311 wireless atheros ethernet

i posted files from an old thread that shows how to install with 10.5.1 from SkG

with the install instructions.


i would suggest that you follow any instructions to do a codec dump for audio patching.

i've had similar problems with audio on the alc268 codec patches. As my computer is a different model some fixes with audio might not be exactly the same as yours.


[How TO] Acer Aspire 5050


The 02micro pci slot was recognized along with the sb600 chipset, their is other drivers for this chipset now but i have had a hard time finding the right combination to get a disk to boot correctly.... i'm in the process of making a dfe boot 321 disk,if anyone has experience with this let me know, i could use the help, especially for the amd with sb600 chipset.



Well good luck with the installs, hope i helped out a bit.

Link to comment
Share on other sites

  • 2 months later...

OK, I have an Acer Extensa 4420-5963


My LSPCI data is as follows:

00:00.0 Host bridge [0600]: ATI Technologies Inc RS690 Host Bridge [1002:7910]

00:01.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx) [1002:7912]

00:04.0 PCI bridge [0604]: ATI Technologies Inc Unknown device [1002:7914]

00:05.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1) [1002:7915]

00:06.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2) [1002:7916]

00:12.0 IDE interface [0101]: ATI Technologies Inc SB600 Non-Raid-5 SATA [1002:4380]

00:13.0 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI0) [1002:4387]

00:13.1 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI1) [1002:4388]

00:13.2 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI2) [1002:4389]

00:13.3 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI3) [1002:438a]

00:13.4 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI4) [1002:438b]

00:13.5 USB Controller [0c03]: ATI Technologies Inc SB600 USB Controller (EHCI) [1002:4386]

00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 14)

00:14.1 IDE interface [0101]: ATI Technologies Inc SB600 IDE [1002:438c]

00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]

00:14.3 ISA bridge [0601]: ATI Technologies Inc SB600 PCI to LPC Bridge [1002:438d]

00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS690M [Radeon X1200 Series] [1002:791f]

02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8071 PCI-E Gigabit Ethernet Controller [11ab:436b] (rev 15)

05:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g [14e4:4315] (rev 01)

0b:06.0 CardBus bridge [0607]: O2 Micro, Inc. OZ711SP1 Memory CardBus Controller [1217:7136] (rev 01)

0b:06.2 SD Host controller [0805]: O2 Micro, Inc. Integrated MMC/SD Controller [1217:7120] (rev 02)

0b:06.3 Mass storage controller [0180]: O2 Micro, Inc. Integrated MS/xD Controller [1217:7130] (rev 01)

0b:06.4 FireWire (IEEE 1394) [0c00]: O2 Micro, Inc. Firewire (IEEE 1394) [1217:00f7] (rev 02)


I have installed Leo4All version 4.1 with the following drivers:

Azalia Sound

Marvell Ethernet Driver

Via/SB... Chipset Driver


I installed the Broadcom Wireless Driver from iPC 10.5.6


I could only get Leo4All to install like other people here and installing only from a USB CD-ROM Drive.


So the items that I would like to fix:

ATI X1250 is only at 1024x768 and I have not successfully gotten any options to allow me to change this. I have tried Callisto drivers including adding my PCI:ID but with no luck. I have tried adding my PCI:ID to ATIRadeonX1000 and ATIRadeonX2000 kexts. I have tried the NATIT driver but no luck there either.

Any chance I will be able to get this to 1280x800 (Laptop resolution)?


Sound is very choppy and will play better when I touch the touchpad.


About the touchpad. Sometimes I will launch an application and nothing will happen unless I move the mouse with the touchpad or press a key on the keyboard.


Sometimes when I boot my machine I can see my internal DVD-ROM drive and other times I can not.


Other then the above I have a pretty stable install of 10.5.4 from Leo4All with a few items off the iPC distro.


Last question is: Is there a way to upgrade to 10.5.6?


As you may be able to tell it is the resolution that is bugging me the most :P


Thanks for any feedback from folks with similar that have fixed their issues?



Link to comment
Share on other sites

  • 3 months later...

Well after giving up on Leo4All v2 for a while (having very little luck with anything else i've tried) i finally got around to trying iAtkos v7 on my Extensa 4420.


Much improvement on stability. Sound still choppy and of course no support for the ATI x1250 (who knows if we'll ever get it!).


Install was simple. To those who wish to try here are the options you need to check/uncheck under customize: Under x86 Patches uncheck DSDT and check the Voodoo 9.5 kernel. Under drivers check the laptop battery, ATI SATA (still buggy but works), Voodoo PS2 With Trackpad, and Broadcom BCM43xx (don't think it's needed but just in case). Everything else is fine. Should install, then reboot (use the -v option just in case) and you should be up and running.


Thus far, like i said earlier, sound works (but choppy), USB works, DVD drive works (haven't tried burning yet), wireless works, trackpad works. The apps appear to work. I haven't yet ran the post 10.5.7 updates. takes a good 10.5 GBs of space so make sure you have at least 15gb allocated.


If you're dual/triple booting good idea to have your linux liveCD, gparted live CD, and your windows vista/7 install CDs handy. I found out installing chameleon2 bootloader messed with windows 7 startup. I had to use gParted live to set partition 1 (windows) as boot, ubuntu liveCD to restore grub and my windows 7 dvd to fix windows startup. Then i needed to add OSX 10.5.7 to the grub menu list.


7/16 - also uncheck VoodooHDA driver and check the Azalia Sound drivers (didn't realize voodoohda is ONLY for Intel systems!) Sounds no longer choppy. nice & clean :lol:

Link to comment
Share on other sites


  • Create New...