Jump to content

Ethernet Problems


1 post in this topic

Recommended Posts

I tried to get ethernet working by doing the following in Terminal:


cd /System/Library/Extensions											 <-- changes directory
sudo nano IONetworking.kext/Contents/PlugIns/AppleYukon.kext/Info.plist   <-- edits file

 (find and change: <key>Yukon-88E8053</key>)
 (to:			  <key>Yukon-88E8056</key>)	   <-- change "53" to "56"

 (find and change: <string>Yukon Gigabit Adapter 88E8053</string>)
 (to:			  <string>Yukon Gigabit Adapter 88E8056</string>)	   <-- change "53" to "56"

 (find and change: <string>0x436211AB</string>)
 (to:			  <string>0x436411AB</string>)	<-- change "62" to "64"

(press Control-O)								   <-- saves changes
(press Y and Enter)								 <-- accepts saving to existing file
(press Control-X)								   <-- exits nano

sudo chown -R root:wheel IONetworkingFamily.kext	<-- repairs permissions
cd /System/Library								  <-- changes directories
sudo rm -rf Extensions.mkext Extensions.kextcache   <-- rebuilds kextcache on reboot


as suggested here

but i seem to have messed it up. when i tried to save the changes it asks for a name to save it in, then when i just hit enter i get a bus error. Is there anyway to properly fix this file now?

Link to comment
Share on other sites


  • Create New...