Jump to content

Permission problem after install or upgrade of leaopard (and the solution)


1 post in this topic

Recommended Posts

Well, it started a few weeks ago and I'm not sure what caused it. I tried playing some trailers on front row, but kept getting an error message that they cannot be played since "the format was not recognized". I also noticed that iCal kept notifying me that it found inconsistencies in my calendar that have been fixed, except it kept popping that error up and when I tried synching with my mobile phone (using iSync and a Nokia patch), it would cancel without reason (though a before this started I was able to).


of course I immediately searched to see if anyone else has encountered this problem, but it seems that other than real OS X users - no one has. I tried re-installing Leopard (kalyway 10.5.1) but got the same errors were again.


the real Apple users were complaining that after upgrade to leopard, their user would lose admin privileges. that got me thinking if something went wrong in the installation. I realized that for the first installs of leopard (which worked fine, till I f'em up trying to upgrade to 10.5.2) I selected US as country and US keyboard layout, whereas in the last two, I've selected Israel and hebrew. possibly something there went wrong - I'm not sure.


I got a hunch that there may be something wrong with the user privileges - so I tried repairing permission etc, but nothing worked. I really didn't feel like installing all over again (not knowing if choosing US would really do the trick or not), so I looked into what the apple users did. the apple users simply created a new user using the root account and granting it Admin priv. so I tried it and it DID work; this is the short way:


1. enter accounts and create a new account.

2. go to /Users/[Previous username]/, select all of the folders inside the home folder, and paste them into the new user's Home folder.

3. Open up a terminal window

4. type cd /Users

5. type chown -R "[New username]" [home folder name] and press enter

6. type chmod 744 [home folder name] and press enter

7. log into the new user, make sure everything is there and that you don't have permission problems - and then you can delete the old user and the old home folder.


and this is the long way was (or the way I did it before realizing that I could do it the short way):


1. type -s in the darwin bootloader prompt.

2. mount the disk type /sbin/mount -uw /

3. once it finishes checking the volume, type passwd

this allows you to type in a new password for the root user.

4. reboot

5. log in as root using the password you created.

6. create a new user

7. copy as described in the short way.


Hope someone finds this information usefull.

Link to comment
Share on other sites


  • Create New...