Jump to content

Networking problems Vmware and 10.4.8


3 posts in this topic

Recommended Posts

So I installed Tiger (10.4.8) on Vware Workstation 6, using Mac OS X 10.4.8 JaS AMD-Intel-SSE2-SSE3 with PPF1 & PPF2 and installed the proper AMD extensions.


Everything works fine except networking.


I have tried everything known to man to get it to work, and it still does not work.


What happens is reports a mac address of all 0's (00:00:00:00:00:00).


Now when set VMware tobridged connection and assign a manual IP address, I can ping the host computer and all other computers on the local subnet. When I look at the arp table of all the computers, there is indeed an entry for 00:00:00:00:00:00 with it's corresponding IP address. The only problem is my router can not communicate with it.


I think the issue is because it has an invalid mac address, it ignores any communication from it. My router acts as the DHCP server and will not assign an ip address to it. When I switch it to NAT, Vmware DHCP will properly give it an ip, and I can once again ping all the computers on my subnet and they can ping the virtual mac, but the router refuses to communicate with it. Which is weird because I was under the impression that once a packet is routed, mac addresses are no longer used.


I have tried to spoof/change the mac address using the following commands:


sudo ifconfig en0 ether <mac address>


and sudo ifconfig en0 lladdr <mac address>.


Yet when I check the mac address it still remains all 0's. I check it using ipconfig en0 | grep ether and in the preferences.


I have installed Maxxuss-AMDPCNET kext.



I don't know what else to try.


Any advice will be greatly appreciated.

Link to comment
Share on other sites




Anybody have any information they can share about this issue?



I have reinstalled it serveral times and get the same results.


Everything else works (including sound).


I just cannot change my mac (and I should be able to), and it refuses to talk to my router (and vice versa) but can access everything else on the local network (ping shares etc).


Any help would be appreciated.

Link to comment
Share on other sites

  • 2 weeks later...

  • Create New...