Jump to content

Weird NTFS mounting issue


1 post in this topic

Recommended Posts

I got Leopard up and running on my dv9000t CTO laptop. Got 10.5.2 installed and all updates and it's working flawlessly with only one kink. I can't get my Vista partition to mount no matter what I do. I have OSX on the secondary hard drive on my laptop, on the main drive I have three partitions. Vista (80GB), XP (10GB), and quickboot or w/e it's called (1GB). For some reason the XP partition automounts just fine, but I can't seem to mount the Vista partition no matter what I try.


When I open Disk Utility it shows the drive and three partitions. Shows disk1s1, disk1s2, and Untitled (the XP partition). When I attempt to mount disk1s1 (Vista) I get an error instantly. I have tried running chkdsk from xp disk and repairing all errors, but still no dice. I installed Parallels and tried to boot from it, but get a bluescreen. So I installed a fresh install of xp to a vmdisk and then added Bootcamp;disk1s1 as an option for another drive for parallels. I can see the Vista partition from Computer Management in the xp installed in Parallels, but it won't mount there either. I can boot into Vista just fine so I know that it's still valid and all the files work.


As a last resort I ran fdisk -e /dev/rdisk1 and then print and the results are quite odd. Shows the first partition is OS/2, hidden, second is Extended DOS, and third is <Unknown ID>. I am so confused. I remember it automounting with a network icon when I had Tiger installed previously, but not now.


Oh and I use Acronis OS Selector to boot Leopard, same as I used with Tiger. I am using EFI mbr and have vanilla kernel. Anybody at least have a suggestion as to where to start? I am completely lost.

Link to comment
Share on other sites


  • Create New...