Jump to content

[How To] Leopard on a Dell Dimension E310


9 posts in this topic

Recommended Posts

If you own this machine, Leopard will run well, though some modifications may have to be made. You will need an entire spare disk for this.




First off, I had success with BrazilMac 10.5.0. I used the DD image to install through windows, though the DVD should work. (find at torrent site, search "dd osx86" and it should come up)


I found it to be a much easier process to use the dd.exe from the Forensic Acquisition Utilities website, than the one included in the download. It's much faster, and can be downloaded here


Before the install, let me warn you that even though there are supposed patches and hacks for the integrated sound card, I never got it working. I ordered a Griffin iMic for $20 off of eBay. The integrated video card wont quite cut it either. I used a pretty low end card, but it did the job perfectly and worked out of the box. It's the nVidia FX 5500. By now you're probably wondering if it's worth the money spent. It is.


After you've waited at the door in a fetal position rocking back and forth for a week waiting for your stuff to come in, now it's the time for the install.


A quick heads up: I have hyperthreading enabled. You can enable it through your BIOS.


To install:


Copy your image file (you will need to unrar) and all of the dd files in the X86 folder in your dd zip file to the root of your windows drive. NOTE: Throughout the guide, I will represent the Windows drive as "c". If yours is another letter, replace "c" with the letter of your drive.


Some people will say that you need the WMI tools from windows to identify your drive number, but you do not. You will only need this if you have two drives of the same size. If so, download WMI tools from microsoft, open WMI object browser (in IE only), go to the system partitions.partcomponent in the left column, click go to object, and click on the associations to identify the drive to intall on. If your drives are different sizes, you can just simply open up command prompt and go into diskpart by typing "diskpart". From there type "list", then "list disk". Look for your drive and remember the number of it.


Now with all of your needed files at the root of your c drive, go into command prompt an type in: "dd if=c:\leopard-x86-flat-img of=\\.\PhysicalDrive(insert disk number here. no spaces) --localwrt"


It will hang there for a while with no indication of progress, just leave it be. And no, --progress doesn"t work with this dd.exe, but this version is about 5x faster.


When finished with the copy, download the Acronis OS Selector and install it. After the pack is installed, you will have to go to Acronis in all programs and install the OS Selector. When finished, boot up your computer. Acronis OS Selector should load, and your OSes should be listed. When booting up to osx, if it says your keyboard cannot be identified, just hit the "~" button.



That's it. Enjoy OS X. If your network card says "cable unplugged" under network settings, troubleshoot in this thread: http://forum.insanelymac.com/index.php?showtopic=25477


I will give assistance via AIM: xXmetalXcoreXx92, though forgive me if I simply say that I don't have the time. I will get back to you though.

Link to comment
Share on other sites

I have a Dimension E310 and it works fine running Kalyway Leopard 10.5.1 and it has basically the same specs as any regular E310.

300 GB SATA Maxwell 3.5" HD

2 GB Ram

Pentium 4 521 2.8 GHz CPU with SSE2 and SSE3

CD/DVD -RW Drive

SigamaTel STA9220 Audio

The same crappy Intel 128mb Graphics card

Only thing I did was burn Kalyway onto a 4.7GB DVD, popped it in, selected MBR as the bootloader, with SSE2 option checked. After that I installed the SigmaTel 9220 patch and everything was working perfectly. The network card gave me no trouble so E310 shouldn't be hard to install Leopard on.

Link to comment
Share on other sites

@ 360

what kinds of install problems are you having with kalyway? I'm trying a install on a friends E310 and once the installer finishes booting it displays the cosmic background but thats it, no english selection box or anything.


I haven't tried the SSE2 patch. But with SSE3 enabled, I hang at a blinking white underscore.

Link to comment
Share on other sites

  • 3 months later...
  • 1 year later...

i have a dell e310 with these specs


processor pentium 4 524 prescott 3.06

mother board ojc474

chipset i915p/i15g rev. B1

south bridge 82801FB(ICH6)

lpcio smsc

bios AO4

memory ddr2 dual 2gig 533 mgh

graphics GPU intel® 82915G/GV/910GL express chip rev.4




ive tried to install leopard many times different ways,i have a mbr setup and would like to know if i can do a GUID so that i can get real updates from apple???? i'm not very good at this thats why im asking for expert help. has anyone been able to get this done? ive been mainly trying 10.5.6 but havent been able to get it done. the MBR setup i have has lots of bugs.used 9200 sigmatel 4 volume and works now.is it possible to set leopard up? with full apple updates?

thanks in advance for any and all help!!!!

Link to comment
Share on other sites


  • Create New...