Jump to content

Successful install on Acer Aspire 3680 Kalyway 10.5.1


JumpZero
 Share

5 posts in this topic

Recommended Posts

Hello everybody,

 

This my story about MAC OSX install on a laptop ACER ASPIRE 3680

I used Kaliway Leopard 10.5.1

 

This post also exist in French here:

http://forum.insanelymac.com/index.php?showtopic=98365

 

For better reading the text is split according to this summary:

-1 Downloading & burning Kaliway DVD

-2 Unsuccessful install on USB hard disk

-3 Successful install on the main hard disk

-4 Post-install

-4-1 Endless welcome video loop

-4-2 Sound

-4-3 Multi boot with grub & pc-efi

-4-4 Write access to OSX partition from Linux

-4-5 French keyboard

-4-6 PCCARD/PCMCIA TI PCIxx12

-4-7 Ralink rt2500 wifi PCCard

-4-8 System time (time offset with other systems)

-5 TODO

 

 

-1 Downloading & burning Kaliway DVD

I won't tell you where to find the files, you know why... But you have to know that Kalyway has released this version in a zip file smaller than 4GB (something like 3.5GB). Then some people in the forum reported impossibility to unzip the file so Kaliway released a DVD iso image that is greater than 4GB.

I downloaded the zip file and also have problems with unzipping it with winzip and winrar (I didn't try from Linux)

I downloaded the iso image and successfully burn it.

However later I understood what I did wrong with the zip file: I tried to unzip inside a fat32 disk and fat32 maximum file size is 4GB! Error message from winzip and winrar were totally silent about this!

I think that many people reporting the problem made the same mistake.

Burning the DVD doesn't bring any comment.

 

-2 Unsuccessful install on USB hard disk

Because I boot some Linux distro from an USB memory stick formatted as an hard disk I thought my laptop was able to boot from an hard disk. I was wrong it isn't! Booting from Kalyway DVD then choosing installing on the USB was successful (big green icon at the end), but booting from the freshly installed disk was not. I tried to install a Linux Ubuntu on the USB hard disk to confirm at it was the same. This laptop can boot from a USB memory stick but not from an USB real hard disk!

 

-3 Successfull install on the main hard disk

So I prepare a 19GB logical partition to receive OS X. It was an NTFS partition, I just backup the file which were in, I didn't format it from Windows or Linux. I boot from the Kalyway DVD and follow explanation given with the DVD. I formatted the partition in an journalled extended MAC OS from within Diskutil from Kalyway. However it was quite confusing to me because before installing I read a lot about choosing mbr_boot or guid_boot according to the partition scheme you choose. Now it's clear for me that to choose a partition scheme guid or mbr is only possible when you start with a new blank disk. In my case with already two systems on the disk (Linux & WinXP) and grub on the mbr. The only possible choice was mbr_boot!

So after trying the guid-boot option and getting the red unsuccessful icon at the end I restarted the install and choose only 3 options:

boot_mbr

vanilla_kernel

acpi_ (this option is needed with the vanilla kernel according to the documentation)

And then I got the big green icon "Successfull install"

 

-4 Post-install

-4-1 Endless welcome video loop

But it wasn't straight OK. The main problem was remaining!

I successfully boot without any option -v or -s and got an Apple welcome video, after this video I was requested to choose my language, my keyboard and then to transfer information from another mac, after that I went back to the video again and again... it was and endless loop! I tried many things without success I tried the -s option at boot and went into a shell so I knew the system was working...

As usual the answer was on the forum:

The trick given by inedible did WORK (after booting in single user mode: -s ):

CODE:/sbin/fsck -fy

/sbin/mount -uw /

touch /var/db/.AppleSetupDone

passwd root

refer to this post : http://forum.insanelymac.com/index.php?sho...20&start=20

At this stage the system is working with perfect native graphic mode 1280x800 but without sound, network, pcmcia and wifi

 

-4-2 Sound

This laptop is equipped with the Realtek ALC883 chip, there are a lot of posts on the forum about it!

Taruga and his AppleHDApatcher is the guru!

I successfully installed the latest revision, with the drag and drop text from Linux but I didn't got any sound!

I tried the latest Azalia ALC883Audio.mpkg I got sound but only from outside speakers and it worked once and never worked again.

I tried the older Azalia ALC883Audio.pkg given by fayze (another Acer Aspire 3680 owner running OSX on this forum) and this one is working!

It's working only with internal speakers but it's ok for now!

this file is available with the fayze acer_3680.zip file available here

http://forum.insanelymac.com/index.php?sho...mp;#entry652230

Even if it's for Tiger it worked for my Leo!

 

-4-3 Multi boot with grub & pc_efi v8 bootloader

Before installing OSX I had grub on my mbr I am used to grub and find it very convenient!

OSX installed its own bootloader on the mbr, however this bootloader was only able to boot Win & OSX not Linux.

It wasn't a problem because I also have grub installed on a USB stick an was able to boot Linux from there.

I also had save my mbr from Linux before installing OSX:

dd if=/dev/sda of=/pathYouWant/BackupMyMbr bs=512 count=1

However after restoring my mbr it wasn't straightforward to boot OSX from grub!

Again the answer was on the forum this time given by wmarsh here:

http://forum.insanelymac.com/index.php?sho...mp;#entry606752

I also had some fine tuning to do (inactivate Windows partition) described in this post.

Now it's perfectly working even if the 5 seconds of pc_efi v8 bootloader are annoying.

 

-4-4 Write access to OSX filesystem from Linux

This is quite simple I'm running Ubuntu 7.04 Feisty Fawn (and now update to 7.10 Gutsy Gibon) and it's natively supporting OSX filesystem. However to be able to write on it it's necessary to disable the journaling. This is done from Mac OSX with Diskutil (available in Applications/Utilities). Then I updated my Linux fstab accordingly.

With other Linux distro it should be the same (HFS filesystem support is available as package deb or rpm).

 

-4-5 French keyboard

The choice is done during OSX install however to get a French PC keyboard matching the laptop I simply installed the French-WinUSB provided within the Kalyway DVD. There is also another one on the French part of the forum (sorry no link search with google).

 

-4-6 PCCARD/PCMCIA TI PCIxx12

My laptop has been purchased in Russia. For some obscure marketing reasons there is no the usual Atheros wifi chip inside. So I use a PCMCIA wifi card. So I needed to have it working. So I needed to have the PCCARD/PCMCIA TI PCIxx12 working first. Once again google search ( PCCARD/PCMCIA TI PCIxx12 site:insanelymac.com) helped me a lot. This time the guru is Chun-Nan follow this link:

http://forum.insanelymac.com/index.php?showtopic=81036

However in my case Chun-Nan latest Rev8 didn't work but I found Reptar's post here in this topic just the second post after original post in page 1.

Reptar has the same computer same kernel and reported success on January 11 (Rev3 on this date)

Then I tried Rev3 and it's OK!

Just repair the permissions after.

 

-4-7 Ralink rt2500 wifi PCCard

I use 2 wifi cards:

OLITEC based on Ralink rt2500

DLINK DWL-G630 based on Ralink RT61

I didn't found a lot of useful information on the forum but Ralink which is a nice open source supporting company provides driver for Mac here:

http://www.ralinktech.com/ralink/Home/Support/Macintosh.html

The last driver in the list is for RT2500 & RT61 for OS 10.3 & 10.4

However it works for RT2500 and Leopard 10.5. It works perfectly straight after driver installation.

It doesn't work with RT61 (Macgirl reported it's for ppc only)

There are some limitations : it appears in Mac OSX as an ethernet interface not an airport interface, but it's not really a problem.

wep keys are lower-case only!

 

-4-8 System time (time offset with other systems)

This is a very well known issue: there is a shift between Windows and OSX times because each system use the hardware clock in a different way. It's UTC time for Mac and local time for Win. Linux is more flexible you can setup the system in the 2 ways. I used the trick given somewhere on this forum:

scripts in rc.local and rc.shutdown (both files in /private/etc/ )

But it's not perfect and I don't like it because if the system crash the shutdwon script won't be run and the hardware clock will be wrong! Also I think before the startup rc.local script is run some messages are written in the logs and if the time is changed after that it should be a mess in the system logs (didn't check).

I think the Mac (and Unix) behaviour is the correct one so I'm planning to go back and clear these 2 scripts, modify my Linux time settings and use the patch for Win (even if not supported in the future, I use Win so seldom ;-)

 

-5 TODO

Have a beer!

Get the wired LAN working with the Marvell Yukon chip. Every Acer Aspire 3680 user reported no success with the Marvell Yukon kext available on the forum. Exept thepunkerguy who reported success with it. I have no time at the moment to try.

Get the battery status reported on the Desktop.

Have another beer!

 

 

If this topic can help some I would be happy to have bring back some support to the community.

 

A big thanks to Kalyway, Chun-Nan, Taruga and all the developers in the Mac OSX community.

 

known Acer Aspire 3680 users on the forum: fayze Reptar thepunkerguy Achilleus

 

--

Jmp0

Link to comment
Share on other sites

  • 1 month later...

I have this exact same laptop, the 3680-2633 (eg the circuit model). Any other advice before I burn the 10.5.2 image?

 

 

I've attached the files Kalyway DVD ReadMe.rtf and Add_kext_to_dvd_boot ReadMe.rtf. What are they talking about? I'm totally clueless.

 

 

Is magiciso safe for editing the files within the iso? I'll make a backup first, of course :rolleyes:

 

 

I found this video on youtube about getting sound working:

 

 

Here's the most results in google for this:

http://www.google.com/search?q=site%3Ainsa...+OR+aspire+3680

Kalyway_DVD_ReadMe.rtf

Add_kext_to_dvd_boot_ReadMe.rtf

Link to comment
Share on other sites

  • 3 months later...
  • 2 weeks later...
  • 2 months later...

I've been searching through this forum for a few months and finally I have successfully installed Kaly way 10.5.1 on my Acer Aspire 3680.

 

I selected these packages when installing:

- Kernel: Vanilla (I think there are only two options on Kalyway version 10.5.1 and I checked them both as recomended on the manual).

- boot_mbr.

 

I got the endless video loop when finished installing but It's solved with the welcome loop trick :unsure:

 

- Atheros Wireless: working (I found a package somewhere on this forum).

- Marvel Yukon (ethernet): working (edited Info.plist on IONetworkingFamily.kext).

- Modem (Agere): not yet

- Card Reader (Texas Instrument): not yet

- PCMCIA: detected, but have not tested yet

- Sleep: working with USBEHCI Updater.pkg

- Battery status: OK

- Audio: working with ALC883 with 6 port enabled (line in and internal microphone not worked yet).

 

I forget where I found the packages, but I have them on my HD, but it's better you search on this forum first like I did.

It seems that there's no responses to this thread any more, but I just want to share my successfull install on Acer Aspire 3680.

 

Unfortunately, I've an error when trying to update it to version 10.5.5, I downloaded it from Apple's website. But I'm satisfied with version 10.5.1 where I'm working on now :P

 

Thanks to all Mac OS X developer to make this possible :D

 

 

Network preferences screenshot:

post-306797-1228167738_thumb.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...