Jump to content

USB Devices not recognized anymore ...


3 posts in this topic

Recommended Posts

Hi there, hope anyone can help with this issue.


Since last update to 10.5.2 my USB Devices are not recognized any longer :-(

They still show up in the System-Profiler>USB with their primary device-informations, but there's no further initialization.

For instance my iPhone or USB-Cam(Harddrives) show up in SP, but no mounting or iPhone synchronize is done...


I dont quite know if VMWare-Fusion could be the problem, because i installed it in the past days.


I'm currently running 9.2.0 kernel, and also tried TOH 9.1.0

I'm booting with chain0 and also tried the new boot_efi_v8.

Tried different System.kext's and the old IOUSBMassStorageClass.kext from 9.0.0


Maybe someone knows the kext which causes these issues and you can help me to get the right kext-file.






Link to comment
Share on other sites

THANKS chinasky for the link.


Shame on my that i didnt find it while searching ;-)

With this informations i found out, that com.apple.iokit.IOUSBMassStorageClass, but ALSO com.apple.driver.AppleUSBComposite also wasnt loaded at startup.


Now it works fine again.

Link to comment
Share on other sites


  • Create New...