Jump to content

SATA DVD Writer detected not working

5 posts in this topic

Recommended Posts

I have upgraded from Jas 10.4.7 Tiger to Zephyroth Leopard 10.5.2 AMD today and by large it was smooth and successful. The only problem is with my SATA DVD Writer (samsung) TSSST Corp CDDVDW SHS203-B. It is detected along with my SATA HDD Seagate ST3808110AS and i can even open and close it from the taskbar button. But whenever I insert a DVD the light will go blinking and the HD drive light also goes flashing but the disc wont open :( . Now I hooked up an OLD LG DVD drive for installing this and that works fine. I can access the DVD Writer drive on My Vista installation ( i am dual-booting) and i can access the Windows HDD which is SATA also from my Leopard. My OSX installation is on an ancient ST320413A Seagate.


PC : Old Self Assembled

Processor : AMD 3200+ Venice OC 2400mhz


Hard Drive(s) : IDE ST320413A Seagate (LEOPARD), ST3808110AS (VISTA)

Graphics Card : XFX Gefore 6200 TC 128 MB QE and CI !

Mobo : Asus A8N VM-CSM

Sound : ADI AD 1986 A : Working no input only two channel

I Selected Nforce Drivers during install.


PS: My DVD RW was working in 10.4.7 after i downloaded the nfroce driver from the net. This is wierd because its working...just not reading...pls help

Link to comment
Share on other sites

  • 3 weeks later...

I've had the same problem - IDE DVD works fine, SATA DVD recognized but not mount the disks. Today i installed new AppleNForceATA.kext from

Leo4all v3 (thanx eddie11c) using Pacifist, and this problem is solved.

Link to comment
Share on other sites

I beleive that your problem is in the nForce drivers. Not only is my drive working (I have the same drive), I can burn dvds with it with Nero running in VMware (as well as burn dvds in Leopard). Look into updating the nForce drivers.



Link to comment
Share on other sites

  • 4 weeks later...

Hi guys, I have this drive also and am still unable to burn dvd's but it will lightscribe my discs. I have installed the latest applenforceata kext from leo4all v3 with still no joy. Any ideas?


I have an amd athlon

asus M2n4-sli MB nforce 4

Link to comment
Share on other sites


  • Create New...