Jump to content

Need help getting HFS+ partition


5 posts in this topic

Recommended Posts

Here's what I have in my computer:

Intel Q6600


Gigabyte P35-DS4

Seagate Barracuda 500GB 7200.11

Kalyway 10.5.1 DVD


For some reason, I have had the hardest time getting a HFS+ partition (which I will tell about later). Here is what I've tried so far:


1.) Disk uitility. I go to erase the partition as Mac OS Extended or whatever and it comes up with "Erase failed: Invalid Argument" or something to that effect. So I tried and erase with writing zeros over the data (as prompted by a search on google) and it still said invalid argument.


2.) diskutil in terminal. Thanks to youtube, I spent a couple hours finding the right commands. Finally I did and I had my hopes up, because from my linux training I knew that the terminal could do anything. Inconveniently, it came up with the same excuse: "Erase Failed: Invalid argument (22)". Whatever is on line 22 is breaking my balls here.


3.) Another convenient find on youtube: Parted Magic. Just like Gparted, but with HFS+ support. Good thing that it only works on a livecd/usb which after the update to 2.0 decides not to work on the Core 2 line of proccessors. Not to mention I can't find version 1.9 anywhere on the Internet.


4.) Now, after 3 stressful days of lots of waiting for the DVD to boot and trying to find a partitioner that will do HFS+, I have come to ask you. Please help me. I tried to install on Fat32, but some error came up about halfway through that I thought would be fixed with a reformat so I didn't write it down.



After this point, it is just me telling my fun adventures in great detail. It probably isn't necessary to read, but if you want to make yourself feel better, then have a lookie here.





I have gone over to this guy's house a ton of times meaning to borrow a blank DVD, and I finally do. This was Wednesday or Thursday (19th or 20th) and I burn it and wait for the Kalyway disk to load. Waited and waited. Then I waited some more. Finally, it comes up. Whoops, I forgot to move my home folder (ubuntu) into my extended partition so that I could free up a primary partition. So I get out, go to my gparted live CD and copy it over (about 3 hours for 50GB) and it was time for sleep.


The next day I wake up and format the empty space to FAT32, and the installer recognized it. I selected everything I needed from the custom install menu and clicked "Install". Estimated time: 3 hours. Goodness gracious! I go and watch a basketball game and played some video games and came back 3 hours later just to see an error message. So I say go to google and see if OS X can be installed on a FAT system, and much to my chagrin, it can't. Now starts the epic journey.


I go to disk utility and try to get it to HFS+ every way I thought possible. If I selected the disk from the menu on the left side and went to partition, then I would have to redo the whole disk, which is something I didn't want to do. If I clicked on the partition (disk0s2) and tried to erase, then I would get an error message. Back to Google. I find something that links to a youtube video that shows someone working the the terminal, which is something I'm comfortable with, so I boot back into the Kalyway disk and find the terminal. It took me about 2 hours to find out what each command was capable of, and the only one that could do what I need was eraseVolume. Easy enough, I did what it asked and it did its thing. Preparing to erase....(my heart was pounding)...Erasing disk...(YES! Oh wait, what's this?)...Immediately after it showed Erasing disk, it came up with the stupid error "Erase failed: Invalid argument (22)". Damnit! Two hours wasted. I went back to the disk utility one more time to see if I could make any magic, and I couldn't. Back to Google again.


I searched all the professional disk management tools for support of HFS+, and none of them did. But, during my search I found some open source software "Parted Magic" that boasted the support of creating HFS+ partition. *Sound heavenly trumpets*. I quickly download and burn it to a CD. I boot it up and it gets about a quarter of the way and says "Opps, couldn't find live media". It can't even spell "oops" correctly, no wonder it can't find it. I thought that I had just burned a bad CD, so I re-download and burn it again. Same thing happens. I head to the forums where I saw something about booting from USB. Good, maybe it will work on USB. So I download it and put it on the USB, rebooted, and it didn't boot to the USB. So there is a program that you have to have to make a USB bootable. I went through hell trying to get that to work, and I'm sure you don't want to hear about it. Just know that it didn't work for me. So I had the genious idea of booting from the CD, then changing the load options to do all of its stuff from the USB. Well, that effort got me further, but still no cigar. So I see that there is a source code for visparted (the partitioner used on Parted Magic) so I learn how to install stuff from source. That took about 2 hours, but I felt real satisfied when it worked. I load up visparted, and it doesn't give me the option to do HFS+, so it is no more useful than gparted.


I haven't been keeping up with the days on this, but a couple have passed and during all of that I had to burn my sister's 10 CDs and put them on her new iPod. Little to my knowlege, iPods don't like to play .flac files. So I re-encode all of her stuff and send her off. That took almost a whole day to find the right software in Windows and do that.




It would be nice to tell me that I just overlooked something simple, but if there is a whole lot of complex stuff then bring it on. The only thing that I will not do is erase my whole hard drive. If I have to do that, then I'll stick with Linux and Windows. Thanks in advance.

Link to comment
Share on other sites

Have you checked the Partition type? MBR vs GUID. Disk Utility fails on formatting HFS+ on large single-partition MBR drives. You can check it by selecting the drive in Disk Utility, going to Info and looking at "Partition Map Scheme".

Link to comment
Share on other sites

It is MBR, I just checked. It has 4 partitions: 1st (root for ubuntu) has 20GB, 2nd (which I want Leopard on) has 50 GB, 3rd (windows) has 100 GB and the 4th is an extended partition at about 125 GB. What would I have to do to make it GUID? Would the whole drive have to be GUID or could it just change the partition I want? I don't really know the difference, or even what GUID stands for/is used for. The only MBR I know of is the Master Boot Record (I think, at least). And would changing a part or the whole disk to GUID mess with GRUB?


Sorry for that being so unorganized, I just typed questions as they came to my mind. Thanks for your quick answer! You might have just figured it out.

Link to comment
Share on other sites

I've looked through google, and there isn't much information about changing from MBR to GUID because most of them tell you from having nothing on the disk. Can anyone tell me how to change from MBR to GUID? Pretty please with a cherry on top?

Link to comment
Share on other sites


  • Create New...